Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Building Controls > Custom Control and Toolbox not working

Reply
Thread Tools

Custom Control and Toolbox not working

 
 
dave
Guest
Posts: n/a
 
      03-30-2006
Yesterday i was creating custom controls and adding them to a project as a
reference. Things were great. As I created a new control it would show up
in the toolbox automatically.

Today, however none of the controls that i reference show up in the toolbox.
What is going on.

Any help would be very much appreciated.
thx
dave
 
Reply With Quote
 
 
 
 
CaffieneRush@gmail.com
Guest
Posts: n/a
 
      03-31-2006
It happened once to me when I was using VS 2003. After wasting a day
trying numerous things, I believe that the fix was to remove and add
back the reference to the web project.

It's not much to go on but I hope that helps.

Regards.

 
Reply With Quote
 
 
 
 
Wayne
Guest
Posts: n/a
 
      04-03-2006
I have had this problem several times in VS.NET 2005.

A lot of the time I just do a Clean and Rebuild (not a build) and they
will show back up. I don't have VS.NET 2005 here so the actual
verbiage may be off a little.

However, there have been times when something "minor" was wrong in the
code and they would not show up. Minor being that it's apparently not
important enough for them to show it in the Error or Warnings list.
Once I figure out what wrong it show back up, make sure to Clean and
Rebuild each time. Also keep in mind if they are all in the same
assembly it is an all or nothing thing so start the last control you
edited.

I hope this helps.

-Wayne




dave wrote:

> Yesterday i was creating custom controls and adding them to a project
> as a reference. Things were great. As I created a new control it
> would show up in the toolbox automatically.
>
> Today, however none of the controls that i reference show up in the
> toolbox. What is going on.
>
> Any help would be very much appreciated.
> thx
> dave




--

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Custom Web Control not showing up in Toolbox John Kotuby ASP .Net 5 05-11-2007 12:22 PM
Problem Getting Custom Control to show not greyed out in toolbox PeterKellner ASP .Net Building Controls 0 05-23-2006 09:44 PM
Custom control and toolbox tabs Erik Cruz ASP .Net 1 01-17-2004 07:52 PM
Cannot add custom control to toolbox - why not? James Radke ASP .Net Web Controls 6 12-23-2003 03:49 PM
ControlDesigner not invoked on custom control when control is rendered within another custom control Matt Sokol ASP .Net Building Controls 2 08-07-2003 07:13 AM



Advertisments