Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Building Controls > SelectedIndexChanged event is not fired

Reply
Thread Tools

SelectedIndexChanged event is not fired

 
 
BentleyInc
Guest
Posts: n/a
 
      12-10-2004
I've created a Web user control that contains a DropDownList and this
DropDownList gets created and loaded in init() everytime. I set
AutoPostBack=true and registered the event.

I'm using the same user control at 2 different places. When running in the
ASP.NET web form, the DropDownList is working fine and the
SelectedIndexChanged event handler does get called, but when running the
same user control in my Sharepoint Web part page, the event never gets
fired.

Has anyone out there had similar problem (not necessarily to be Sharepoint
related) that SelectedIndexChanged is not firing? Any possible reasons? It
definitely does a post back just the event is not firing.

Thanks in advance.

Jingmei Li
Bentley Systems Inc.



 
Reply With Quote
 
 
 
 
Henri
Guest
Posts: n/a
 
      12-12-2004
Please provide your code.
Difficult to help without it.

Henri

"BentleyInc" <(E-Mail Removed)> a écrit dans le message de
news:%(E-Mail Removed)...
> I've created a Web user control that contains a DropDownList and this
> DropDownList gets created and loaded in init() everytime. I set
> AutoPostBack=true and registered the event.
>
> I'm using the same user control at 2 different places. When running in the
> ASP.NET web form, the DropDownList is working fine and the
> SelectedIndexChanged event handler does get called, but when running the
> same user control in my Sharepoint Web part page, the event never gets
> fired.
>
> Has anyone out there had similar problem (not necessarily to be Sharepoint
> related) that SelectedIndexChanged is not firing? Any possible reasons? It
> definitely does a post back just the event is not firing.
>
> Thanks in advance.
>
> Jingmei Li
> Bentley Systems Inc.
>
>
>
>




 
Reply With Quote
 
 
 
 
ComSpex
Guest
Posts: n/a
 
      12-17-2004
My guess is it may be a kind of name conflict -- same id is used somewhere.

"BentleyInc" wrote:

> I've created a Web user control that contains a DropDownList and this
> DropDownList gets created and loaded in init() everytime. I set
> AutoPostBack=true and registered the event.
>
> I'm using the same user control at 2 different places. When running in the
> ASP.NET web form, the DropDownList is working fine and the
> SelectedIndexChanged event handler does get called, but when running the
> same user control in my Sharepoint Web part page, the event never gets
> fired.
>
> Has anyone out there had similar problem (not necessarily to be Sharepoint
> related) that SelectedIndexChanged is not firing? Any possible reasons? It
> definitely does a post back just the event is not firing.
>
> Thanks in advance.
>
> Jingmei Li
> Bentley Systems Inc.
>
>
>
>

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Embedded <divs> with events: How to prevent the parent div's eventfrom being fired when the embedded div's event is fired? Num GG Javascript 2 11-17-2008 08:56 PM
fired event Sorting which wasn't handled - sorting and SelectedIndexChanged Jason ASP .Net Web Controls 0 10-04-2006 02:19 PM
DropDownList SelectedIndexChanged Event not fired =?Utf-8?B?YWJvaXZpbg==?= ASP .Net 0 02-09-2005 09:17 PM
Why SelectedIndexChanged event for DropDownList sometimes did not fired or beware of the same values in VALUE property hal ASP .Net 2 09-13-2004 12:39 PM
Button.Init? how Do I know if click event has been fired? TextBox.TextChanged event before Button.Click in a CompositeCustomControl. jorge ASP .Net 2 05-25-2004 11:45 PM



Advertisments