Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Building Controls > The Register directive for the referenced assembly

Reply
Thread Tools

The Register directive for the referenced assembly

 
 
Sergey Polyakov
Guest
Posts: n/a
 
      05-24-2004
Hello everybody!

I am authoring my custom webcontrol and faced a very difficult problem. I
have two assemblies: the first one contains some base classes and the second
one contains a class which
1) Inherits a class from the first assembly
2) Contains references to the first assembly's class instances.

When I drop the control from the second assembly onto a form, it adds
references for both assemblies to the project, but it creates only one
Register directive (which defines the TagPrefix) in the aspx code. At design
time the control is displayed fine, but at run-time it throws an exception.

To solve the problem one should manually add the Register directive for the
base assembly.

Does anybody know what should I do to that the Register directives for both
assemblies were created automatically when one drops the control onto a
form?

Any help is appreciated

Thank you in advance!
Sergey


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP! - "The WSIntranet, Version=1.0.0.0, Culture=neutral, PublicKeyToken=24410d33c1a2222e assembly specified in a Register directive of this page could not be found" Mike ASP .Net Security 0 07-30-2004 02:08 PM
Problem with runtime compilation of aspx files. Register Directive ignores Assembly Dan ASP .Net 3 06-14-2004 06:13 AM
The Register directive for the referenced assembly Sergey Polyakov ASP .Net 0 05-24-2004 05:38 PM
The Register directive for the referenced assembly Sergey Polyakov ASP .Net Web Controls 0 05-24-2004 05:38 PM
The 'Location' attribute is not supported by the 'OutPutCache' directive????when i set in the directive .NET Follower ASP .Net 1 02-13-2004 10:32 AM



Advertisments