Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Building Controls > Control added programmatically not firing event

Reply
Thread Tools

Control added programmatically not firing event

 
 
Troy
Guest
Posts: n/a
 
      02-29-2004
Hi, I'm loading a usercontrol with image buttons into a panel. When clicking the buttons the click event does not fire. Any suggestions

Thanks
Tro

 
Reply With Quote
 
 
 
 
Alessandro Zifiglio
Guest
Posts: n/a
 
      03-01-2004
Provide some more details. At what stage of your pages life cycle are you
loading the controls. In what method. Are you loading the controls based on
a button click ?


"Troy" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Hi, I'm loading a usercontrol with image buttons into a panel. When

clicking the buttons the click event does not fire. Any suggestions?
>
> Thanks,
> Troy
>



 
Reply With Quote
 
 
 
 
Troy
Guest
Posts: n/a
 
      03-01-2004
Alessandro
I was loading the UserControl into a panel based on a button click. Unfortunately, this didn't work. The UserControl never showed up. The UserControl is determined by a database record and associated fields with content for that control on button click. It seems to get this to work, I have to load the sub Get_UserControl, which provides the function described earlier, during the Page_Load event of the base page. When I do this, my button click event fires. But this is wrought with all kinds of problematic behavior, having to load Get_UserControl twice, once during the Page_Load event of the base page, and again within my UserControl dynamically loaded in the panel. Any thoughts

Troy

----- Alessandro Zifiglio wrote: ----

Provide some more details. At what stage of your pages life cycle are yo
loading the controls. In what method. Are you loading the controls based o
a button click


"Troy" <(E-Mail Removed)> wrote in messag
news:(E-Mail Removed)..
> Hi, I'm loading a usercontrol with image buttons into a panel. Whe

clicking the buttons the click event does not fire. Any suggestions
>> Thanks

> Tro
>

 
Reply With Quote
 
Alessandro Zifiglio
Guest
Posts: n/a
 
      03-01-2004
see if this old post helps resolve your issue

http://groups.google.com/groups?hl=e...oogle%2BSearch

"Troy" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Alessandro,
> I was loading the UserControl into a panel based on a button click.

Unfortunately, this didn't work. The UserControl never showed up. The
UserControl is determined by a database record and associated fields with
content for that control on button click. It seems to get this to work, I
have to load the sub Get_UserControl, which provides the function described
earlier, during the Page_Load event of the base page. When I do this, my
button click event fires. But this is wrought with all kinds of problematic
behavior, having to load Get_UserControl twice, once during the Page_Load
event of the base page, and again within my UserControl dynamically loaded
in the panel. Any thoughts?
>
> Troy
>
> ----- Alessandro Zifiglio wrote: -----
>
> Provide some more details. At what stage of your pages life cycle are

you
> loading the controls. In what method. Are you loading the controls

based on
> a button click ?
>
>
> "Troy" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
> > Hi, I'm loading a usercontrol with image buttons into a panel.

When
> clicking the buttons the click event does not fire. Any suggestions?
> >> Thanks,

> > Troy
> >



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LoadViewState not firing when Control added with AddAt =?Utf-8?B?RGV2aW4gRmVuc3RlcmhlaW0=?= ASP .Net 5 11-26-2009 06:44 PM
MenuItemClick not firing if programmatically changing selected itemon a Menu Control adiel_g@hotmail.com ASP .Net Web Controls 2 07-07-2008 05:35 PM
Firefox not firing button event programmatically from JavaScript butIE and Safari do Braden.Bowers@gmail.com ASP .Net 1 01-10-2008 11:45 PM
Event not firing from dynamically added linkbutton JoakimR ASP .Net 3 01-08-2005 05:56 PM
Programmatically creating a datagrid control - Events NOT Firing!!!! Please Help KJ ASP .Net Datagrid Control 0 08-11-2003 05:20 PM



Advertisments