Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > Media in my aspx

Reply
Thread Tools

Media in my aspx

 
 
Mario
Guest
Posts: n/a
 
      05-20-2010
I need to play short movie on my aspx page (created from the master page).
In VS2008 I inserted Silverlight application project. Got
silverlightControlHost element in my TestPage. Cut and copy element in my
aspx page didn't run until I didn't changed the source, correcting the path
as it shown below.

Now I heard the sound of wmv file, but can't got the picture, although I got
it correctly on my TestPage which don't have master template.

My question is How do I got movie element on my aspx page which is created
from master ?

<asp:Content ID="Content2" ContentPlaceHolderID="ContentPlaceHolder1"
runat="server">

<div id="silverlightControlHost" style="border-style: inset;
background-color: #808080">

<object data="data:application/x-silverlight-2,"
type="application/x-silverlight-2" width="100%" height="100%">

<param name="source"
value="./ClientBin/SilverlightAplikacija.xap"/>

<param name="onError" value="onSilverlightError" />

<param name="background" value="white" />

<param name="minRuntimeVersion" value="3.0.40624.0" />

<param name="autoUpgrade" value="true" />

<a
href="http://go.microsoft.com/fwlink/?LinkID=149156&v=3.0.40624.0"
style="text-decoration:none">

<img src="http://go.microsoft.com/fwlink/?LinkId=108181"
alt="Get Microsoft Silverlight" style="border-style:none"/>

</a>

</object><iframe id="_sl_historyFrame"
style="visibility:hidden;height:0px;width:0px;bord er:0px"></iframe>

</div>

......

</asp:Content>



p.s.

MainPage.xaml looks like this:

<UserControl x:Class="SilverlightAplikacija.MainPage"

xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"

xmlns="http://schemas.microsoft.com/winfx/2006/xaml"

xmlns:d="http://schemas.microsoft.com/expression/blend/2008"
xmlns:mc="http://schemas.openxmlformats.org/markup-compatibility/2006"

mc:Ignorable="d" designWidth="640" designHeight="480">

<Grid x:Name="LayoutRoot">

<MediaElement x:Name="So32v64_56k_wmv" Margin="123,61,197,179"
Source="./Film/So32v64-56k.wmv" Stretch="Fill" AutoPlay="True"/>

</Grid>

</UserControl>

So I don't know how the <silverlightControlHost> knows that this xaml file
is what I need ?

Second thing which bother me is the Path. Source="./Film/So32v64-56k.wmv
means that folfer FILM must be in ClientBin folder of my project ???


 
Reply With Quote
 
 
 
 
Alexey Smirnov
Guest
Posts: n/a
 
      05-25-2010
On May 20, 9:22*am, "Mario" <(E-Mail Removed)> wrote:
> My question is How do I got movie element on my aspx page which is created
> from master ?
>
> <asp:Content ID="Content2" ContentPlaceHolderID="ContentPlaceHolder1"
> runat="server">
>
> * * <div id="silverlightControlHost" style="border-style: inset;
> background-color: #808080">
>
> .....
>
> </asp:Content>


From what you've posted here, I see that this code is already from the
content page, not "from master". Maybe your problem is in one of the
file paths, specified in the code. The easiest way to check it is
probably to copy silverlight app to the root directory of the website
and change all paths to "/filename..."
 
Reply With Quote
 
 
 
 
Mario
Guest
Posts: n/a
 
      05-27-2010

"Alexey Smirnov" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
On May 20, 9:22 am, "Mario" <(E-Mail Removed)> wrote:
> My question is How do I got movie element on my aspx page which is created
> from master ?
>
> <asp:Content ID="Content2" ContentPlaceHolderID="ContentPlaceHolder1"
> runat="server">
>
> <div id="silverlightControlHost" style="border-style: inset;
> background-color: #808080">
>
> .....
>
> </asp:Content>


From what you've posted here, I see that this code is already from the
content page, not "from master". Maybe your problem is in one of the
file paths, specified in the code. The easiest way to check it is
probably to copy silverlight app to the root directory of the website
and change all paths to "/filename..."

Thnx. I solved, somehow.


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
error message" media state ,media disconnected" =?Utf-8?B?YW1pdGF2YS5nYW5ndWx5QGltYXAuY2M=?= Wireless Networking 1 10-07-2006 11:41 AM
Microsoft Media Plus Digital Media Beth M. Computer Information 0 01-24-2006 06:15 PM
adding main.aspx.vb & main.aspx.resx under aspx John M ASP .Net 1 05-29-2005 09:27 PM
Memorex media problems??? Toasty media??? Chuck DVD Video 0 12-14-2004 12:21 PM
trade 64mb smart media for 16mb smart media cards wjva Digital Photography 1 08-20-2003 08:30 PM



Advertisments