Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > A question about IHTTPModule and debugging

Reply
Thread Tools

A question about IHTTPModule and debugging

 
 
Kenneth Myhra
Guest
Posts: n/a
 
      02-05-2004
Hi,

We have been trying to develop an IHTTPModule (that was supposed to replace
or take over the ISAPI Filters, as far as we know). We have developed one in
C# and it seems to be working. The problem is that it is not working as it
is supposed to work and we *need* to debug it. We made a search on MSDN
already. Either my search keywords were irrelevant (we used <IHTTPModule
debug> and <IHTTPModule debugging>, without the greater and smaller signs.
We got no relevant results).

We have a support deal with Microsoft. We would like to have support on this
issue and we would also like to have more information about how your support
deals/support contracts work (It said 5-pack support. What goes into a pack?
Also what happens after 5? Do we pay per incident? Or can we buy a 5-pack
more? A URL or document that could enlighten us about these questions would
be valuable).

To repeat our real problem: We could not manage to debug an IHTTPModule with
Just-In-Time debugging (meaning debugging from VS.NET with step into and
break points). We would like support on this issue. We can provide further
details (like we tried all 3 Isolation modes in the web application Low,
Medium, Isolated. We tried this and that etc. if you ask for details).


 
Reply With Quote
 
 
 
 
Dennis Homann
Guest
Posts: n/a
 
      02-05-2004
Hi Kenneth,

I never had problems debugging IHttpModules so far. If your breakpoint does
not work
this indicates that either the module is never loaded, the debugger is not
attached to
the application, or the code containing your breakpoint is never executed.

Make sure you have
1. configured your IHttpModule in web.config (httpModules section)
2. compiled your module in Debug mode
3. started the web app from within VS using "Debug" or attached the debugger
to the ASP.NET worker process after starting the app

Then, try to set a breakpoint in "void Init(HttpApplication context)". If it
still doesn't work, may you can give us a minimal code example of
what you're doing along with httpModules part of your web.config.

--
Dennis

"Kenneth Myhra" <(E-Mail Removed)> schrieb im Newsbeitrag
news:eQAjab$(E-Mail Removed)...
> Hi,
>
> We have been trying to develop an IHTTPModule (that was supposed to

replace
> or take over the ISAPI Filters, as far as we know). We have developed one

in
> C# and it seems to be working. The problem is that it is not working as it
> is supposed to work and we *need* to debug it. We made a search on MSDN
> already. Either my search keywords were irrelevant (we used <IHTTPModule
> debug> and <IHTTPModule debugging>, without the greater and smaller signs.
> We got no relevant results).
>
> We have a support deal with Microsoft. We would like to have support on

this
> issue and we would also like to have more information about how your

support
> deals/support contracts work (It said 5-pack support. What goes into a

pack?
> Also what happens after 5? Do we pay per incident? Or can we buy a 5-pack
> more? A URL or document that could enlighten us about these questions

would
> be valuable).
>
> To repeat our real problem: We could not manage to debug an IHTTPModule

with
> Just-In-Time debugging (meaning debugging from VS.NET with step into and
> break points). We would like support on this issue. We can provide further
> details (like we tried all 3 Isolation modes in the web application Low,
> Medium, Isolated. We tried this and that etc. if you ask for details).
>
>



 
Reply With Quote
 
 
 
 
Kenneth Myhra
Guest
Posts: n/a
 
      02-06-2004
Thanks Dennis, the problem was that I didn't manually attach to the asp .net
worker process, now it works.

-Kenneth

"Dennis Homann" <anonymous@discussions> wrote in message
news:(E-Mail Removed)...
> Hi Kenneth,
>
> I never had problems debugging IHttpModules so far. If your breakpoint

does
> not work
> this indicates that either the module is never loaded, the debugger is not
> attached to
> the application, or the code containing your breakpoint is never executed.
>
> Make sure you have
> 1. configured your IHttpModule in web.config (httpModules section)
> 2. compiled your module in Debug mode
> 3. started the web app from within VS using "Debug" or attached the

debugger
> to the ASP.NET worker process after starting the app
>
> Then, try to set a breakpoint in "void Init(HttpApplication context)". If

it
> still doesn't work, may you can give us a minimal code example of
> what you're doing along with httpModules part of your web.config.
>
> --
> Dennis
>
> "Kenneth Myhra" <(E-Mail Removed)> schrieb im Newsbeitrag
> news:eQAjab$(E-Mail Removed)...
> > Hi,
> >
> > We have been trying to develop an IHTTPModule (that was supposed to

> replace
> > or take over the ISAPI Filters, as far as we know). We have developed

one
> in
> > C# and it seems to be working. The problem is that it is not working as

it
> > is supposed to work and we *need* to debug it. We made a search on MSDN
> > already. Either my search keywords were irrelevant (we used <IHTTPModule
> > debug> and <IHTTPModule debugging>, without the greater and smaller

signs.
> > We got no relevant results).
> >
> > We have a support deal with Microsoft. We would like to have support on

> this
> > issue and we would also like to have more information about how your

> support
> > deals/support contracts work (It said 5-pack support. What goes into a

> pack?
> > Also what happens after 5? Do we pay per incident? Or can we buy a

5-pack
> > more? A URL or document that could enlighten us about these questions

> would
> > be valuable).
> >
> > To repeat our real problem: We could not manage to debug an IHTTPModule

> with
> > Just-In-Time debugging (meaning debugging from VS.NET with step into and
> > break points). We would like support on this issue. We can provide

further
> > details (like we tried all 3 Isolation modes in the web application Low,
> > Medium, Isolated. We tried this and that etc. if you ask for details).
> >
> >

>
>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
IHttpModule Question (storing state) Mike ASP .Net 4 04-04-2005 05:54 PM
IHttpHandler/IHttpModule and Session Henrik de Jong ASP .Net 1 08-24-2004 03:19 PM
Bug or security concern related to upload of binary files and IHttpModule? Kenneth Myhra ASP .Net 2 02-16-2004 01:43 PM
A question about IHttpModule and verbs Kenneth Myhra ASP .Net 2 02-10-2004 01:48 PM
http pipline, ihttpmodule and filtering responses Steven Livingstone ASP .Net 2 10-20-2003 12:25 PM



Advertisments