Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Java > Applet to run on Win 98, Win ME, Win XP, Win Vista & Win 7 ??

Reply
Thread Tools

Applet to run on Win 98, Win ME, Win XP, Win Vista & Win 7 ??

 
 
Krist
Guest
Posts: n/a
 
      05-04-2010
Hi gurus,

In our JSF/JSP application we use applet to do client side printing.
The chalenge is that the application must run on various windows
version, i.e : Win 98, Win ME, Win XP, Win Vista & Win 7.

Is there any known concern/issue on this applet portability for those
WIndows versions ?

Thank you very much,
Krist
 
Reply With Quote
 
 
 
 
Roedy Green
Guest
Posts: n/a
 
      05-04-2010
On Mon, 3 May 2010 20:54:23 -0700 (PDT), Krist <(E-Mail Removed)>
wrote, quoted or indirectly quoted someone who said :

>Is there any known concern/issue on this applet portability for those
>WIndows versions ?


The current version of Java no longer runs on Win98 and WinME.


JDK 1.5 no longer supports Win NT.

I don't know about Win2K.

The current version runs on XP, Vista and Windows 7.
--
Roedy Green Canadian Mind Products
http://mindprod.com

What is the point of a surveillance camera with insufficient resolution to identify culprits?
 
Reply With Quote
 
 
 
 
Arne Vajh°j
Guest
Posts: n/a
 
      05-04-2010
On 03-05-2010 23:54, Krist wrote:
> In our JSF/JSP application we use applet to do client side printing.
> The chalenge is that the application must run on various windows
> version, i.e : Win 98, Win ME, Win XP, Win Vista& Win 7.
>
> Is there any known concern/issue on this applet portability for those
> WIndows versions ?


Java 1.6 supports 2000, XP, 2003, Vista, 2008 and 7 per
http://java.sun.com/javase/6/webnote...gurations.html

Java 1.5 supports 98, ME, 2000, XP, 2003, Vista, 2008 and 7 per
http://java.sun.com/j2se/1.5.0/syste...gurations.html

It seems as if you are OK by targetting Java 1.5!

Arne


 
Reply With Quote
 
David Lamb
Guest
Posts: n/a
 
      05-06-2010
Arne Vajh°j wrote:
> Java 1.6 supports 2000, XP, 2003, Vista, 2008 and 7 per
> http://java.sun.com/javase/6/webnote...gurations.html
>
> Java 1.5 supports 98, ME, 2000, XP, 2003, Vista, 2008 and 7 per
> http://java.sun.com/j2se/1.5.0/syste...gurations.html
>
> It seems as if you are OK by targetting Java 1.5!


For a while -- but isn't 1.5 in end-of-life now?
 
Reply With Quote
 
Lew
Guest
Posts: n/a
 
      05-06-2010
Arne Vajh°j wrote:
>> It seems as if you are OK by targetting Java 1.5!

>


David Lamb wrote:
> For a while -- but isn't 1.5 in end-of-life now?
>


Officially, and for some time now.

In reality, it's very widespread and becoming more so as shops finally
come around to upgrading from 1.4.

Furthermore, targeting Java 5 is not the same as restricting to Java
5. You don't lose the Java 6 customers by targeting Java 5.

As to why someone now would upgrade to Java 5 from earlier versions
and not to Java 6, well, you'd have to ask them why they'd do such a
durn-fool thing.

--
Lew
No one in this world has ever lost money by underestimating the
intelligence of the great masses of the plain people.
- H. L. Mencken
 
Reply With Quote
 
Arne Vajh°j
Guest
Posts: n/a
 
      05-06-2010
On 06-05-2010 09:44, David Lamb wrote:
> Arne Vajh°j wrote:
>> Java 1.6 supports 2000, XP, 2003, Vista, 2008 and 7 per
>> http://java.sun.com/javase/6/webnote...gurations.html
>>
>> Java 1.5 supports 98, ME, 2000, XP, 2003, Vista, 2008 and 7 per
>> http://java.sun.com/j2se/1.5.0/syste...gurations.html
>>
>> It seems as if you are OK by targetting Java 1.5!

>
> For a while -- but isn't 1.5 in end-of-life now?


Yes. At least in SUN's free version.

But what so?

If you only want to users using supported versions
of Java to be able to use your applet then you can
target 1.6.

If you want more than 90% of users to be able to
use your applet then you need to target 1.5 (which
implies that it will run on 1.6 - and 1.7 when it
comes out).

Arne

 
Reply With Quote
 
Arne Vajh°j
Guest
Posts: n/a
 
      05-06-2010
On 06-05-2010 11:16, Lew wrote:
> Arne Vajh°j wrote:
>>> It seems as if you are OK by targetting Java 1.5!

>
> David Lamb wrote:
>> For a while -- but isn't 1.5 in end-of-life now?

>
> Officially, and for some time now.
>
> In reality, it's very widespread and becoming more so as shops finally
> come around to upgrading from 1.4.
>
> Furthermore, targeting Java 5 is not the same as restricting to Java
> 5. You don't lose the Java 6 customers by targeting Java 5.
>
> As to why someone now would upgrade to Java 5 from earlier versions
> and not to Java 6, well, you'd have to ask them why they'd do such a
> durn-fool thing.


On client side I think people are upgrading to latest and greatest.

Server side things are a bit more complex due to all types of
constraints about what Java EE version is certified with what
Java SE version, what Java SE version is certified with what
OS version, what app version is certified with what Java EE
version and so on.

Arne
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Vista codec packages for Vista 32 & vista 64 Kue2 Windows 64bit 0 03-05-2007 05:48 PM
Cool Applet Cool Applet http://24.60.235.213/Grid/ Alisher Fatykhov Java 1 08-06-2003 04:32 AM
Re: newbie: Join JApplet & Applet in one applet Andrew Thompson Java 0 08-05-2003 01:41 PM
Re: play wave files using java.applet.Applet webster Java 0 07-20-2003 01:51 PM
applet vs. canvas in applet Rob Love Java 1 07-07-2003 10:07 PM



Advertisments