Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > VHDL > Testing an AHB slave after synthesis

Reply
Thread Tools

Testing an AHB slave after synthesis

 
 
Ludek Ludek is offline
Junior Member
Join Date: Apr 2010
Posts: 1
 
      04-07-2010
Hi people,

I develop an AHB slave with a framework. So the slave has generally one input (ahb_slv_in_type) and one output (ahb_slv_out_type). But (as most of you know) this is a wide bus, therefore after synthesis I get lots of single signals and I cannot simulate it with the framework again. Is there any way to keep these signals in one bus as it was before synthesis? I use Synplify PRO and ModelSim but I have not found in manuals anything helpful.

Any help is very appreciated.
Thanks
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
use of Hburst signal in an AHB slave anupam.jain21@gmail.com VHDL 0 08-19-2006 05:41 AM
Summarise the points needed for AHB Slave Interface Implementation anupam.jain21@gmail.com VHDL 3 06-29-2006 11:14 AM
AHB Slave Interface SPLIT requirement anupam VHDL 2 05-31-2006 10:29 AM
AMBA AHB Slave interface questions Johnny VHDL 4 04-15-2004 05:30 PM
what are the possible reasons that successful pre-synthesis simulation + successful synthesis = failed post-synthes walala VHDL 4 09-08-2003 01:51 PM



Advertisments