Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > General Computer Discussion > General Computer Support > SQL error - invalid object

Reply
Thread Tools

SQL error - invalid object

 
 
sfalleti sfalleti is offline
Junior Member
Join Date: Feb 2010
Posts: 1
 
      02-16-2010
Hi there,

We have dataloads which are loaded from one system to another.
The script removes the load table if it exists, recreates it and then loads to it. On success it should move the file to the archive directory.

Although we can see the table successfully creates, we are getting this error. Although sometimes even after the message, the data will load successfully, other times it does not. Here is an excerpt of the messages.

extract: 39,616 Sequence : 1 Loading data to load table Command: 30 Type: SQL Syntax: BULK INSERT database>.dbo.transactions_load FROM "\\sfap02e\dataload\in\company\ready\sst_mcn.txt._ 20100216"
WITH (DATAFILETYPE = 'char',
BATCHSIZE = 10000,
CODEPAGE = 'RAW',
FIELDTERMINATOR = '~~',
ROWTERMINATOR = '0x0A',
MAXERRORS=1000000,
TABLOCK,
FIRSTROW=2)
16/02/10 09:45:02 ERROR! Extract: 39,616 Sequence: 1 Loading data to load table Command Type: SQL
Syntax: BULK INSERT f<database>.dbo.transactions_load FROM "\\sfap02e\dataload\in\company\ready\sst_mcn.txt._ 20100216"
WITH (DATAFILETYPE = 'char',
BATCHSIZE = 10000,
CODEPAGE = 'RAW',
FIELDTERMINATOR = '~~',
ROWTERMINATOR = '0x0A',
MAXERRORS=1000000,
TABLOCK,
FIRSTROW=2)
Error: Invalid object name '<database>.dbo.transactions_load'.
16/02/10 09:45:07 Extract: 39,616 Sequence : 1 Verifying rows loaded Command: 40 Type: SQL-LONG Syntax: select isnull (min (0), 1) where (select count (*) from transactions_load) = 368901 - 1


There was more...and it keeps on going after this. sometimes it fails and never works, but this morning on the third attempt the file loaded and moved to the archive directory. The problem is that this should be happening automatically by the system and should require no manual intervention. It should also not error but then go through on some occasions.

Any help would be appreciated
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do fix: "Wrong number of arguments" / "invalid propert assignment"/ "Invalid argument" Java Guy Java 1 10-15-2006 08:31 PM
Invalid URI: There is an invalid sequence in the string. Error!! Patrick.O.Ige ASP .Net 1 07-02-2006 11:21 AM
Object creation - Do we really need to create a parent for a derieved object - can't the base object just point to an already created base object jon wayne C++ 9 09-22-2005 02:06 AM
Invalid object name accessing SQL Jerry Nelson ASP .Net 2 10-16-2004 06:20 PM
invalid@invalid.org Hank Sniadoch Computer Information 1 08-20-2004 11:24 AM



Advertisments