Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > LoadPageStateFromPersistenceMedium not loading when ajax postback

Reply
Thread Tools

LoadPageStateFromPersistenceMedium not loading when ajax postback

 
 
Eric
Guest
Posts: n/a
 
      01-24-2010
This is huge issue im dealing with and it pertains only to ajax calls.
When I do ajax post call from client and page is supposed to
load viewstate with overriden LoadPageStateFromPersistenceMedium - it never fires.
Something stops it from executing. I tried registering hidden fields __VIEWSTATE etc.
Nothing worked. I know that page init manager somehow checks for viewstate but apparently
it fails. My problem would be fixed if I knew how to manually simulate LoadPageStateFromPersistenceMedium method
but it is kind of very complicated. Is there an easy elegant way to load a viewstate from saved before
using SavePageStateToPersistenceMedium viewstate? LoadViewstate is for single control and it won't work.
That would be super helpful for dealing and controling viewstates combined with ajax.
Thanks

Eric
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
AJAX Treeview How to keep expanded nodes expanded during AJAX postback ton ASP .Net 2 12-10-2008 04:11 PM
(Ajax) Loading a web service after async postback elado7@gmail.com ASP .Net 0 10-15-2007 08:56 PM
AJAX IDE and AJAX TOOL--The Release of JoyiStar AJAX WebShop 3 Beta minnie Java 1 12-13-2006 06:29 AM
Postback not being set to True on first postback =?Utf-8?B?Q2hhZA==?= ASP .Net 2 04-04-2005 06:17 PM
VIEWSTATE - LoadPageStateFromPersistenceMedium problem Dominik Lisowski ASP .Net 0 09-10-2004 08:45 AM



Advertisments