Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > Weird behaviour of SetAuthCookie, bug?

Reply
Thread Tools

Weird behaviour of SetAuthCookie, bug?

 
 
Strange Cat
Guest
Posts: n/a
 
      01-21-2004
Hi everyone!

I have a weird problem with FormsAuthentication.

I have an app that works just fine with FormsAuthentication.

The user requests the homepage, he is redirected to login page, then enters
valid username and password that are checked versus a db table, if the info
is ok i execute SetAuthCookie(xxx, False) then i open a new window which
displays the home page, all is working fine...

The problem occurs on a machine named PIPPO_PC ONLY if I login in WinXP
using user PIPPO, so the situation is:

Computer Name: PIPPO_XP
WinXP User Name: PIPPO

After logging in Windows with user name PIPPO, if I try to login on my app
after opening the new window with the home page, the LOGIN page of my app is
display instead of the home page, even though the login procedure on my APP
goes ok... now this is weird...

Looks like that ASP.NET cannot set the cookie if the computer name and user
name are similar...

Does any one have a similar problem???

Thanx in advance

ASC


 
Reply With Quote
 
 
 
 
Mohamed El Ashamwy
Guest
Posts: n/a
 
      03-01-2004
Please check the machine that have this problem to see if it accepts cookies
from your FormsAuthentication applications.
Check the Privacy tab in the Internet Options Dialog and see if cookies from
your appliaction are blocked?

You could override cookie handling for the web site containing your
application. If you need to do so, please apply the following:

In the internet options dialog, open the Privacy tab and click on the Edit
button in the Web Sites section. Write the address of your site and choose
allow to allow the site to use cookies.

Hope this solves you problem.
Regards
Mohamed El Ashmawy
MEA Developer Support Center
ITWorx on behalf of Microsoft EMEA GTSC


"Strange Cat" <(E-Mail Removed)> wrote in message
newsVrPb.122926$(E-Mail Removed)...
> Hi everyone!
>
> I have a weird problem with FormsAuthentication.
>
> I have an app that works just fine with FormsAuthentication.
>
> The user requests the homepage, he is redirected to login page, then

enters
> valid username and password that are checked versus a db table, if the

info
> is ok i execute SetAuthCookie(xxx, False) then i open a new window which
> displays the home page, all is working fine...
>
> The problem occurs on a machine named PIPPO_PC ONLY if I login in WinXP
> using user PIPPO, so the situation is:
>
> Computer Name: PIPPO_XP
> WinXP User Name: PIPPO
>
> After logging in Windows with user name PIPPO, if I try to login on my app
> after opening the new window with the home page, the LOGIN page of my app

is
> display instead of the home page, even though the login procedure on my

APP
> goes ok... now this is weird...
>
> Looks like that ASP.NET cannot set the cookie if the computer name and

user
> name are similar...
>
> Does any one have a similar problem???
>
> Thanx in advance
>
> ASC
>
>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
debugger behaviour different to execution behaviour Andy Chambers Java 1 05-14-2007 09:51 AM
Weird TextBox behaviour fd123456 ASP .Net 0 12-25-2004 01:37 PM
Weird TextBox behaviour fd123456 ASP .Net 1 12-23-2004 04:37 PM
weird user control behaviour - please help! =?Utf-8?B?RGFuIE5hc2g=?= ASP .Net 0 11-02-2004 02:42 PM
FormsAuthentication - Weird Behaviour dotCore ASP .Net 1 02-09-2004 03:52 AM



Advertisments