Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Wireless Networking > Laptop Only Uses WiFi, Refuses to Use Wired LAN When Connected

Reply
Thread Tools

Laptop Only Uses WiFi, Refuses to Use Wired LAN When Connected

 
 
M.H.
Guest
Posts: n/a
 
      07-23-2005
I have an IBM ThinkPad T42 running Windows XP SP2, and I have two
network adapters:

1. Intel PRO/1000 MT
2. Intel PRO/Wireless 2200BG

I have the adapters set to IP xxx.xxx.x.3 and xxx.xxx.x.4, respectively.
For network bindings, I have the LAN set first, then WiFi. The
problem is, when the laptop is in its dock, where it should have a wired
connection, it uses WiFi instead. If I set both adapters to the same
IP, such as IP xxx.xxx.x.3, and the laptop is in its dock, it uses the
wired network, as the WiFi connection cannot setup its IP. How can I
get Windows XP to use the wired connection when present, and only the
WiFi as a fallback? Thanks.
 
Reply With Quote
 
 
 
 
* * Chas
Guest
Posts: n/a
 
      07-23-2005

"M.H." <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
| I have an IBM ThinkPad T42 running Windows XP SP2, and I have two
| network adapters:
|
| 1. Intel PRO/1000 MT
| 2. Intel PRO/Wireless 2200BG
|
| I have the adapters set to IP xxx.xxx.x.3 and xxx.xxx.x.4,
respectively.
| For network bindings, I have the LAN set first, then WiFi. The
| problem is, when the laptop is in its dock, where it should have a
wired
| connection, it uses WiFi instead. If I set both adapters to the same
| IP, such as IP xxx.xxx.x.3, and the laptop is in its dock, it uses the
| wired network, as the WiFi connection cannot setup its IP. How can I
| get Windows XP to use the wired connection when present, and only the
| WiFi as a fallback? Thanks.

You can manually enable and disable both adapters. Also, there is a
bridge feature that should control the adapters. Right click on My
Networks (or whatever the fools in Redmond call it) desktop icon and
choose Properties. Look for the Wired, Wireless and Bridge icons and
right click on them to check their status.

Chas.


 
Reply With Quote
 
 
 
 
eM eL
Guest
Posts: n/a
 
      07-23-2005
"M.H." <(E-Mail Removed)> wrote in message news:(E-Mail Removed)...
>I have an IBM ThinkPad T42 running Windows XP SP2, and I have two network adapters:
> How can I get Windows XP to use the wired connection when present, and only the
> WiFi as a fallback? Thanks.


Use IBM Access Connections to configure your connections instead of using windows
network setup (and uncheck the "connect automatically" property for the wireless
connection.)

--
><<>><eM eL><



 
Reply With Quote
 
Clark
Guest
Posts: n/a
 
      07-23-2005
Have you tried Network Connections-Advanced-Advanced Settings . I don't
know is that will do it, but it looks promising.

Clark

"* * Chas" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
>
> "M.H." <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
> | I have an IBM ThinkPad T42 running Windows XP SP2, and I have two
> | network adapters:
> |
> | 1. Intel PRO/1000 MT
> | 2. Intel PRO/Wireless 2200BG
> |
> | I have the adapters set to IP xxx.xxx.x.3 and xxx.xxx.x.4,
> respectively.
> | For network bindings, I have the LAN set first, then WiFi. The
> | problem is, when the laptop is in its dock, where it should have a
> wired
> | connection, it uses WiFi instead. If I set both adapters to the same
> | IP, such as IP xxx.xxx.x.3, and the laptop is in its dock, it uses the
> | wired network, as the WiFi connection cannot setup its IP. How can I
> | get Windows XP to use the wired connection when present, and only the
> | WiFi as a fallback? Thanks.
>
> You can manually enable and disable both adapters. Also, there is a
> bridge feature that should control the adapters. Right click on My
> Networks (or whatever the fools in Redmond call it) desktop icon and
> choose Properties. Look for the Wired, Wireless and Bridge icons and
> right click on them to check their status.
>
> Chas.
>
>



 
Reply With Quote
 
M.H.
Guest
Posts: n/a
 
      07-23-2005
eM eL wrote:
> "M.H." <(E-Mail Removed)> wrote in message news:(E-Mail Removed)...
>
>>I have an IBM ThinkPad T42 running Windows XP SP2, and I have two network adapters:
>>How can I get Windows XP to use the wired connection when present, and only the
>>WiFi as a fallback? Thanks.

>
>
> Use IBM Access Connections to configure your connections instead of using windows
> network setup (and uncheck the "connect automatically" property for the wireless
> connection.)
>


Ok, I think using IBM Access Connections is the best solution, and what
I was using previously. However, I switched over to letting Windows
handle my connections, and I can't figure out how to re-enable IBM
Access Connections. If I double-click on the "Wireless Connection
Status" (I think this is a part of IBM Access Connections) in my system
tray, I only have three buttons, "Find WLAN," "Modify WLAN Settings"
(grayed out), and "Close." How do I wrench control of my connections
from Windows and give them back to IBM Access Connections? Thanks!
 
Reply With Quote
 
eM eL
Guest
Posts: n/a
 
      07-23-2005
"M.H." <(E-Mail Removed)> wrote in message news(E-Mail Removed)...
> How do I wrench control of my connections from Windows and give them back to IBM
> Access Connections? Thanks!




Go to Start | Network Connections
Click on the Wireless Connection and choose Properties
Go to the Advanced tab and uncheck the "Use Windows to configure my wireless network
setting" box. Click on OK.
Click once on the IBM Access Connections icon in the tray and choose Launch IBM
Access Connections.
Click on Manage profiles and go from there.
Good luck!
--
><eM eL><



 
Reply With Quote
 
M.H.
Guest
Posts: n/a
 
      07-24-2005
eM eL wrote:
> "M.H." <(E-Mail Removed)> wrote in message news(E-Mail Removed)...
>
>> How do I wrench control of my connections from Windows and give them back to IBM
>>Access Connections? Thanks!

>
>
>
>
> Go to Start | Network Connections
> Click on the Wireless Connection and choose Properties
> Go to the Advanced tab and uncheck the "Use Windows to configure my wireless network
> setting" box. Click on OK.
> Click once on the IBM Access Connections icon in the tray and choose Launch IBM
> Access Connections.
> Click on Manage profiles and go from there.
> Good luck!


Thanks, that worked! Although the "Use Windows to configure my wireless
setting box" was under the "Wireless Networks" tab, not "Advanced."
Since IBM Access Connections was handling my WiFi previously, all I had
to do was disable Windows from handling it and IBM AC took over from there.
 
Reply With Quote
 
M.H.
Guest
Posts: n/a
 
      07-24-2005
eM eL wrote:
> "M.H." <(E-Mail Removed)> wrote in message news(E-Mail Removed)...
>
>> How do I wrench control of my connections from Windows and give them back to IBM
>>Access Connections? Thanks!

>
>
>
>
> Go to Start | Network Connections
> Click on the Wireless Connection and choose Properties
> Go to the Advanced tab and uncheck the "Use Windows to configure my wireless network
> setting" box. Click on OK.
> Click once on the IBM Access Connections icon in the tray and choose Launch IBM
> Access Connections.
> Click on Manage profiles and go from there.
> Good luck!


Actually, that didn't work. Also, IBM Access Connections seems to be
for manual switching only. So I've gone back to Windows, but now I
think I have the same issue...grr...
 
Reply With Quote
 
M.H.
Guest
Posts: n/a
 
      07-24-2005
eM eL wrote:
> "M.H." <(E-Mail Removed)> wrote in message news(E-Mail Removed)...
>
>> How do I wrench control of my connections from Windows and give them back to IBM
>>Access Connections? Thanks!

>
>
>
>
> Go to Start | Network Connections
> Click on the Wireless Connection and choose Properties
> Go to the Advanced tab and uncheck the "Use Windows to configure my wireless network
> setting" box. Click on OK.
> Click once on the IBM Access Connections icon in the tray and choose Launch IBM
> Access Connections.
> Click on Manage profiles and go from there.
> Good luck!


I figured out a Windows snafu. If you have a wired and WiFi connection,
disconnect from the wired, it switches over to WiFi. Then when you
redock the laptop, it still uses the WiFi.
 
Reply With Quote
 
Guest
Posts: n/a
 
      07-24-2005
Pop a cmd box. Run

c:\>route /?

Play with the IF (interface), and possibly metric.
When you get it switching the way you want, write
it up in a pair of .cmd scripts, one to switch to
wifi, one to switch to ethernet. IFs may not be
simply 1 for wired, 2 for wifi, ... it may be 1 for
wired, 10003 for wifi, or whatever. There may be
other, easier ways.

MH- [Sun, 24 Jul 2005 17:26:29 -0400]:
>I figured out a Windows snafu. If you have a wired and WiFi connection,
>disconnect from the wired, it switches over to WiFi. Then when you
>redock the laptop, it still uses the WiFi.


--
40th Floor - Software @ http://40th.com/
iPlay : the ultimate audio player for mobiles
parametric eq, xfeed, reverb; all on a mobile
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Connection between a lan-connected pc and a wireless connected =?Utf-8?B?Q2lhY2NpaG9tZQ==?= Wireless Networking 1 08-17-2006 11:00 AM
Wireless can't see Wired, Wired Can't Access Wireless UFGrayMatter Wireless Networking 0 08-14-2006 01:26 AM
Wireless connected but don't have LAN connected Thaqalainnaqvi@gmail.com Computer Support 6 06-11-2006 09:06 PM
wireless can't access wired. But Wired can access wireless =?Utf-8?B?ZGZhdG92aWM=?= Wireless Networking 5 02-05-2005 08:07 AM
Can't connect wired linksys lan to wireless belkin lan Tom D Wireless Networking 4 01-24-2005 02:06 PM



Advertisments