Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > .net 2.0 mess

Reply
Thread Tools

.net 2.0 mess

 
 
Martins
Guest
Posts: n/a
 
      10-08-2009
I have a w2003R2 server 32bits whose .NET 2.0 is messed.

Under CPannel, add/remove/WinComponents, .NET2.0 shows as uninstalled.

I select the item, click OK, it installs but apparently nothing is
installed. Coming back to WindowsComponents it remains unckecked.

Can't also install from dornetfx.exe because it says that it can't find the
path for ...\v2.0.50727\Microsoft.Build.Framework.dll. Al that moment the
file is there, of course.

Thanks for help,
Martins
 
Reply With Quote
 
 
 
 
Alexey Smirnov
Guest
Posts: n/a
 
      10-08-2009
On Oct 8, 1:37*pm, Martins <(E-Mail Removed)> wrote:
> I have a w2003R2 server 32bits whose .NET 2.0 is messed.
>
> Under CPannel, add/remove/WinComponents, .NET2.0 shows as uninstalled.
>
> I select the item, click OK, it installs but apparently nothing is
> installed. Coming back to WindowsComponents it remains unckecked.
>
> Can't also install from dornetfx.exe because it says that it can't find the
> path for ...\v2.0.50727\Microsoft.Build.Framework.dll. Al that moment the
> file is there, of course.
>
> Thanks for help,
> Martins


Hi, Martins

please check following article

How to manually remove and then reinstall the .NET Framework 2.0
http://support.microsoft.com/kb/908077

Hope this helps
 
Reply With Quote
 
 
 
 
Martins
Guest
Posts: n/a
 
      10-08-2009


"Alexey Smirnov" wrote:

>
> please check following article
>
> How to manually remove and then reinstall the .NET Framework 2.0
> http://support.microsoft.com/kb/908077
>
> Hope this helps
>


Hi Alexey,

I've been there already.

msiexec /unregister and msiexec /regserver done

Use the Repair command on the Windows Installer cache file:
there is no installer cache file.

dotnetfx.exe /t:%temp% /c:"msiexec.exe /fvecms %temp%\netfx.msi"
says: To install this product please run Install.exe

Manually remove and then reinstall the .NET Framework 2.0
There is no URTTemp folder
There is no mscoree.dll file

The v2.0.50727 folder is in Framework folder, I deleted it.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v2.0.50727
No v2.0.50727 under NDP

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramewor k\policy\v2.0
No V2.0 under policy

Windows Installer CleanUp Utility (Msizap.exe) does not show any v2.0

Msizap TP {7131646D-CD3C-40F4-97B9-CD9E4E6262EF}
Produces lots or message lines (I can post if needed).

Content of %Temp% was deleted except for 4 files (in use).

Trying to install .net framework 2.0
... it says validating install, stopping services, Copying new files,
building executables, binding executables, writing registry values,
Installing assemblers, then: about Microsoft.Build.Framework.dll it says the
system can not find the path specified.

I'm still stuck
Martins



 
Reply With Quote
 
Alexey Smirnov
Guest
Posts: n/a
 
      10-08-2009
On Oct 8, 4:18*pm, Martins <(E-Mail Removed)> wrote:
> "Alexey Smirnov" wrote:
>
> > please check following article

>
> > How to manually remove and then reinstall the .NET Framework 2.0
> >http://support.microsoft.com/kb/908077

>
> > Hope this helps

>
> Hi Alexey,
>
> I've been there already.
>
> msiexec /unregister and msiexec /regserver done
>
> Use the Repair command on the Windows Installer cache file:
> there is no installer cache file.
>
> dotnetfx.exe /t:%temp% /c:"msiexec.exe /fvecms %temp%\netfx.msi"
> says: To install this product please run Install.exe
>
> Manually remove and then reinstall the .NET Framework 2.0
> There is no URTTemp folder
> There is no mscoree.dll file
>
> The v2.0.50727 folder is in Framework folder, I deleted it.
>
> HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v2.0.50727
> No v2.0.50727 under NDP
>
> HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramewor k\policy\v2.0
> No V2.0 under policy
>
> Windows Installer CleanUp Utility (Msizap.exe) does not show any v2.0
>
> Msizap TP {7131646D-CD3C-40F4-97B9-CD9E4E6262EF}
> Produces lots or message lines (I can post if needed).
>
> Content of %Temp% was deleted except for 4 files (in use).
>
> Trying to install .net framework 2.0
> .. it says validating install, stopping services, Copying new files,
> building executables, binding executables, writing registry values,
> Installing assemblers, then: about Microsoft.Build.Framework.dll it says the
> system can not find the path specified.
>
> I'm still stuck
> Martins


yes, it looks tricky

I suppose you have downloaded correct versions and you have admin
permissions on the server. I could only suggest to check if Windows
Installer is not "corrupted".

Dotnetfx.exe requires Windows Installer 3.0
http://www.microsoft.com/downloads/d...displaylang=en

Try to download it and install

Windows Installer 3.0
http://www.microsoft.com/downloads/d...displaylang=en

Maybe this would help to run installation properly after that...
 
Reply With Quote
 
Martins
Guest
Posts: n/a
 
      10-08-2009

Alexey,

I have admin permissions on the server.

Trying to install Windows Installer, I get:

Setup has detected that the service pack version of the system is newer than
the update you are applying. There is no need to install this update.

Could something somehow be hooked to something related to the .net 2.0 and
prevent it to be installed?

I am entering the twilight zone. This is the 3rd day of trying to solve this
problem. I could reinstall .net1.0 and 1.1 without much problems, but .net
2.0 has been quite difficult.

Thanks
Martins
 
Reply With Quote
 
Alexey Smirnov
Guest
Posts: n/a
 
      10-08-2009
On Oct 8, 5:51*pm, Martins <(E-Mail Removed)> wrote:
> Alexey,
>
> I have admin permissions on the server.
>
> Trying to install Windows Installer, I get:
>
> Setup has detected that the service pack version of the system is newer than
> the update you are applying. There is no need to install this update.
>
> Could something somehow be hooked to something related to the .net 2.0 and
> prevent it to be installed?
>
> I am entering the twilight zone. This is the 3rd day of trying to solve this
> problem. I could reinstall .net1.0 and 1.1 without much problems, but .net
> 2.0 has been quite difficult.
>
> Thanks
> Martins


I found a post referred to a problem similar to your case. Try to
follow steps 3-7 to see if it helps
http://blogs.msdn.com/astebner/archi...7/8108332.aspx

I would also recommend you to check if Windows Event Log has more
specific error message to point you in the right direction
 
Reply With Quote
 
Martins
Guest
Posts: n/a
 
      10-09-2009
>Try to follow steps 3-7 to see if it helpshttp://blogs.msdn.com/astebner/archive/2008/03/07/8108332.aspx

I've done that. The problem s that .net 2.0 is not shown as installed
anywhere.

Trying step 7, I get this funny answer:

"None of the products that are addressed by this software update are
installed on this computer.
Click Cancel to exit setup."

I tried
NDP20SP2-KB958481-x86.exe, NDP30SP2-KB958483-x86.exe and NDP35SP1-
KB958484-x86.exe and they all say the same!

CPU is Intel Core 2 duo E6750, 2.6Gig, 2GigRAM.

Thanks
Martins
 
Reply With Quote
 
Martins
Guest
Posts: n/a
 
      10-09-2009
>Try to follow steps 3-7 to see if it
helpshttp://blogs.msdn.com/astebner/archive/2008/03/07/8108332.aspx

I've done that. The problem s that .net 2.0 is not shown as installed
anywhere.

Trying step 7, I get this funny answer:

"None of the products that are addressed by this software update are
installed on this computer.
Click Cancel to exit setup."

I tried
NDP20SP2-KB958481-x86.exe, NDP30SP2-KB958483-x86.exe and NDP35SP1-
KB958484-x86.exe and they all say the same!

CPU is Intel Core 2 duo E6750, 2.6Gig, 2GigRAM.

Thanks
Martins
 
Reply With Quote
 
Martins
Guest
Posts: n/a
 
      10-09-2009
Looking after log files, I found out many many of these messages (they seem
all the same) in Application log:

The description for Event ID ( 10005 ) in Source ( MsiInstaller ) cannot be
found. The local computer may not have the necessary registry information or
message DLL files to display messages from a remote computer. You may be able
to use the /AUXSOURCE= flag to retrieve this description; see Help and
Support for details. The following information is part of the event: Product:
Microsoft .NET Framework 2.0 -- Error 25015.Failed to install assembly
'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Mic rosoft.Build.Framework.dll'
because of system error: The system cannot find the path specified.
, (NULL), (NULL), (NULL), (NULL), , .


Thanks
Martins
 
Reply With Quote
 
Alexey Smirnov
Guest
Posts: n/a
 
      10-09-2009
On Oct 9, 4:27*pm, Martins <(E-Mail Removed)> wrote:
> Looking after log files, I found out many many of these messages (they seem
> all the same) in Application log:
>
> The description for Event ID ( 10005 ) in Source ( MsiInstaller ) cannot be
> found. The local computer may not have the necessary registry information or
> message DLL files to display messages from a remote computer. You may be able
> to use the /AUXSOURCE= flag to retrieve this description; see Help and
> Support for details. The following information is part of the event: Product:
> Microsoft .NET Framework 2.0 -- Error 25015.Failed to install assembly
> 'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Mic rosoft.Build.Framework.dl*l'
> because of system error: The system cannot find the path specified.
> , (NULL), (NULL), (NULL), (NULL), , .
>
> Thanks
> Martins


Looking for "error 25015. failed to install assembly" in Google I see
many suggestions to rename or delete v2.0.50727 folder and start
installation again.

Plus I found an interesting topic on Microsoft.com site, take a look
maybe this helps

http://social.msdn.microsoft.com/For...-49016c734c4a/
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless Networking a Mess =?Utf-8?B?Q2VsZWJyaXR5WDIz?= Wireless Networking 3 05-17-2005 03:35 PM
Big Mess, what should I do? =?Utf-8?B?Q3JhaWc=?= ASP .Net 2 04-28-2005 08:20 PM
TabIndex a mess! C@rLoS ASP .Net 0 04-09-2005 09:51 AM
Authentication mess =?Utf-8?B?cmtibmFpcg==?= ASP .Net 4 01-21-2005 03:21 PM
PIX 515, DMZ, VPN, what a mess. Need Help. Eddie Cisco 9 06-20-2004 08:22 PM



Advertisments