Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Python > Re: Using select.kqueue()

Reply
Thread Tools

Re: Using select.kqueue()

 
 
Ritesh Nadhani
Guest
Posts: n/a
 
      09-03-2009
Indeed, I was facing that issue.

Appplying the patch to the select26 module now works.

Also, I had to change:

kq.control([]...)

to

kq.control(ev, ...)

Not sure what happens when you pass None as the first parameter.

On Tue, Sep 1, 2009 at 5:47 AM, <(E-Mail Removed)> wrote:
> On 07:51 am, http://www.velocityreviews.com/forums/(E-Mail Removed) wrote:
>>
>> Hi
>>
>> I am trying to use kqueue. Since, I am on v2.5, I use the baclport:
>> http://pypi.python.org/pypi/select26/0.1a3.
>>
>> Following the example at:
>> http://julipedia.blogspot.com/2004/1...of-kqueue.html (which
>> works perfectly as it tells all events), I tried to port it to Python:
>>
>> http://www.bpaste.net/show/25/
>>
>> Not sure where I am wrong but the poller only returns *one* event
>> ever. Adding new text, deleting the file does not return any event.
>>
>> What can I be doing wrong?

>
> Perhaps you are encountering http://bugs.python.org/issue5910
>
> Jean-Paul
>




--
Ritesh
http://www.riteshn.com
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Using a Link Button to redirect to another page by using data from =?Utf-8?B?R1REcml2ZXI=?= ASP .Net 1 02-16-2005 07:04 PM
Error page using the Application_Error void dosnt work when using DIV for a please wait message s_erez@hotmail.com ASP .Net 2 12-24-2004 12:11 PM
no code in webform using vs.net, but in webform using notepad timmso ASP .Net 1 12-12-2003 04:30 PM
Using GetOleDbSchemaTable to get SQL Server Field Description - using pete ASP .Net 1 08-29-2003 10:50 AM
Re: MVP? Index error on nested element using System.xml but NOT using msxml??? William F. Robertson, Jr. ASP .Net 1 06-25-2003 08:08 PM



Advertisments