Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > Could not load type 'Global.yaddayadda'. - Global.asax.cs

Reply
Thread Tools

Could not load type 'Global.yaddayadda'. - Global.asax.cs

 
 
Daniel Bass
Guest
Posts: n/a
 
      12-31-2003
Scenario (Hardware)
----------------------

I've got an engineering source server with Win 2k on it. We use it for all
the source files for our projects etc...
Let's call it "Engineering" for this scenario's sake.

Next, I have a test machine, again running Win 2k, we'll call it "Test",
that we use to drop all our compiled applications onto for testing before
release to our clients.

Finally, there's my box, (let's call it "Local") where the code is written
and compiled from (not stored though). Local is running XP Pro.

All machines have the latest patches and .Net frameworks, along with the IIS
that came with their respective platforms.


Scenario (Software)
--------------------

I'm writing an ASP.Net application with VS.Net 2003, running on Local, which
creates a project in the IIS space of Test, which has a virtual directory
pointing to code on Engineering. I didn't come up with this policy, it was
before I arrived.


The Problem
-------------

I'm getting this error when I first create and simply drop one label onto
the WebForm1.aspx.

================================================== ===================

Server Error in '/YaddaYadda' Application.
----------------------------------------------------------------------------
----

Parser Error
Description: An error occurred during the parsing of a resource required to
service this request. Please review the following specific parse error
details and modify your source file appropriately.

Parser Error Message: Could not load type 'YaddaYadda.Global'.

Source Error:


Line 1: <%@ Application Codebehind="Global.asax.cs"
Inherits="YaddaYadda.Global" %>



Source File: \\Engineering\Projects\YaddaYadda\global.asax Line: 1


----------------------------------------------------------------------------
----
Version Information: Microsoft .NET Framework Version:1.1.4322.573; ASP.NET
Version:1.1.4322.573

================================================== ========================


I've tried the "Rebuild Solutions", as well as ensuring the namespaces are
all correct, and have reboot both Test and Local to no avail.

Any ideas?

Thanks for your time.
Dan.

PS. HAPPY NEW YEAR!


 
Reply With Quote
 
 
 
 
John Ruiz
Guest
Posts: n/a
 
      12-31-2003
Daniel Bass wrote:
"I'm writing an ASP.Net application with VS.Net 2003, running on Local,
which creates a project in the IIS space of Test, which has a virtual
directory pointing to code on Engineering"
---

If you are trying to compile/run this on Local, I would bet you that your
problem is in trying to get at code that resides on Engineering.

Search the group archives for a post with the subject "Can't run ASP.NET
application on local machine with network share" from around 06/2002.


 
Reply With Quote
 
 
 
 
Daniel Bass
Guest
Posts: n/a
 
      12-31-2003
Thanks, you were right... here's the solution i found with that tip.

----------------------------------------------------------------------------
------------
When you trying to run asp.net application, IIS makes dll
assembly in the /bin directory. That assembly must be
registered in your desktop machine before you can run it.
So, run "/Administrative tools/Microsoft .NET Framework
Configuration" (\WINNT\Microsoft.NET\Framework\[version]
\mscorcfg.msc), in the "Runtime security policy->Increase
assembly trust" make full trust to
your "//notebookname/../bin/assemblyname.dll"
After that restart "w3svc" (type in dos console(cmd) [net
stop w3svc] and start [net start w3svc]) or restart
machine.
----------------------------------------------------------------------------
------------

this is stupid though, because it means that for every DLL registered off
site, you need to tell .Net that you want it to have permissions. It's a
workaround to a problem, rather than a fix.
Surely this should be apart of the project settings?

Dan.


"John Ruiz" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
Daniel Bass wrote:
"I'm writing an ASP.Net application with VS.Net 2003, running on Local,
which creates a project in the IIS space of Test, which has a virtual
directory pointing to code on Engineering"
---

If you are trying to compile/run this on Local, I would bet you that your
problem is in trying to get at code that resides on Engineering.

Search the group archives for a post with the subject "Can't run ASP.NET
application on local machine with network share" from around 06/2002.



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
could not load type "_default" M ASP .Net 1 07-24-2006 04:29 PM
Could not load type =?Utf-8?B?RGhlZXJhaiBXYWRo?= ASP .Net 2 10-26-2005 06:33 PM
Could not load type - not obvious ChrisC ASP .Net 8 05-12-2005 01:20 PM
Could not load type Neil Ramsbottom ASP .Net 2 07-30-2003 05:23 AM
could not load type global bob ASP .Net 1 07-02-2003 04:18 AM



Advertisments