Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP.NET process identity does not have read permissions to the global assembly cache

Reply
Thread Tools

ASP.NET process identity does not have read permissions to the global assembly cache

 
 
JerryW
Guest
Posts: n/a
 
      12-29-2003
I just reinstalled .NET 2003 (after repeated attempts to get ASP.NET
Web Applications to work). I first did a complete uninstall of .NET
2003, .NET Framework 1.1, and IIS. I also completely deleted
c:\inetpub\wwwroot and rebooted before reinstalling.

I created a new virtual directory from within IIS (e.g. MyWebTest).
Then I tried to create a new Visual C# ASP.NET Web Application
pointing to the location http://localhost/MyWebTest. I get an error:

"The Web server reported the following error when attempting to create
or open the Web project located at the following URL:
'http://localhost/MyWebTest'. 'HTTP/1.1 500 Internal Server Error'.

The Event log has:

Failed to execute the request because the ASP.NET process identity
does not have read permissions to the global assembly cache. Error:
0x8013141a

I could not see a way to change the permissions on the GAC folder
(C:\Windows\assembly). As a test, I gave the ASPNET user Administrator
privileges. That did not work - got the same error.

Can anyone help me fix this? - Thanks
 
Reply With Quote
 
 
 
 
Jim Cheshire [MSFT]
Guest
Posts: n/a
 
      12-29-2003
Hi Jerry,

If you unregister fusion.dll from a command prompt, you will be able to see
the permissions on the GAC.

Jim Cheshire, MCSE, MCSD [MSFT]
ASP.NET Developer Support

This post is provided "as-is" and infers no rights.

--------------------
>From: http://www.velocityreviews.com/forums/(E-Mail Removed) (JerryW)
>Newsgroups: microsoft.public.dotnet.framework.aspnet
>Subject: ASP.NET process identity does not have read permissions to the

global assembly cache
>Date: 29 Dec 2003 08:31:46 -0800
>Organization: http://groups.google.com
>Lines: 24
>Message-ID: <(E-Mail Removed) >
>NNTP-Posting-Host: 24.91.252.243
>Content-Type: text/plain; charset=ISO-8859-1
>Content-Transfer-Encoding: 8bit
>X-Trace: posting.google.com 1072715506 4325 127.0.0.1 (29 Dec 2003

16:31:46 GMT)
>X-Complaints-To: (E-Mail Removed)
>NNTP-Posting-Date: Mon, 29 Dec 2003 16:31:46 +0000 (UTC)
>Path:

cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!TK2MSFTN GP08.phx.gbl!newsfeed00.su
l.t-online.de!t-online.de!130.59.10.21.MISMATCH!irazu.switch.ch!sw itch.ch!ne
ws.maxwell.syr.edu!postnews1.google.com!not-for-mail
>Xref: cpmsftngxa07.phx.gbl microsoft.public.dotnet.framework.aspnet:198618
>X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
>
>I just reinstalled .NET 2003 (after repeated attempts to get ASP.NET
>Web Applications to work). I first did a complete uninstall of .NET
>2003, .NET Framework 1.1, and IIS. I also completely deleted
>c:\inetpub\wwwroot and rebooted before reinstalling.
>
>I created a new virtual directory from within IIS (e.g. MyWebTest).
>Then I tried to create a new Visual C# ASP.NET Web Application
>pointing to the location http://localhost/MyWebTest. I get an error:
>
>"The Web server reported the following error when attempting to create
>or open the Web project located at the following URL:
>'http://localhost/MyWebTest'. 'HTTP/1.1 500 Internal Server Error'.
>
>The Event log has:
>
>Failed to execute the request because the ASP.NET process identity
>does not have read permissions to the global assembly cache. Error:
>0x8013141a
>
>I could not see a way to change the permissions on the GAC folder
>(C:\Windows\assembly). As a test, I gave the ASPNET user Administrator
>privileges. That did not work - got the same error.
>
>Can anyone help me fix this? - Thanks
>


 
Reply With Quote
 
 
 
 
JerryW
Guest
Posts: n/a
 
      12-30-2003
Thanks Jim. How do you actually see/change permissions on the GAC? I
was trying to do this with Windows Explorer (Properties-Security and
see no Security tab).

Jerry


(E-Mail Removed) (Jim Cheshire [MSFT]) wrote in message news:<$(E-Mail Removed)>...
> Hi Jerry,
>
> If you unregister fusion.dll from a command prompt, you will be able to see
> the permissions on the GAC.
>
> Jim Cheshire, MCSE, MCSD [MSFT]
> ASP.NET Developer Support
>
> This post is provided "as-is" and infers no rights.
>
> --------------------
> >From: (E-Mail Removed) (JerryW)
> >Newsgroups: microsoft.public.dotnet.framework.aspnet
> >Subject: ASP.NET process identity does not have read permissions to the

> global assembly cache
> >Date: 29 Dec 2003 08:31:46 -0800
> >Organization: http://groups.google.com
> >Lines: 24
> >Message-ID: <(E-Mail Removed) >
> >NNTP-Posting-Host: 24.91.252.243
> >Content-Type: text/plain; charset=ISO-8859-1
> >Content-Transfer-Encoding: 8bit
> >X-Trace: posting.google.com 1072715506 4325 127.0.0.1 (29 Dec 2003

> 16:31:46 GMT)
> >X-Complaints-To: (E-Mail Removed)
> >NNTP-Posting-Date: Mon, 29 Dec 2003 16:31:46 +0000 (UTC)
> >Path:

> cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!TK2MSFTN GP08.phx.gbl!newsfeed00.su
> l.t-online.de!t-online.de!130.59.10.21.MISMATCH!irazu.switch.ch!sw itch.ch!ne
> ws.maxwell.syr.edu!postnews1.google.com!not-for-mail
> >Xref: cpmsftngxa07.phx.gbl microsoft.public.dotnet.framework.aspnet:198618
> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
> >
> >I just reinstalled .NET 2003 (after repeated attempts to get ASP.NET
> >Web Applications to work). I first did a complete uninstall of .NET
> >2003, .NET Framework 1.1, and IIS. I also completely deleted
> >c:\inetpub\wwwroot and rebooted before reinstalling.
> >
> >I created a new virtual directory from within IIS (e.g. MyWebTest).
> >Then I tried to create a new Visual C# ASP.NET Web Application
> >pointing to the location http://localhost/MyWebTest. I get an error:
> >
> >"The Web server reported the following error when attempting to create
> >or open the Web project located at the following URL:
> >'http://localhost/MyWebTest'. 'HTTP/1.1 500 Internal Server Error'.
> >
> >The Event log has:
> >
> >Failed to execute the request because the ASP.NET process identity
> >does not have read permissions to the global assembly cache. Error:
> >0x8013141a
> >
> >I could not see a way to change the permissions on the GAC folder
> >(C:\Windows\assembly). As a test, I gave the ASPNET user Administrator
> >privileges. That did not work - got the same error.
> >
> >Can anyone help me fix this? - Thanks
> >

 
Reply With Quote
 
Jim Cheshire [MSFT]
Guest
Posts: n/a
 
      12-30-2003
Jerry,

You have to unregister fusion.dll first.

Jim Cheshire, MCSE, MCSD [MSFT]
ASP.NET Developer Support

This post is provided "as-is" and infers no rights.

--------------------
>From: (E-Mail Removed) (JerryW)
>Newsgroups: microsoft.public.dotnet.framework.aspnet
>Subject: Re: ASP.NET process identity does not have read permissions to

the global assembly cache
>Date: 30 Dec 2003 04:58:12 -0800
>Organization: http://groups.google.com
>Lines: 66
>Message-ID: <(E-Mail Removed) >
>References: <(E-Mail Removed) >

<$(E-Mail Removed)>
>NNTP-Posting-Host: 24.91.252.243
>Content-Type: text/plain; charset=ISO-8859-1
>Content-Transfer-Encoding: 8bit
>X-Trace: posting.google.com 1072789092 20099 127.0.0.1 (30 Dec 2003

12:58:12 GMT)
>X-Complaints-To: (E-Mail Removed)
>NNTP-Posting-Date: Tue, 30 Dec 2003 12:58:12 +0000 (UTC)
>Path:

cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!cpmsftng xa09.phx.gbl!TK2MSFTNGP08.
phx.gbl!newsfeed00.sul.t-online.de!t-online.de!newsfeed.icl.net!newsfeed.fjs
erv.net!proxad.net!news-out.visi.com!hermes.visi.com!newsfeed2.dallas1.lev el
3.net!news.level3.com!postnews1.google.com!not-for-mail
>Xref: cpmsftngxa07.phx.gbl microsoft.public.dotnet.framework.aspnet:198826
>X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
>
>Thanks Jim. How do you actually see/change permissions on the GAC? I
>was trying to do this with Windows Explorer (Properties-Security and
>see no Security tab).
>
>Jerry
>
>
>(E-Mail Removed) (Jim Cheshire [MSFT]) wrote in message

news:<$(E-Mail Removed)>...
>> Hi Jerry,
>>
>> If you unregister fusion.dll from a command prompt, you will be able to

see
>> the permissions on the GAC.
>>
>> Jim Cheshire, MCSE, MCSD [MSFT]
>> ASP.NET Developer Support
>>
>> This post is provided "as-is" and infers no rights.
>>
>> --------------------
>> >From: (E-Mail Removed) (JerryW)
>> >Newsgroups: microsoft.public.dotnet.framework.aspnet
>> >Subject: ASP.NET process identity does not have read permissions to the

>> global assembly cache
>> >Date: 29 Dec 2003 08:31:46 -0800
>> >Organization: http://groups.google.com
>> >Lines: 24
>> >Message-ID: <(E-Mail Removed) >
>> >NNTP-Posting-Host: 24.91.252.243
>> >Content-Type: text/plain; charset=ISO-8859-1
>> >Content-Transfer-Encoding: 8bit
>> >X-Trace: posting.google.com 1072715506 4325 127.0.0.1 (29 Dec 2003

>> 16:31:46 GMT)
>> >X-Complaints-To: (E-Mail Removed)
>> >NNTP-Posting-Date: Mon, 29 Dec 2003 16:31:46 +0000 (UTC)
>> >Path:

>>

cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!TK2MSFTN GP08.phx.gbl!newsfeed00.su
>>

l.t-online.de!t-online.de!130.59.10.21.MISMATCH!irazu.switch.ch!sw itch.ch!ne
>> ws.maxwell.syr.edu!postnews1.google.com!not-for-mail
>> >Xref: cpmsftngxa07.phx.gbl

microsoft.public.dotnet.framework.aspnet:198618
>> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
>> >
>> >I just reinstalled .NET 2003 (after repeated attempts to get ASP.NET
>> >Web Applications to work). I first did a complete uninstall of .NET
>> >2003, .NET Framework 1.1, and IIS. I also completely deleted
>> >c:\inetpub\wwwroot and rebooted before reinstalling.
>> >
>> >I created a new virtual directory from within IIS (e.g. MyWebTest).
>> >Then I tried to create a new Visual C# ASP.NET Web Application
>> >pointing to the location http://localhost/MyWebTest. I get an error:
>> >
>> >"The Web server reported the following error when attempting to create
>> >or open the Web project located at the following URL:
>> >'http://localhost/MyWebTest'. 'HTTP/1.1 500 Internal Server Error'.
>> >
>> >The Event log has:
>> >
>> >Failed to execute the request because the ASP.NET process identity
>> >does not have read permissions to the global assembly cache. Error:
>> >0x8013141a
>> >
>> >I could not see a way to change the permissions on the GAC folder
>> >(C:\Windows\assembly). As a test, I gave the ASPNET user Administrator
>> >privileges. That did not work - got the same error.
>> >
>> >Can anyone help me fix this? - Thanks
>> >

>


 
Reply With Quote
 
JerryW
Guest
Posts: n/a
 
      12-30-2003
Sorry, didn't say - I did unregister fusion.dll first. In Windows
Explorer I then right-mouse-click on C:\Windows\assembly and select
Properties. The dialog has only a General tab - nothing else. I am
running Windows XP Prof and am logged in as a user with Administrator
privileges.

JerryW

(E-Mail Removed) (Jim Cheshire [MSFT]) wrote in message news:<(E-Mail Removed)>...
> Jerry,
>
> You have to unregister fusion.dll first.
>
> Jim Cheshire, MCSE, MCSD [MSFT]
> ASP.NET Developer Support
>
> This post is provided "as-is" and infers no rights.
>
> --------------------
> >From: (E-Mail Removed) (JerryW)
> >Newsgroups: microsoft.public.dotnet.framework.aspnet
> >Subject: Re: ASP.NET process identity does not have read permissions to

> the global assembly cache
> >Date: 30 Dec 2003 04:58:12 -0800
> >Organization: http://groups.google.com
> >Lines: 66
> >Message-ID: <(E-Mail Removed) >
> >References: <(E-Mail Removed) >

> <$(E-Mail Removed)>
> >NNTP-Posting-Host: 24.91.252.243
> >Content-Type: text/plain; charset=ISO-8859-1
> >Content-Transfer-Encoding: 8bit
> >X-Trace: posting.google.com 1072789092 20099 127.0.0.1 (30 Dec 2003

> 12:58:12 GMT)
> >X-Complaints-To: (E-Mail Removed)
> >NNTP-Posting-Date: Tue, 30 Dec 2003 12:58:12 +0000 (UTC)
> >Path:

> cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!cpmsftng xa09.phx.gbl!TK2MSFTNGP08.
> phx.gbl!newsfeed00.sul.t-online.de!t-online.de!newsfeed.icl.net!newsfeed.fjs
> erv.net!proxad.net!news-out.visi.com!hermes.visi.com!newsfeed2.dallas1.lev el
> 3.net!news.level3.com!postnews1.google.com!not-for-mail
> >Xref: cpmsftngxa07.phx.gbl microsoft.public.dotnet.framework.aspnet:198826
> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
> >
> >Thanks Jim. How do you actually see/change permissions on the GAC? I
> >was trying to do this with Windows Explorer (Properties-Security and
> >see no Security tab).
> >
> >Jerry
> >
> >
> >(E-Mail Removed) (Jim Cheshire [MSFT]) wrote in message

> news:<$(E-Mail Removed)>...
> >> Hi Jerry,
> >>
> >> If you unregister fusion.dll from a command prompt, you will be able to

> see
> >> the permissions on the GAC.
> >>
> >> Jim Cheshire, MCSE, MCSD [MSFT]
> >> ASP.NET Developer Support
> >>
> >> This post is provided "as-is" and infers no rights.
> >>
> >> --------------------
> >> >From: (E-Mail Removed) (JerryW)
> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
> >> >Subject: ASP.NET process identity does not have read permissions to the

> global assembly cache
> >> >Date: 29 Dec 2003 08:31:46 -0800
> >> >Organization: http://groups.google.com
> >> >Lines: 24
> >> >Message-ID: <(E-Mail Removed) >
> >> >NNTP-Posting-Host: 24.91.252.243
> >> >Content-Type: text/plain; charset=ISO-8859-1
> >> >Content-Transfer-Encoding: 8bit
> >> >X-Trace: posting.google.com 1072715506 4325 127.0.0.1 (29 Dec 2003

> 16:31:46 GMT)
> >> >X-Complaints-To: (E-Mail Removed)
> >> >NNTP-Posting-Date: Mon, 29 Dec 2003 16:31:46 +0000 (UTC)
> >> >Path:
> >>

> cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!TK2MSFTN GP08.phx.gbl!newsfeed00.su
> >>

> l.t-online.de!t-online.de!130.59.10.21.MISMATCH!irazu.switch.ch!sw itch.ch!ne
> >> ws.maxwell.syr.edu!postnews1.google.com!not-for-mail
> >> >Xref: cpmsftngxa07.phx.gbl

> microsoft.public.dotnet.framework.aspnet:198618
> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
> >> >
> >> >I just reinstalled .NET 2003 (after repeated attempts to get ASP.NET
> >> >Web Applications to work). I first did a complete uninstall of .NET
> >> >2003, .NET Framework 1.1, and IIS. I also completely deleted
> >> >c:\inetpub\wwwroot and rebooted before reinstalling.
> >> >
> >> >I created a new virtual directory from within IIS (e.g. MyWebTest).
> >> >Then I tried to create a new Visual C# ASP.NET Web Application
> >> >pointing to the location http://localhost/MyWebTest. I get an error:
> >> >
> >> >"The Web server reported the following error when attempting to create
> >> >or open the Web project located at the following URL:
> >> >'http://localhost/MyWebTest'. 'HTTP/1.1 500 Internal Server Error'.
> >> >
> >> >The Event log has:
> >> >
> >> >Failed to execute the request because the ASP.NET process identity
> >> >does not have read permissions to the global assembly cache. Error:
> >> >0x8013141a
> >> >
> >> >I could not see a way to change the permissions on the GAC folder
> >> >(C:\Windows\assembly). As a test, I gave the ASPNET user Administrator
> >> >privileges. That did not work - got the same error.
> >> >
> >> >Can anyone help me fix this? - Thanks
> >> >

> >

 
Reply With Quote
 
Jim Cheshire [MSFT]
Guest
Posts: n/a
 
      12-30-2003
Jerry,

Are you running on an NTFS partition? Do you have Simple File Sharing
enabled?

Jim Cheshire, MCSE, MCSD [MSFT]
Microsoft Developer Support
ASP.NET
(E-Mail Removed)

This post is provided as-is with no warranties and confers no rights.


--------------------
>From: (E-Mail Removed) (JerryW)
>Newsgroups: microsoft.public.dotnet.framework.aspnet
>Subject: Re: ASP.NET process identity does not have read permissions to

the global assembly cache
>Date: 30 Dec 2003 10:35:48 -0800
>Organization: http://groups.google.com
>Lines: 116
>Message-ID: <(E-Mail Removed) >
>References: <(E-Mail Removed) >

<$(E-Mail Removed)>
<(E-Mail Removed) >
<(E-Mail Removed)>
>NNTP-Posting-Host: 24.91.252.243
>Content-Type: text/plain; charset=ISO-8859-1
>Content-Transfer-Encoding: 8bit
>X-Trace: posting.google.com 1072809348 11095 127.0.0.1 (30 Dec 2003

18:35:48 GMT)
>X-Complaints-To: (E-Mail Removed)
>NNTP-Posting-Date: Tue, 30 Dec 2003 18:35:48 +0000 (UTC)
>Path:

cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!cpmsftng xa09.phx.gbl!TK2MSFTNGP08.
phx.gbl!newsfeed00.sul.t-online.de!newsfeed01.sul.t-online.de!t-online.de!fu
-berlin.de!postnews1.google.com!not-for-mail
>Xref: cpmsftngxa07.phx.gbl microsoft.public.dotnet.framework.aspnet:198920
>X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
>
>Sorry, didn't say - I did unregister fusion.dll first. In Windows
>Explorer I then right-mouse-click on C:\Windows\assembly and select
>Properties. The dialog has only a General tab - nothing else. I am
>running Windows XP Prof and am logged in as a user with Administrator
>privileges.
>
>JerryW
>
>(E-Mail Removed) (Jim Cheshire [MSFT]) wrote in message

news:<(E-Mail Removed)>...
>> Jerry,
>>
>> You have to unregister fusion.dll first.
>>
>> Jim Cheshire, MCSE, MCSD [MSFT]
>> ASP.NET Developer Support
>>
>> This post is provided "as-is" and infers no rights.
>>
>> --------------------
>> >From: (E-Mail Removed) (JerryW)
>> >Newsgroups: microsoft.public.dotnet.framework.aspnet
>> >Subject: Re: ASP.NET process identity does not have read permissions to

>> the global assembly cache
>> >Date: 30 Dec 2003 04:58:12 -0800
>> >Organization: http://groups.google.com
>> >Lines: 66
>> >Message-ID: <(E-Mail Removed) >
>> >References: <(E-Mail Removed) >

>> <$(E-Mail Removed)>
>> >NNTP-Posting-Host: 24.91.252.243
>> >Content-Type: text/plain; charset=ISO-8859-1
>> >Content-Transfer-Encoding: 8bit
>> >X-Trace: posting.google.com 1072789092 20099 127.0.0.1 (30 Dec 2003

>> 12:58:12 GMT)
>> >X-Complaints-To: (E-Mail Removed)
>> >NNTP-Posting-Date: Tue, 30 Dec 2003 12:58:12 +0000 (UTC)
>> >Path:

>>

cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!cpmsftng xa09.phx.gbl!TK2MSFTNGP08.
>>

phx.gbl!newsfeed00.sul.t-online.de!t-online.de!newsfeed.icl.net!newsfeed.fjs
>>

erv.net!proxad.net!news-out.visi.com!hermes.visi.com!newsfeed2.dallas1.lev el
>> 3.net!news.level3.com!postnews1.google.com!not-for-mail
>> >Xref: cpmsftngxa07.phx.gbl

microsoft.public.dotnet.framework.aspnet:198826
>> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
>> >
>> >Thanks Jim. How do you actually see/change permissions on the GAC? I
>> >was trying to do this with Windows Explorer (Properties-Security and
>> >see no Security tab).
>> >
>> >Jerry
>> >
>> >
>> >(E-Mail Removed) (Jim Cheshire [MSFT]) wrote in message

>> news:<$(E-Mail Removed)>...
>> >> Hi Jerry,
>> >>
>> >> If you unregister fusion.dll from a command prompt, you will be able

to
>> see
>> >> the permissions on the GAC.
>> >>
>> >> Jim Cheshire, MCSE, MCSD [MSFT]
>> >> ASP.NET Developer Support
>> >>
>> >> This post is provided "as-is" and infers no rights.
>> >>
>> >> --------------------
>> >> >From: (E-Mail Removed) (JerryW)
>> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
>> >> >Subject: ASP.NET process identity does not have read permissions to

the
>> global assembly cache
>> >> >Date: 29 Dec 2003 08:31:46 -0800
>> >> >Organization: http://groups.google.com
>> >> >Lines: 24
>> >> >Message-ID: <(E-Mail Removed) >
>> >> >NNTP-Posting-Host: 24.91.252.243
>> >> >Content-Type: text/plain; charset=ISO-8859-1
>> >> >Content-Transfer-Encoding: 8bit
>> >> >X-Trace: posting.google.com 1072715506 4325 127.0.0.1 (29 Dec 2003

>> 16:31:46 GMT)
>> >> >X-Complaints-To: (E-Mail Removed)
>> >> >NNTP-Posting-Date: Mon, 29 Dec 2003 16:31:46 +0000 (UTC)
>> >> >Path:
>> >>

>>

cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!TK2MSFTN GP08.phx.gbl!newsfeed00.su
>> >>

>>

l.t-online.de!t-online.de!130.59.10.21.MISMATCH!irazu.switch.ch!sw itch.ch!ne
>> >> ws.maxwell.syr.edu!postnews1.google.com!not-for-mail
>> >> >Xref: cpmsftngxa07.phx.gbl

>> microsoft.public.dotnet.framework.aspnet:198618
>> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
>> >> >
>> >> >I just reinstalled .NET 2003 (after repeated attempts to get ASP.NET
>> >> >Web Applications to work). I first did a complete uninstall of .NET
>> >> >2003, .NET Framework 1.1, and IIS. I also completely deleted
>> >> >c:\inetpub\wwwroot and rebooted before reinstalling.
>> >> >
>> >> >I created a new virtual directory from within IIS (e.g. MyWebTest).
>> >> >Then I tried to create a new Visual C# ASP.NET Web Application
>> >> >pointing to the location http://localhost/MyWebTest. I get an error:
>> >> >
>> >> >"The Web server reported the following error when attempting to

create
>> >> >or open the Web project located at the following URL:
>> >> >'http://localhost/MyWebTest'. 'HTTP/1.1 500 Internal Server Error'.
>> >> >
>> >> >The Event log has:
>> >> >
>> >> >Failed to execute the request because the ASP.NET process identity
>> >> >does not have read permissions to the global assembly cache. Error:
>> >> >0x8013141a
>> >> >
>> >> >I could not see a way to change the permissions on the GAC folder
>> >> >(C:\Windows\assembly). As a test, I gave the ASPNET user

Administrator
>> >> >privileges. That did not work - got the same error.
>> >> >
>> >> >Can anyone help me fix this? - Thanks
>> >> >
>> >

>


 
Reply With Quote
 
JerryW
Guest
Posts: n/a
 
      12-31-2003
Thanks Jim. I am running on an NTFS partition. I did not have Simple
File Sharing enabled. After enabling Simple File Sharing I did not see
any difference in the Windows Explorer Properties. What does Simple
File Sharing have to do with this or my original problem? Please
explain.

JerryW

(E-Mail Removed) (Jim Cheshire [MSFT]) wrote in message news:<8a#(E-Mail Removed)>...
> Jerry,
>
> Are you running on an NTFS partition? Do you have Simple File Sharing
> enabled?
>
> Jim Cheshire, MCSE, MCSD [MSFT]
> Microsoft Developer Support
> ASP.NET
> (E-Mail Removed)
>
> This post is provided as-is with no warranties and confers no rights.
>
>
> --------------------
> >From: (E-Mail Removed) (JerryW)
> >Newsgroups: microsoft.public.dotnet.framework.aspnet
> >Subject: Re: ASP.NET process identity does not have read permissions to

> the global assembly cache
> >Date: 30 Dec 2003 10:35:48 -0800
> >Organization: http://groups.google.com
> >Lines: 116
> >Message-ID: <(E-Mail Removed) >
> >References: <(E-Mail Removed) >

> <$(E-Mail Removed)>
> <(E-Mail Removed) >
> <(E-Mail Removed)>
> >NNTP-Posting-Host: 24.91.252.243
> >Content-Type: text/plain; charset=ISO-8859-1
> >Content-Transfer-Encoding: 8bit
> >X-Trace: posting.google.com 1072809348 11095 127.0.0.1 (30 Dec 2003

> 18:35:48 GMT)
> >X-Complaints-To: (E-Mail Removed)
> >NNTP-Posting-Date: Tue, 30 Dec 2003 18:35:48 +0000 (UTC)
> >Path:

> cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!cpmsftng xa09.phx.gbl!TK2MSFTNGP08.
> phx.gbl!newsfeed00.sul.t-online.de!newsfeed01.sul.t-online.de!t-online.de!fu
> -berlin.de!postnews1.google.com!not-for-mail
> >Xref: cpmsftngxa07.phx.gbl microsoft.public.dotnet.framework.aspnet:198920
> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
> >
> >Sorry, didn't say - I did unregister fusion.dll first. In Windows
> >Explorer I then right-mouse-click on C:\Windows\assembly and select
> >Properties. The dialog has only a General tab - nothing else. I am
> >running Windows XP Prof and am logged in as a user with Administrator
> >privileges.
> >
> >JerryW
> >
> >(E-Mail Removed) (Jim Cheshire [MSFT]) wrote in message

> news:<(E-Mail Removed)>...
> >> Jerry,
> >>
> >> You have to unregister fusion.dll first.
> >>
> >> Jim Cheshire, MCSE, MCSD [MSFT]
> >> ASP.NET Developer Support
> >>
> >> This post is provided "as-is" and infers no rights.
> >>
> >> --------------------
> >> >From: (E-Mail Removed) (JerryW)
> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
> >> >Subject: Re: ASP.NET process identity does not have read permissions to

> the global assembly cache
> >> >Date: 30 Dec 2003 04:58:12 -0800
> >> >Organization: http://groups.google.com
> >> >Lines: 66
> >> >Message-ID: <(E-Mail Removed) >
> >> >References: <(E-Mail Removed) >

> <$(E-Mail Removed)>
> >> >NNTP-Posting-Host: 24.91.252.243
> >> >Content-Type: text/plain; charset=ISO-8859-1
> >> >Content-Transfer-Encoding: 8bit
> >> >X-Trace: posting.google.com 1072789092 20099 127.0.0.1 (30 Dec 2003

> 12:58:12 GMT)
> >> >X-Complaints-To: (E-Mail Removed)
> >> >NNTP-Posting-Date: Tue, 30 Dec 2003 12:58:12 +0000 (UTC)
> >> >Path:
> >>

> cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!cpmsftng xa09.phx.gbl!TK2MSFTNGP08.
> >>

> phx.gbl!newsfeed00.sul.t-online.de!t-online.de!newsfeed.icl.net!newsfeed.fjs
> >>

> erv.net!proxad.net!news-out.visi.com!hermes.visi.com!newsfeed2.dallas1.lev el
> >> 3.net!news.level3.com!postnews1.google.com!not-for-mail
> >> >Xref: cpmsftngxa07.phx.gbl

> microsoft.public.dotnet.framework.aspnet:198826
> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
> >> >
> >> >Thanks Jim. How do you actually see/change permissions on the GAC? I
> >> >was trying to do this with Windows Explorer (Properties-Security and
> >> >see no Security tab).
> >> >
> >> >Jerry
> >> >
> >> >
> >> >(E-Mail Removed) (Jim Cheshire [MSFT]) wrote in message

> news:<$(E-Mail Removed)>...
> >> >> Hi Jerry,
> >> >>
> >> >> If you unregister fusion.dll from a command prompt, you will be able

> to
> see
> >> >> the permissions on the GAC.
> >> >>
> >> >> Jim Cheshire, MCSE, MCSD [MSFT]
> >> >> ASP.NET Developer Support
> >> >>
> >> >> This post is provided "as-is" and infers no rights.
> >> >>
> >> >> --------------------
> >> >> >From: (E-Mail Removed) (JerryW)
> >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
> >> >> >Subject: ASP.NET process identity does not have read permissions to

> the
> global assembly cache
> >> >> >Date: 29 Dec 2003 08:31:46 -0800
> >> >> >Organization: http://groups.google.com
> >> >> >Lines: 24
> >> >> >Message-ID: <(E-Mail Removed) >
> >> >> >NNTP-Posting-Host: 24.91.252.243
> >> >> >Content-Type: text/plain; charset=ISO-8859-1
> >> >> >Content-Transfer-Encoding: 8bit
> >> >> >X-Trace: posting.google.com 1072715506 4325 127.0.0.1 (29 Dec 2003

> 16:31:46 GMT)
> >> >> >X-Complaints-To: (E-Mail Removed)
> >> >> >NNTP-Posting-Date: Mon, 29 Dec 2003 16:31:46 +0000 (UTC)
> >> >> >Path:
> >> >>
> >>

> cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!TK2MSFTN GP08.phx.gbl!newsfeed00.su
> >> >>
> >>

> l.t-online.de!t-online.de!130.59.10.21.MISMATCH!irazu.switch.ch!sw itch.ch!ne
> >> >> ws.maxwell.syr.edu!postnews1.google.com!not-for-mail
> >> >> >Xref: cpmsftngxa07.phx.gbl

> microsoft.public.dotnet.framework.aspnet:198618
> >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
> >> >> >
> >> >> >I just reinstalled .NET 2003 (after repeated attempts to get ASP.NET
> >> >> >Web Applications to work). I first did a complete uninstall of .NET
> >> >> >2003, .NET Framework 1.1, and IIS. I also completely deleted
> >> >> >c:\inetpub\wwwroot and rebooted before reinstalling.
> >> >> >
> >> >> >I created a new virtual directory from within IIS (e.g. MyWebTest).
> >> >> >Then I tried to create a new Visual C# ASP.NET Web Application
> >> >> >pointing to the location http://localhost/MyWebTest. I get an error:
> >> >> >
> >> >> >"The Web server reported the following error when attempting to

> create
> >> >> >or open the Web project located at the following URL:
> >> >> >'http://localhost/MyWebTest'. 'HTTP/1.1 500 Internal Server Error'.
> >> >> >
> >> >> >The Event log has:
> >> >> >
> >> >> >Failed to execute the request because the ASP.NET process identity
> >> >> >does not have read permissions to the global assembly cache. Error:
> >> >> >0x8013141a
> >> >> >
> >> >> >I could not see a way to change the permissions on the GAC folder
> >> >> >(C:\Windows\assembly). As a test, I gave the ASPNET user

> Administrator
> >> >> >privileges. That did not work - got the same error.
> >> >> >
> >> >> >Can anyone help me fix this? - Thanks
> >> >> >
> >> >

> >

 
Reply With Quote
 
Jim Cheshire [MSFT]
Guest
Posts: n/a
 
      12-31-2003
Jerry,

If Simple File Sharing is enabled, you won't have a Security tab.

Jim Cheshire, MCSE, MCSD [MSFT]
Microsoft Developer Support
ASP.NET
(E-Mail Removed)

This post is provided as-is with no warranties and confers no rights.

--------------------
>From: (E-Mail Removed) (JerryW)
>Newsgroups: microsoft.public.dotnet.framework.aspnet
>Subject: Re: ASP.NET process identity does not have read permissions to

the global assembly cache
>Date: 30 Dec 2003 18:43:54 -0800
>Organization: http://groups.google.com
>Lines: 177
>Message-ID: <(E-Mail Removed) >
>References: <(E-Mail Removed) >

<$(E-Mail Removed)>
<(E-Mail Removed) >
<(E-Mail Removed)>
<(E-Mail Removed) >
<8a#(E-Mail Removed)>
>NNTP-Posting-Host: 24.91.252.243
>Content-Type: text/plain; charset=ISO-8859-1
>Content-Transfer-Encoding: 8bit
>X-Trace: posting.google.com 1072838635 11689 127.0.0.1 (31 Dec 2003

02:43:55 GMT)
>X-Complaints-To: (E-Mail Removed)
>NNTP-Posting-Date: Wed, 31 Dec 2003 02:43:55 +0000 (UTC)
>Path:

cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!TK2MSFTN GP08.phx.gbl!newsfeed00.su
l.t-online.de!t-online.de!newsfeed.icl.net!newsfeed.fjserv.net!new s.maxwell.
syr.edu!postnews1.google.com!not-for-mail
>Xref: cpmsftngxa07.phx.gbl microsoft.public.dotnet.framework.aspnet:199016
>X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
>
>Thanks Jim. I am running on an NTFS partition. I did not have Simple
>File Sharing enabled. After enabling Simple File Sharing I did not see
>any difference in the Windows Explorer Properties. What does Simple
>File Sharing have to do with this or my original problem? Please
>explain.
>
>JerryW
>
>(E-Mail Removed) (Jim Cheshire [MSFT]) wrote in message

news:<8a#(E-Mail Removed)>...
>> Jerry,
>>
>> Are you running on an NTFS partition? Do you have Simple File Sharing
>> enabled?
>>
>> Jim Cheshire, MCSE, MCSD [MSFT]
>> Microsoft Developer Support
>> ASP.NET
>> (E-Mail Removed)
>>
>> This post is provided as-is with no warranties and confers no rights.
>>
>>
>> --------------------
>> >From: (E-Mail Removed) (JerryW)
>> >Newsgroups: microsoft.public.dotnet.framework.aspnet
>> >Subject: Re: ASP.NET process identity does not have read permissions to

>> the global assembly cache
>> >Date: 30 Dec 2003 10:35:48 -0800
>> >Organization: http://groups.google.com
>> >Lines: 116
>> >Message-ID: <(E-Mail Removed) >
>> >References: <(E-Mail Removed) >

>> <$(E-Mail Removed)>
>> <(E-Mail Removed) >
>> <(E-Mail Removed)>
>> >NNTP-Posting-Host: 24.91.252.243
>> >Content-Type: text/plain; charset=ISO-8859-1
>> >Content-Transfer-Encoding: 8bit
>> >X-Trace: posting.google.com 1072809348 11095 127.0.0.1 (30 Dec 2003

>> 18:35:48 GMT)
>> >X-Complaints-To: (E-Mail Removed)
>> >NNTP-Posting-Date: Tue, 30 Dec 2003 18:35:48 +0000 (UTC)
>> >Path:

>>

cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!cpmsftng xa09.phx.gbl!TK2MSFTNGP08.
>>

phx.gbl!newsfeed00.sul.t-online.de!newsfeed01.sul.t-online.de!t-online.de!fu
>> -berlin.de!postnews1.google.com!not-for-mail
>> >Xref: cpmsftngxa07.phx.gbl

microsoft.public.dotnet.framework.aspnet:198920
>> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
>> >
>> >Sorry, didn't say - I did unregister fusion.dll first. In Windows
>> >Explorer I then right-mouse-click on C:\Windows\assembly and select
>> >Properties. The dialog has only a General tab - nothing else. I am
>> >running Windows XP Prof and am logged in as a user with Administrator
>> >privileges.
>> >
>> >JerryW
>> >
>> >(E-Mail Removed) (Jim Cheshire [MSFT]) wrote in message

>> news:<(E-Mail Removed)>...
>> >> Jerry,
>> >>
>> >> You have to unregister fusion.dll first.
>> >>
>> >> Jim Cheshire, MCSE, MCSD [MSFT]
>> >> ASP.NET Developer Support
>> >>
>> >> This post is provided "as-is" and infers no rights.
>> >>
>> >> --------------------
>> >> >From: (E-Mail Removed) (JerryW)
>> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
>> >> >Subject: Re: ASP.NET process identity does not have read permissions

to
>> the global assembly cache
>> >> >Date: 30 Dec 2003 04:58:12 -0800
>> >> >Organization: http://groups.google.com
>> >> >Lines: 66
>> >> >Message-ID: <(E-Mail Removed) >
>> >> >References: <(E-Mail Removed) >

>> <$(E-Mail Removed)>
>> >> >NNTP-Posting-Host: 24.91.252.243
>> >> >Content-Type: text/plain; charset=ISO-8859-1
>> >> >Content-Transfer-Encoding: 8bit
>> >> >X-Trace: posting.google.com 1072789092 20099 127.0.0.1 (30 Dec 2003

>> 12:58:12 GMT)
>> >> >X-Complaints-To: (E-Mail Removed)
>> >> >NNTP-Posting-Date: Tue, 30 Dec 2003 12:58:12 +0000 (UTC)
>> >> >Path:
>> >>

>>

cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!cpmsftng xa09.phx.gbl!TK2MSFTNGP08.
>> >>

>>

phx.gbl!newsfeed00.sul.t-online.de!t-online.de!newsfeed.icl.net!newsfeed.fjs
>> >>

>>

erv.net!proxad.net!news-out.visi.com!hermes.visi.com!newsfeed2.dallas1.lev el
>> >> 3.net!news.level3.com!postnews1.google.com!not-for-mail
>> >> >Xref: cpmsftngxa07.phx.gbl

>> microsoft.public.dotnet.framework.aspnet:198826
>> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
>> >> >
>> >> >Thanks Jim. How do you actually see/change permissions on the GAC? I
>> >> >was trying to do this with Windows Explorer (Properties-Security and
>> >> >see no Security tab).
>> >> >
>> >> >Jerry
>> >> >
>> >> >
>> >> >(E-Mail Removed) (Jim Cheshire [MSFT]) wrote in message

>> news:<$(E-Mail Removed)>...
>> >> >> Hi Jerry,
>> >> >>
>> >> >> If you unregister fusion.dll from a command prompt, you will be

able
>> to
>> see
>> >> >> the permissions on the GAC.
>> >> >>
>> >> >> Jim Cheshire, MCSE, MCSD [MSFT]
>> >> >> ASP.NET Developer Support
>> >> >>
>> >> >> This post is provided "as-is" and infers no rights.
>> >> >>
>> >> >> --------------------
>> >> >> >From: (E-Mail Removed) (JerryW)
>> >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
>> >> >> >Subject: ASP.NET process identity does not have read permissions

to
>> the
>> global assembly cache
>> >> >> >Date: 29 Dec 2003 08:31:46 -0800
>> >> >> >Organization: http://groups.google.com
>> >> >> >Lines: 24
>> >> >> >Message-ID: <(E-Mail Removed) >
>> >> >> >NNTP-Posting-Host: 24.91.252.243
>> >> >> >Content-Type: text/plain; charset=ISO-8859-1
>> >> >> >Content-Transfer-Encoding: 8bit
>> >> >> >X-Trace: posting.google.com 1072715506 4325 127.0.0.1 (29 Dec

2003
>> 16:31:46 GMT)
>> >> >> >X-Complaints-To: (E-Mail Removed)
>> >> >> >NNTP-Posting-Date: Mon, 29 Dec 2003 16:31:46 +0000 (UTC)
>> >> >> >Path:
>> >> >>
>> >>

>>

cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!TK2MSFTN GP08.phx.gbl!newsfeed00.su
>> >> >>
>> >>

>>

l.t-online.de!t-online.de!130.59.10.21.MISMATCH!irazu.switch.ch!sw itch.ch!ne
>> >> >> ws.maxwell.syr.edu!postnews1.google.com!not-for-mail
>> >> >> >Xref: cpmsftngxa07.phx.gbl

>> microsoft.public.dotnet.framework.aspnet:198618
>> >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
>> >> >> >
>> >> >> >I just reinstalled .NET 2003 (after repeated attempts to get

ASP.NET
>> >> >> >Web Applications to work). I first did a complete uninstall of

.NET
>> >> >> >2003, .NET Framework 1.1, and IIS. I also completely deleted
>> >> >> >c:\inetpub\wwwroot and rebooted before reinstalling.
>> >> >> >
>> >> >> >I created a new virtual directory from within IIS (e.g.

MyWebTest).
>> >> >> >Then I tried to create a new Visual C# ASP.NET Web Application
>> >> >> >pointing to the location http://localhost/MyWebTest. I get an

error:
>> >> >> >
>> >> >> >"The Web server reported the following error when attempting to

>> create
>> >> >> >or open the Web project located at the following URL:
>> >> >> >'http://localhost/MyWebTest'. 'HTTP/1.1 500 Internal Server

Error'.
>> >> >> >
>> >> >> >The Event log has:
>> >> >> >
>> >> >> >Failed to execute the request because the ASP.NET process identity
>> >> >> >does not have read permissions to the global assembly cache.

Error:
>> >> >> >0x8013141a
>> >> >> >
>> >> >> >I could not see a way to change the permissions on the GAC folder
>> >> >> >(C:\Windows\assembly). As a test, I gave the ASPNET user

>> Administrator
>> >> >> >privileges. That did not work - got the same error.
>> >> >> >
>> >> >> >Can anyone help me fix this? - Thanks
>> >> >> >
>> >> >
>> >

>


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ASP.NET process identity does not have read permissions to the global assembly cache. rrossney@gmail.com ASP .Net 3 02-21-2011 11:45 PM
ASP.NET process identity does not have read permissions to the global assembly cache Michael Neumann ASP .Net 1 01-09-2006 06:52 AM
ASP.NET process identity does not have read permissions to the global assembly cache Michael Neumann ASP .Net 1 01-06-2006 01:48 PM
ASP.NET process identity does not have read permissions to the global assembly cache. c ASP .Net 0 07-20-2005 12:33 AM
ASP.NET process identity does not have read permissions to the GAC JerryW ASP .Net 2 12-29-2003 02:29 PM



Advertisments