Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > ASA 5505 Remote Access VPN: client can not see internal network

Reply
Thread Tools

ASA 5505 Remote Access VPN: client can not see internal network

 
 
johnz
Guest
Posts: n/a
 
      08-17-2009
Hi, I'm trying to setup a Cisco ASA 5505 with remote access VPN following
the configuration example from the Cisco web site. Client from the VPN
Connects, however, users can not see the inside network, does not PING etc.
Funny thing is once the VPN connects, the inside net work can ping the VPN
client.

ASA Config:
ciscoasa# sh run
: Saved
:
ASA Version 8.0(4)32
!
hostname ciscoasa
enable password 9jNfZuG3TC5tCVH0 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.254.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 172.16.254.2 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
shutdown
!
interface Ethernet0/4
shutdown
!
interface Ethernet0/5
shutdown
!
interface Ethernet0/6
shutdown
!
interface Ethernet0/7
shutdown
!
ftp mode passive
access-list nat0 extended permit ip 192.168.254.0 255.255.255.0 10.1.1.0
255.255.255.0
access-list nat0 extended permit ip 192.168.254.0 255.255.255.0
192.168.254.0 255.255.255.0
access-list testvpn_splitTunnelAcl standard permit 192.168.254.0
255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.254.0
255.255.255.0 10.1.1.0 255.255.255.240
access-list inside_access_in extended permit icmp any any log debugging
access-list outside_access_in extended permit icmp any any
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool testvpnpool 10.1.1.1-10.1.1.10 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-621.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nat0
nat (inside) 1 192.168.254.0 255.255.255.0
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 172.16.254.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat
0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect
0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable 4433
http 192.168.254.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set
ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5
ESP-AES-256-SHA ESP-AES-256
-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption aes
hash sha
group 2
lifetime 86400
crypto isakmp policy 65535
authentication pre-share
encryption aes
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
management-access inside

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
group-policy testvpn internal
group-policy testvpn attributes
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value testvpn_splitTunnelAcl
address-pools value testvpnpool
username jzhu password +9zVBByW3b2CIkJwtX8R/A== nt-encrypted
username admin password +9zVBByW3b2CIkJwtX8R/A== nt-encrypted privilege 15
tunnel-group testvpn type remote-access
tunnel-group testvpn general-attributes
address-pool testvpnpool
default-group-policy testvpn
tunnel-group testvpn ipsec-attributes
pre-shared-key *
!
!
prompt hostname context
Cryptochecksum:4eb7580ec3e799f3b02c5da513461900
: end



-------------------------------------



--
+----------------------------------------------------------+
| http://forums.cabling-design.com/ |
| *** a better way to USENET *** |
| no-spam Web and RSS interface to your favorite newsgroup |
| comp.dcom.sys.cisco - 44007 messages and counting! |
+----------------------------------------------------------+

 
Reply With Quote
 
 
 
 
jrguent@gmail.com
Guest
Posts: n/a
 
      08-18-2009
On Aug 17, 4:04*pm, (E-Mail Removed) (johnz)
wrote:
> Hi, I'm trying to setup a Cisco ASA 5505 with remote access VPN following
> the configuration example from the Cisco web site. Client from the VPN
> Connects, however, users can not see the inside network, does not PING etc.
> Funny thing is once the VPN connects, the inside net work can ping the VPN
> client.
>
> ASA Config:
> ciscoasa# sh run
> : Saved
> :
> ASA Version 8.0(4)32
> !
> hostname ciscoasa
> enable password 9jNfZuG3TC5tCVH0 encrypted
> passwd 2KFQnbNIdI.2KYOU encrypted
> names
> !
> interface Vlan1
> *nameif inside
> *security-level 100
> *ip address 192.168.254.1 255.255.255.0
> !
> interface Vlan2
> *nameif outside
> *security-level 0
> *ip address 172.16.254.2 255.255.255.0
> !
> interface Ethernet0/0
> *switchport access vlan 2
> !
> interface Ethernet0/1
> !
> interface Ethernet0/2
> !
> interface Ethernet0/3
> *shutdown
> !
> interface Ethernet0/4
> *shutdown
> !
> interface Ethernet0/5
> *shutdown
> !
> interface Ethernet0/6
> *shutdown
> !
> interface Ethernet0/7
> *shutdown
> !
> ftp mode passive
> access-list nat0 extended permit ip 192.168.254.0 255.255.255.0 10.1.1.0
> 255.255.255.0
> access-list nat0 extended permit ip 192.168.254.0 255.255.255.0
> 192.168.254.0 255.255.255.0
> access-list testvpn_splitTunnelAcl standard permit 192.168.254.0
> 255.255.255.0
> access-list inside_nat0_outbound extended permit ip 192.168.254.0
> 255.255.255.0 10.1.1.0 255.255.255.240
> access-list inside_access_in extended permit icmp any any log debugging
> access-list outside_access_in extended permit icmp any any
> pager lines 24
> logging enable
> logging asdm informational
> mtu inside 1500
> mtu outside 1500
> ip local pool testvpnpool 10.1.1.1-10.1.1.10 mask 255.255.255.0
> icmp unreachable rate-limit 1 burst-size 1
> asdm image disk0:/asdm-621.bin
> no asdm history enable
> arp timeout 14400
> global (outside) 1 interface
> nat (inside) 0 access-list nat0
> nat (inside) 1 192.168.254.0 255.255.255.0
> access-group inside_access_in in interface inside
> access-group outside_access_in in interface outside
> route outside 0.0.0.0 0.0.0.0 172.16.254.1 1
> timeout xlate 3:00:00
> timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
> timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat
> 0:05:00
> timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect
> 0:02:00
> timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
> timeout tcp-proxy-reassembly 0:01:00
> dynamic-access-policy-record DfltAccessPolicy
> http server enable 4433
> http 192.168.254.0 255.255.255.0 inside
> no snmp-server location
> no snmp-server contact
> snmp-server enable traps snmp authentication linkup linkdown coldstart
> crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
> crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
> crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
> crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
> crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
> crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
> crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
> crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
> crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
> crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
> crypto ipsec security-association lifetime seconds 28800
> crypto ipsec security-association lifetime kilobytes 4608000
> crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
> crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set
> ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5
> ESP-AES-256-SHA ESP-AES-256
> -MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
> crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
> crypto map outside_map interface outside
> crypto isakmp enable outside
> crypto isakmp policy 10
> *authentication pre-share
> *encryption aes
> *hash sha
> *group 2
> *lifetime 86400
> crypto isakmp policy 65535
> *authentication pre-share
> *encryption aes
> *hash sha
> *group 2
> *lifetime 86400
> telnet timeout 5
> ssh timeout 5
> console timeout 0
> management-access inside
>
> threat-detection basic-threat
> threat-detection statistics access-list
> no threat-detection statistics tcp-intercept
> group-policy testvpn internal
> group-policy testvpn attributes
> *vpn-tunnel-protocol IPSec
> *split-tunnel-policy tunnelspecified
> *split-tunnel-network-list value testvpn_splitTunnelAcl
> *address-pools value testvpnpool
> username jzhu password +9zVBByW3b2CIkJwtX8R/A== nt-encrypted
> username admin password +9zVBByW3b2CIkJwtX8R/A== nt-encrypted privilege 15
> tunnel-group testvpn type remote-access
> tunnel-group testvpn general-attributes
> *address-pool testvpnpool
> *default-group-policy testvpn
> tunnel-group testvpn ipsec-attributes
> *pre-shared-key *
> !
> !
> prompt hostname context
> Cryptochecksum:4eb7580ec3e799f3b02c5da513461900
> : end
>
> -------------------------------------
>
> --
> +----------------------------------------------------------+
> | * * * * * *http://forums.cabling-design.com/* * * * * * |
> | * * * * * * **** a better way to USENET *** * * * * * * *|
> | no-spam Web and RSS interface to your favorite newsgroup |
> | * *comp.dcom.sys.cisco - 44007 messages and counting! * *|
> +----------------------------------------------------------+


Hello,

You may try troubleshooting this with "show conn", And ASDM logging.
Assuming all inside systems default gateway is set to 192.168.254.1,
you would not require internal network routes for return traffic to
vpn clients using the VPN address pool 10.1.1.0/24. With this
configuration it appears to me that only icmp traffic would be allowed
from RAVPN users off of the outside interface to inside, unless you
are permitting VPN tunneled traffic to bypass interface ACL inspection
(show run sysopt command will show this status)

The second line in the nat exemption acl below looks peculiar with
source and destination networks being the same..I am not sure this is
a problem though...first line should be matching your RAVPN tunneled
traffic to bypass the nat process.

access-list nat0 extended permit ip 192.168.254.0 255.255.255.0
10.1.1.0
> 255.255.255.0
> access-list nat0 extended permit ip 192.168.254.0 255.255.255.0
> 192.168.254.0 255.255.255.0


> nat (inside) 0 access-list nat0


Regards.
 
Reply With Quote
 
 
 
 
johnz
Guest
Posts: n/a
 
      08-19-2009
johnz had written this in response to
http://forums.cabling-design.com/cis...nal-45270-.htm
:
HI thanks for the reply.

i'm not getting any output with the "sh run sysopt" command.
Is this normal?
I also tried removing the funy nat0 statement. that did not make any
difference.

I have a question about the client i'm using to test. Would it matter if
the client is connecting from the same subnet with the outside interface?

also can you explain your statement about "permitting VPN tunneled traffic
to by pass the interface ACL inspection"?





--
+----------------------------------------------------------
| http://forums.cabling-design.com/
| *** a better way to USENET ***
| no-spam Web and RSS interface to your favorite newsgroup
| comp.dcom.sys.cisco - 44032 messages and counting!
+----------------------------------------------------------

 
Reply With Quote
 
jrguent@gmail.com
Guest
Posts: n/a
 
      08-20-2009
On Aug 19, 1:34*pm, (E-Mail Removed) (johnz)
wrote:
> johnz had written this in response tohttp://forums.cabling-design.com/cisco/Re-ASA-5505-Remote-Access-VPN-...
> *:
> HI thanks for the reply.
>
> i'm not getting any output with the "sh run sysopt" command.
> Is this normal?
> I also tried removing the funy nat0 statement. that did not make any
> difference.
>
> I have a question about the client i'm using to test. Would it matter if
> the client is connecting from the same subnet with the outside interface?
>
> also can you explain your statement about "permitting VPN tunneled traffic
> to by pass the interface ACL inspection"?
>
> --
> +----------------------------------------------------------+
> | * * * * * *http://forums.cabling-design.com/* * * * * * |
> | * * * * * * **** a better way to USENET *** * * * * * * *|
> | no-spam Web and RSS interface to your favorite newsgroup |
> | * *comp.dcom.sys.cisco - 44032 messages and counting! * *|
> +----------------------------------------------------------+


Hello,

It should not matter the client is connecting from the same subnet as
the outside firewall interface. I would setup logging on ASA to
debug level and then examine the messages for more information as to
why you are not able to ping from the RAVPN client to the internal
network.

>also can you explain your statement about "permitting VPN tunneled

traffic
> to by pass the interface ACL inspection"?
>


ASA can be setup to allow all IPSec tunneled traffic to bypass
interface access-control-lists, this would mean you would not need to
add specific firewall policy rules for traffic to and from the VPN
client over the VPN tunnel.
Command to enable this is "sysopt connection permit-vpn" To disable
prepend same command with "no"
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Re: ASA 5505 behind ASA 5505 Dogg Child Cisco 0 06-07-2010 12:13 PM
Remote User VPN - ASA 5505 and Client 5.0.02 TimParker Cisco 3 01-18-2009 09:53 AM
ASA 5505 Inside interface on remote network 7echno7im Cisco 1 11-06-2008 07:12 PM
Can't See Internal Network: ASA 5505 Buck Rogers Cisco 2 01-21-2008 02:00 AM
ASA 5505 as hardware vpn client to PIX 501 or ASA 5505 with network extension mode activated bjorn@kumlait.se Cisco 1 06-17-2007 12:43 PM



Advertisments