Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > virtual directory not being configured as an application error in asp.net app

Reply
Thread Tools

virtual directory not being configured as an application error in asp.net app

 
 
Tim Zych
Guest
Posts: n/a
 
      12-23-2003
Does anybody know what's wrong with this authentication?

I'm following the book ASP.Net Kick Start's advice....

1) Create a new ASP.Net app

2) Create a web.config file in the root directory with the following:
<configuration>
<system.web>
<authentication mode="Forms" />
</system.web>
</configuration>

3) Create a folder called "Secret Files" and in it add a WebForm called
Secret.aspx and another Web.Config file.
The web.config file contains:
<configuration>
<system.web>
<authorization>
<deny users="?" />
</authorization>
</system.web>
</configuration>

and the Secret.aspx file has a label indicating success if we are redirected
to that page.

4) Add a page called Login.aspx that contains a 2 textboxes (txtUsername and
txtPassword) and a button.

The button_click event has the following code:

Private Sub Button1_Click(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles Button1.Click
If txtUsername.Text = "tim" And txtPassword.Text = "password" Then
System.Web.Security.FormsAuthentication. _
RedirectFromLoginPage(txtPassword.Text, False)
Else
Label1.Text = "Invalid Username/Password"
End If
End Sub


When I run this *inside* Visual Studio, it seems to work OK. But when I
replicate this into another asp.net folder, I get the error:
----------------------------------------------------------------------------
Parser Error Message: It is an error to use a section registered as
allowDefinition='MachineToApplication' beyond application level. This error
can be caused by a virtual directory not being configured as an application
in IIS.
----------------------------------------------------------------------------

Apparently the framework doesn't like the web.config file in the root
directory.
<authentication mode="Forms" /> is highlighted in the error message.

How can I fix this?

Thanks.
















 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Re: Getting Virtual Directory not configured error Tim Mackey ASP .Net 1 01-23-2007 04:24 PM
another virtual directory not being configured as an application error Adam Sandler ASP .Net 0 01-22-2007 05:47 PM
error - virtual dir not being configured as an application in IIS. scott ASP .Net 1 06-12-2006 02:13 PM
Virtual directory error: "directory does not exist or is not accessible because of security settings" Dave ASP .Net 1 10-24-2005 02:05 AM
Virtual directory not configured as an application =?Utf-8?B?UGF1bA==?= ASP .Net 2 12-22-2004 07:19 PM



Advertisments