Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > unable to dedug asp.net app - The project is not configured to be debugged.

Reply
Thread Tools

unable to dedug asp.net app - The project is not configured to be debugged.

 
 
TM
Guest
Posts: n/a
 
      12-02-2003
When I run an ASP.Net application I am getting the following error:
"Error while trying to run project: Unable to start debugging on the web
server. The project is not configured to be debugged."

I checked and made sure the Machine Debug Manager is running on the server,
made sure the web.comfit file has debug=true. Mine is:
<compilation defaultLanguage="vb" debug="true" />

I also checked the directory executions permissions and it is set to scripts
and executables.

My name is as a member of the VB Developers group and Debugger Users Group.
I am developing on an XP Professional machine with VS.Net 2003 and the web
server is on a local LAN as a stand alone server, running Windows 2003

Any ideas how to fix this ?
--
Tony




 
Reply With Quote
 
 
 
 
Cristhian Job
Guest
Posts: n/a
 
      12-03-2003
Read this.... it should help

Ten Steps to Successful Debugging
It's terrible when it happens-but rest assured, it will happen. You see,
debugging Windows programs is a pretty simple process and one not prone to
failure. But debugging Web applications is much more fallible.

So, what should you do if you attempt to start debugging a Web application
and get the dreaded "Unable to start debugging on the Web Server" error?
Here's your one-stop checklist...

1.. Are you working offline in Internet Explorer? Launch Internet Explorer
and look in the File menu. If "Work Offline" is checked, click it to
unselect this option, restart Visual Studio .NET, then try again.
2.. Are there syntax errors in Web.config? If there are, you won't be able
to start debugging. To check this, click Debug, Start Without Debugging and
see whether your browser reports back an error. If it does, fix it and try
again.
3.. Are you running Windows 2000 or Windows XP? If so, continue to step
four. If you're debugging a remote ASP.NET application under Windows NT 4,
you'll need to launch the application without debugging, then manually
attach to it. Look up "debugging ASP.NET Web applications, system
requirements" in the Help Index for more information. Word of advice:
upgrade.
4.. Are you a member of the Debuggers Users group? You may be logged on as
Administrator, but it's still worth checking. If you're not in the group,
you may be denied your debugging rights.
5.. Does your Web.config file have its "debug" attribute set to "true"? If
not, you're going nowhere. You might also want to check that the
Configuration Manager lists your project as 'Debug', not 'Release' (use the
drop-down box on the standard menu to alter, or choose Build, Configuration
Manager).
6.. When you created the project, did you specify an IP address rather
than a machine name? If so, launch Internet Explorer, choose Internet
Options, select the Security tab and add the IP address to the list of
trusted sites-then try again.
7.. Did you install IIS after Visual Studio .NET? If so, you'll need to do
a little fixing. Use the Help Index to look up "installing Internet
Information Server". Midway through the software requirements, you'll find
instructions telling you how to install IIS. It also provides advice on
configuring and repairing IIS after installing Visual Studio .NET: Follow
the guidelines.
8.. Are the IIS security settings set up properly? You can check this by
launching the Internet Services Manager in Windows 2000, or Internet
Information Services in Windows XP (found under the Administrative Tools
option on the Programs menu). Navigate to your Web server, locate the
Default Web Site node, right-click and select Properties, choose the
Directory Security tab, and select Edit. Ensure Anonymous Access and
Integrated Windows Authentication are checked, then OK on all open dialog
boxes.
9.. Is the Web application virtual folder set up correctly? You can check
this by launching the Internet Services Manager in Windows 2000, or Internet
Information Services in Windows XP (found under the Administrative Tools
option on the Programs menu). Navigate to your Web server, expand the
Default Web Site node, and then find your application folder in the list. If
it looks like regular Windows Explorer, it hasn't been set up correctly. To
resolve, right-click on the folder, select Properties, click the Create
button, and then hit OK to save.
10.. And finally, the most obvious of them all: Is the URL for the project
correct? Ensure both directory and extensions are accurate-and attempt to
browse the list of available files, where appropriate.
Hope it helps,
Cristhian
México

"TM" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> When I run an ASP.Net application I am getting the following error:
> "Error while trying to run project: Unable to start debugging on the web
> server. The project is not configured to be debugged."
>
> I checked and made sure the Machine Debug Manager is running on the

server,
> made sure the web.comfit file has debug=true. Mine is:
> <compilation defaultLanguage="vb" debug="true" />
>
> I also checked the directory executions permissions and it is set to

scripts
> and executables.
>
> My name is as a member of the VB Developers group and Debugger Users

Group.
> I am developing on an XP Professional machine with VS.Net 2003 and the web
> server is on a local LAN as a stand alone server, running Windows 2003
>
> Any ideas how to fix this ?
> --
> Tony
>
>
>
>



 
Reply With Quote
 
 
 
 
TM
Guest
Posts: n/a
 
      12-03-2003
Well, this was the item that did the trick:
> 9.. Is the Web application virtual folder set up correctly? You can

check
> this by launching the Internet Services Manager in Windows 2000, or

Internet
> Information Services in Windows XP (found under the Administrative Tools
> option on the Programs menu). Navigate to your Web server, expand the
> Default Web Site node, and then find your application folder in the list.

If
> it looks like regular Windows Explorer, it hasn't been set up correctly.

To
> resolve, right-click on the folder, select Properties, click the Create
> button, and then hit OK to save.


Any idea how I can prevent this problem from occurring in the future so that
when I create ASP.Net applications they will debug without me doing this
manual step ?
--
Tony



"Cristhian Job" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Read this.... it should help
>
> Ten Steps to Successful Debugging
> It's terrible when it happens-but rest assured, it will happen. You see,
> debugging Windows programs is a pretty simple process and one not prone to
> failure. But debugging Web applications is much more fallible.
>
> So, what should you do if you attempt to start debugging a Web application
> and get the dreaded "Unable to start debugging on the Web Server" error?
> Here's your one-stop checklist...
>
> 1.. Are you working offline in Internet Explorer? Launch Internet

Explorer
> and look in the File menu. If "Work Offline" is checked, click it to
> unselect this option, restart Visual Studio .NET, then try again.
> 2.. Are there syntax errors in Web.config? If there are, you won't be

able
> to start debugging. To check this, click Debug, Start Without Debugging

and
> see whether your browser reports back an error. If it does, fix it and try
> again.
> 3.. Are you running Windows 2000 or Windows XP? If so, continue to step
> four. If you're debugging a remote ASP.NET application under Windows NT 4,
> you'll need to launch the application without debugging, then manually
> attach to it. Look up "debugging ASP.NET Web applications, system
> requirements" in the Help Index for more information. Word of advice:
> upgrade.
> 4.. Are you a member of the Debuggers Users group? You may be logged on

as
> Administrator, but it's still worth checking. If you're not in the group,
> you may be denied your debugging rights.
> 5.. Does your Web.config file have its "debug" attribute set to "true"?

If
> not, you're going nowhere. You might also want to check that the
> Configuration Manager lists your project as 'Debug', not 'Release' (use

the
> drop-down box on the standard menu to alter, or choose Build,

Configuration
> Manager).
> 6.. When you created the project, did you specify an IP address rather
> than a machine name? If so, launch Internet Explorer, choose Internet
> Options, select the Security tab and add the IP address to the list of
> trusted sites-then try again.
> 7.. Did you install IIS after Visual Studio .NET? If so, you'll need to

do
> a little fixing. Use the Help Index to look up "installing Internet
> Information Server". Midway through the software requirements, you'll find
> instructions telling you how to install IIS. It also provides advice on
> configuring and repairing IIS after installing Visual Studio .NET: Follow
> the guidelines.
> 8.. Are the IIS security settings set up properly? You can check this by
> launching the Internet Services Manager in Windows 2000, or Internet
> Information Services in Windows XP (found under the Administrative Tools
> option on the Programs menu). Navigate to your Web server, locate the
> Default Web Site node, right-click and select Properties, choose the
> Directory Security tab, and select Edit. Ensure Anonymous Access and
> Integrated Windows Authentication are checked, then OK on all open dialog
> boxes.
> 9.. Is the Web application virtual folder set up correctly? You can

check
> this by launching the Internet Services Manager in Windows 2000, or

Internet
> Information Services in Windows XP (found under the Administrative Tools
> option on the Programs menu). Navigate to your Web server, expand the
> Default Web Site node, and then find your application folder in the list.

If
> it looks like regular Windows Explorer, it hasn't been set up correctly.

To
> resolve, right-click on the folder, select Properties, click the Create
> button, and then hit OK to save.
> 10.. And finally, the most obvious of them all: Is the URL for the

project
> correct? Ensure both directory and extensions are accurate-and attempt to
> browse the list of available files, where appropriate.
> Hope it helps,
> Cristhian
> México
>
> "TM" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
> > When I run an ASP.Net application I am getting the following error:
> > "Error while trying to run project: Unable to start debugging on the web
> > server. The project is not configured to be debugged."
> >
> > I checked and made sure the Machine Debug Manager is running on the

> server,
> > made sure the web.comfit file has debug=true. Mine is:
> > <compilation defaultLanguage="vb" debug="true" />
> >
> > I also checked the directory executions permissions and it is set to

> scripts
> > and executables.
> >
> > My name is as a member of the VB Developers group and Debugger Users

> Group.
> > I am developing on an XP Professional machine with VS.Net 2003 and the

web
> > server is on a local LAN as a stand alone server, running Windows 2003
> >
> > Any ideas how to fix this ?
> > --
> > Tony
> >
> >
> >
> >

>
>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error while trying to run project: Unable to start debugging on the web server. The project is not configured to be debugged. windows 2003 server Claude seraphin ASP .Net 12 02-15-2014 04:29 PM
error message: "Unable to start debugging on the web server. The project is not configured to be debugged." genc_ymeri ASP .Net 2 11-08-2005 02:52 AM
error message: "Unable to start debugging on the web server. The project is not configured to be debugged." genc_ymeri ASP .Net Security 2 11-08-2005 02:52 AM
Error while trying to run project: Unable to start debugging on the web server. The project is not configured Ken Stealth ASP .Net 2 01-31-2004 05:46 PM
virtual directory not being configured as an application error in asp.net app Tim Zych ASP .Net 0 12-23-2003 04:03 PM



Advertisments