Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computer Certification > MCSA > help please

Reply
Thread Tools

help please

 
 
Keith Chilton
Guest
Posts: n/a
 
      07-11-2007
I can not figure out why on a Windows Server 2003 PC that I can run a
program using the local path ... C:/Programs/Lexstar.exe
but I can NOT run it using UNC //MyServerName/Programs/Lexstar.exe

The weird thing is other PCs can access this program over the network, but I
can not access it from the console using the UNC like I said.
My shared and NTFS permissions look fine. I've looked at them a ton now and
nothing looks wrong.

I'm not understanding what has happened that UNC is being blocked locally on
this Server 2003 PC. What gives?


 
Reply With Quote
 
 
 
 
John R
Guest
Posts: n/a
 
      07-11-2007

"Keith Chilton" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
>I can not figure out why on a Windows Server 2003 PC that I can run a
>program using the local path ... C:/Programs/Lexstar.exe
> but I can NOT run it using UNC //MyServerName/Programs/Lexstar.exe
>
> The weird thing is other PCs can access this program over the network, but
> I can not access it from the console using the UNC like I said.
> My shared and NTFS permissions look fine. I've looked at them a ton now
> and nothing looks wrong.
>
> I'm not understanding what has happened that UNC is being blocked locally
> on this Server 2003 PC. What gives?


Assuming that the "C:\Programs" folder is shared using the share name
"Programs", and that the netbios name "MyServerName" resolves correctly,
there should be nothing stopping it from working.

If you are using the UNC, you must have both NTFS permissions for
Read+Execute, and you must have Share permissions for Change. (Be certain
you don't have any 'deny' situations in any of your permissions).

What exactly is the error message you receive when you type in the UNC path?
Can you open the UNC in an explorer window and see the executable?

Try mapping a drive letter to the "Programs" share and see if that works...

C:>\ net use M: \\MyServerName\Programs
C:> M:\Lexstar.exe

John R


 
Reply With Quote
 
 
 
 
John R
Guest
Posts: n/a
 
      07-11-2007

"keith chilton" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Here are some screenshots of the situation... The error screenshot, The
> shortcut I'm trying to use via UNC and then me accessing this folder via
> UNC
> and the console (or hard drive. it's the H drive I know.. long story)
>
> I made up the paths and names in the original post for security issues. I
> don't think it's an issue though really now. (The Imagestar2006 folder is
> real shared folder and prowin32.exe is the real file i'm having problems
> with, not Lexstar.exe) The user account logged in is a member of Data
> Processing and has FULL CONTROL over this folder as shown by "security
> settings.JPG")
>
> Any help is appreciated. I tried mapping it. That didn't help.
> --


Looking at the UNC jpg file that you sent, once you can actually view that
executable, what happens when you just double click on prowin32.exe ? I am
assuming you will get the same error that you don't have permission.

Now, looking at the security settings jpg, click on the 'sharing' tab, and
click on the permissions button. Do you have permission through there? If
you are accessing it using the unc, you must have both share permissions and
ntfs permissions.

John R


 
Reply With Quote
 
Red Swingline Stapler
Guest
Posts: n/a
 
      07-11-2007
"keith chilton" <(E-Mail Removed)> wrote in news:Okp0zB8wHHA.4612
@TK2MSFTNGP04.phx.gbl:

> UNC screenshot
>


Check your windows firewall settings. Often this can cause seeming
inexplicable behavior like this.

 
Reply With Quote
 
keith chilton
Guest
Posts: n/a
 
      07-11-2007
There is no firewall on on this machine.. It is disabled by group policy.

It has the same error when you click the prowin32.exe file using UNC...

The sharing tab has the Everyone Group with full control.....I always have
Everyone full control and then use NTFS to control permissions for users...

--
****River Valley Financial Bank, Internet Email Confidentiality Footer****
Privileged/Confidential Information may be contained in this message. If you
are not the addressee indicated in this message (or responsible for delivery
of the message to such person), you may not copy or deliver this message to
anyone. In such case, you should destroy this message, and notify us
immediately. If you or your employer does not consent to Internet email
messages of this kind, please advise us immediately. Opinions, conclusions
and other information expressed in this message are not given or endorsed by
my firm or employer unless otherwise indicated by an authorized
representative independent of this message. All Securities are offered
through Money Concepts Capital Corp., 7828 East 88th Street, Indianapolis,
Indiana 46256, 317-841-0370. Member NASD/SIPC. Not FDIC Insured, No Bank
Guarantees, May Lose Value.
"John R" <jsr^^^813@zoom^^^internet.net> wrote in message
news:(E-Mail Removed)...
>
> "keith chilton" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
>> Here are some screenshots of the situation... The error screenshot, The
>> shortcut I'm trying to use via UNC and then me accessing this folder via
>> UNC
>> and the console (or hard drive. it's the H drive I know.. long story)
>>
>> I made up the paths and names in the original post for security issues. I
>> don't think it's an issue though really now. (The Imagestar2006 folder is
>> real shared folder and prowin32.exe is the real file i'm having problems
>> with, not Lexstar.exe) The user account logged in is a member of Data
>> Processing and has FULL CONTROL over this folder as shown by "security
>> settings.JPG")
>>
>> Any help is appreciated. I tried mapping it. That didn't help.
>> --

>
> Looking at the UNC jpg file that you sent, once you can actually view that
> executable, what happens when you just double click on prowin32.exe ? I
> am assuming you will get the same error that you don't have permission.
>
> Now, looking at the security settings jpg, click on the 'sharing' tab, and
> click on the permissions button. Do you have permission through there?
> If you are accessing it using the unc, you must have both share
> permissions and ntfs permissions.
>
> John R
>



 
Reply With Quote
 
John R
Guest
Posts: n/a
 
      07-11-2007

"keith chilton" <(E-Mail Removed)> wrote in message
news:%(E-Mail Removed)...
> There is no firewall on on this machine.. It is disabled by group policy.
>
> It has the same error when you click the prowin32.exe file using UNC...
>
> The sharing tab has the Everyone Group with full control.....I always have
> Everyone full control and then use NTFS to control permissions for
> users...
>


I tried it here on both 2003 and XP and had no problems. Can you do this on
other machines on your network or is this machine the only one? Does it
work if you log on as a domain admin?

The only other thing I would recommend is that you disable IPv6 if you have
it enabled. I've seen other file access issues when IPv6 is enabled and you
access local resources via UNC, (although they were corruption issues when
copying files, not permission issues accessing it).

John R


 
Reply With Quote
 
Mostly Gizzards
Guest
Posts: n/a
 
      07-11-2007
Add Remove Programs -> Windows Componenents:

Remove the Internet Explorer Enhanced Security Configuration

MG

"Keith Chilton" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
>I can not figure out why on a Windows Server 2003 PC that I can run a
>program using the local path ... C:/Programs/Lexstar.exe
> but I can NOT run it using UNC //MyServerName/Programs/Lexstar.exe
>
> The weird thing is other PCs can access this program over the network, but
> I can not access it from the console using the UNC like I said.
> My shared and NTFS permissions look fine. I've looked at them a ton now
> and nothing looks wrong.
>
> I'm not understanding what has happened that UNC is being blocked locally
> on this Server 2003 PC. What gives?
>



 
Reply With Quote
 
keith chilton
Guest
Posts: n/a
 
      07-11-2007
I can't do this on other machines, this is our application server pc for
this program. I changed group membership to domain admin. Error. I don't
think i have IPv6 on this machine. I checked the LAN properties box and it
just has TCP/IP there.. v6 will show up separately in there (I think) The
only other thing I know to tell you that I haven't is I did update all the
way to Service Pack 2 and this is 2003 server standard edition. Maybe SP2 is
at fault and this will be fixed in the future?

This is crazy. Why do I get the weird stuff? I dont want it. It just comes
to me! Well off to the event logs to see if I can figure anything
out...........................

thanks John. If you have any other ideas let me know


 
Reply With Quote
 
keith chilton
Guest
Posts: n/a
 
      07-11-2007
Mostly Gizzards is the MAN!

I checked out the IE Sec Config and added that path to my trusted sites
list.... It worked! Makes perfect sense now... It wasnt a trusted site on
the intranet..

Thanks for all the help guys

--
****River Valley Financial Bank, Internet Email Confidentiality Footer****
Privileged/Confidential Information may be contained in this message. If you
are not the addressee indicated in this message (or responsible for delivery
of the message to such person), you may not copy or deliver this message to
anyone. In such case, you should destroy this message, and notify us
immediately. If you or your employer does not consent to Internet email
messages of this kind, please advise us immediately. Opinions, conclusions
and other information expressed in this message are not given or endorsed by
my firm or employer unless otherwise indicated by an authorized
representative independent of this message. All Securities are offered
through Money Concepts Capital Corp., 7828 East 88th Street, Indianapolis,
Indiana 46256, 317-841-0370. Member NASD/SIPC. Not FDIC Insured, No Bank
Guarantees, May Lose Value.
"Mostly Gizzards" <(E-Mail Removed)> wrote in message
news:O%(E-Mail Removed)...
> Add Remove Programs -> Windows Componenents:
>
> Remove the Internet Explorer Enhanced Security Configuration
>
> MG
>
> "Keith Chilton" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
>>I can not figure out why on a Windows Server 2003 PC that I can run a
>>program using the local path ... C:/Programs/Lexstar.exe
>> but I can NOT run it using UNC //MyServerName/Programs/Lexstar.exe
>>
>> The weird thing is other PCs can access this program over the network,
>> but I can not access it from the console using the UNC like I said.
>> My shared and NTFS permissions look fine. I've looked at them a ton now
>> and nothing looks wrong.
>>
>> I'm not understanding what has happened that UNC is being blocked locally
>> on this Server 2003 PC. What gives?
>>

>
>



 
Reply With Quote
 
John R
Guest
Posts: n/a
 
      07-11-2007

"keith chilton" <(E-Mail Removed)> wrote in message
news:OSUHSW%(E-Mail Removed)...
> Mostly Gizzards is the MAN!
>
> Makes perfect sense now


It always does once you find the right answer.
That's what I love most about this field.

(Files this one away under things to watch for)

John R


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Please please please help this guy with his open source java app casioculture@gmail.com Java 4 05-05-2005 08:24 AM
Console profile for Windows app in VC++ - PLEASE PLEASE PLEASE HELP! MuZZy C++ 7 01-07-2005 08:40 PM
Computer problems please please please help Nick Computer Support 0 06-04-2004 08:49 PM
HELP! HELP! PLEASE, PLEASE, PLEASE tpg comcntr Computer Support 11 02-15-2004 06:22 PM
please help... ...me learn C++ please please please :) KK C++ 2 10-14-2003 02:08 PM



Advertisments