Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > could not load type library

Reply
Thread Tools

could not load type library

 
 
Blue Frog
Guest
Posts: n/a
 
      10-31-2003
Hey,

Have a weird problem - been looking for a solution for 2 days solid now.

I am developing my first asp.net site and everything was going fine while I
developed on my XP laptop but I copied the site over to my 2000 server box
and set the permissions, set up the application again - configuration of
both machines seems exactly the same and the site ran fine for a day then
all of a sudden I get a 'could not load type' error for one of my assembly
classes.

So I looked around on the net and read some stuff about versioning and maybe
recompiling the assemblies so I did only to find that then I got another
'could not load type' error - this time on a different class in a different
assembly.

Anyone got any ideas what might be the problem here????

Blue Frog


 
Reply With Quote
 
 
 
 
Natty Gur
Guest
Posts: n/a
 
      11-02-2003
Hi,

CLR loader algorithm works like this:

1) Check if assembly reference got public key of strong name
If key found CLR looks for the assembly in the GAC. if not found CLR
looks in the executable directory (bin dir in ASP.NET case). if type not
found in the local directory could not load type library throw by the
CLR

2) If assembly reference without public key the CLR looks for the
assembly just in the local directory.

Check that your assemblies meet that search path. If you can send the
error message as seen on the browser.

Natty Gur[MVP]
Phone Numbers:
Office: +972-(0)9-7740261
Fax: +972-(0)9-7740261
Mobile: +972-(0)58-888377


*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
could not load type "_default" M ASP .Net 1 07-24-2006 04:29 PM
Could not load type =?Utf-8?B?RGhlZXJhaiBXYWRo?= ASP .Net 2 10-26-2005 06:33 PM
Could not load type - not obvious ChrisC ASP .Net 8 05-12-2005 01:20 PM
Could not load type Neil Ramsbottom ASP .Net 2 07-30-2003 05:23 AM
could not load type global bob ASP .Net 1 07-02-2003 04:18 AM



Advertisments