Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computer Certification > MCAD > Debug.Assert(): missing MsgBox (VS.NET 2003, C#)

Reply
Thread Tools

Debug.Assert(): missing MsgBox (VS.NET 2003, C#)

 
 
Mark Newby
Guest
Posts: n/a
 
      04-29-2005
when i try to use (in a web form)

System.Diagnostics.Debug.Assert(false, "IT IS FALSE");

i never get the MsgBox-style dialog box displaying when the assertion
evals as false when run in debug mode. the project is located on the
local pc (xp pro, sp2) and run in debug mode from local pc, so the
dialog box should appear on local pc, right?

the VS.NET Output Window shows correct "IT IS FALSE" output, etc.

any ideas?

mark (studying for 70-315)
 
Reply With Quote
 
 
 
 
G.V.
Guest
Posts: n/a
 
      05-03-2005

http://www.c-sharpcorner.com/Code/20...nASPDotNet.asp

G.V.

"Mark Newby" <(E-Mail Removed)> wrote in message
news:%(E-Mail Removed)...
: when i try to use (in a web form)
:
: System.Diagnostics.Debug.Assert(false, "IT IS FALSE");
:
: i never get the MsgBox-style dialog box displaying when the assertion
: evals as false when run in debug mode. the project is located on the
: local pc (xp pro, sp2) and run in debug mode from local pc, so the
: dialog box should appear on local pc, right?
:
: the VS.NET Output Window shows correct "IT IS FALSE" output, etc.
:
: any ideas?
:
: mark (studying for 70-315)

 
Reply With Quote
 
 
 
 
Mark Newby
Guest
Posts: n/a
 
      05-05-2005
G.V. wrote:
> http://www.c-sharpcorner.com/Code/20...nASPDotNet.asp
>
> G.V.
>
> "Mark Newby" <(E-Mail Removed)> wrote in message
> news:%(E-Mail Removed)...
> : when i try to use (in a web form)
> :
> : System.Diagnostics.Debug.Assert(false, "IT IS FALSE");
> :
> : i never get the MsgBox-style dialog box displaying when the assertion
> : evals as false when run in debug mode. the project is located on the
> : local pc (xp pro, sp2) and run in debug mode from local pc, so the
> : dialog box should appear on local pc, right?
> :
> : the VS.NET Output Window shows correct "IT IS FALSE" output, etc.
> :
> : any ideas?


thanks G.V., but that seems rather like re-inventing the wheel, no? the
MS Training Kit book for 70-315 says the dialog box should be available
from a web app running locally as i described.

could it be because it's changed from .NET Framework 1.0 --> 1.1 perhaps?


mark
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I show msgbox (".NET framework is not installed") before my program run ? Mendhak [MVP] ASP .Net 0 05-15-2005 03:44 PM
Re: Debug.Assert(): missing MsgBox (VS.NET 2003, C#) Mark Newby MCSD 0 05-05-2005 05:00 PM
Debug.Assert(): missing MsgBox (VS.NET 2003, C#) Mark Newby ASP .Net 1 05-03-2005 07:43 AM
[.NET 2003] Debug.Assert(): missing MsgBox Mark Newby MCSD 0 04-29-2005 01:12 PM
Re: msgbox? Emil Kvarnhammar ASP .Net 1 07-16-2003 09:44 AM



Advertisments