Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > HTML > iframe in ie & ff & Chrome & Opera

Reply
Thread Tools

iframe in ie & ff & Chrome & Opera

 
 
Øyvind Granberg
Guest
Posts: n/a
 
      12-05-2008
Hi...

I have this site, based on iframes.
http://www.tresfjording.com/sitemal/

The page shos fine in IE.

But in Chrome, Firefox and Opera, all latest upgrades and updates, the
frames do not come seamless together...
The renderering on the screen is the same in these browser.

It's a little frustrating when a straight forward code is working fine in
IE, but not in others.
Here is the code of the index.htm

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">
<html>
<head >
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<title>Granberg Online - index</title>
<style type="text/css">
<!--
body {
background-color: #666666;
}
-->
</style>
</head>
<body>
<div align="center">
<table border="0" cellpadding="0" cellspacing="0">
<tr>
<td><iframe src="top.htm" width="750" height="150" frameborder="0"
scrolling="No" > </iframe></td>
</tr>
<tr>
<td><iframe src="menu.htm" name="leftframe" width="150" height="350"
scrolling="No" frameborder="0" id="leftframe"> </iframe>
<iframe src="hoved.htm" name="mainframe" width="450" height="350"
scrolling="Auto" frameborder="0" id="mainframe"></iframe>
<iframe src="right.htm" name="rightframe" width="150" height="350"
scrolling="No" frameborder="0" id="rightframe"></iframe></td>
</tr>
<tr>
<td><iframe src="bunn.htm" name="botnframe" width="750"
marginwidth="20px" height="20" scrolling="No" frameborder="0"
id="botnframe"></iframe></td>
</tr>
</table>
</div>
</body>
</html>


I can't see what's wrong here?
Can anyone help me?

--

Vennlig hilsen
Øyvind Granberg

http://www.velocityreviews.com/forums/(E-Mail Removed)
www.tresfjording.com

 
Reply With Quote
 
 
 
 
dorayme
Guest
Posts: n/a
 
      12-05-2008
In article <4938747c$(E-Mail Removed)>,
Øyvind Granberg <(E-Mail Removed)> wrote:

> Hi...
>
> I have this site, based on iframes.
> http://www.tresfjording.com/sitemal/
>
> The page shos fine in IE.
>
> But in Chrome, Firefox and Opera, all latest upgrades and updates, the
> frames do not come seamless together...
> The renderering on the screen is the same in these browser.
>
> It's a little frustrating when a straight forward code is working fine in
> IE, but not in others.
> Here is the code of the index.htm
>
> <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"

....
> </html>
>
>
> I can't see what's wrong here?
> Can anyone help me?


For one thing, the value of attribute ³marginwidth² for element
³<iframe>² must be a number.

--
dorayme
 
Reply With Quote
 
 
 
 
Øyvind Granberg
Guest
Posts: n/a
 
      12-06-2008
I took all the "marginwith" away.
I removed all the "frameborer="0"

Still no fix!

the url is now http://www.tresfjording.com/

--

Vennlig hilsen
Øyvind Granberg

(E-Mail Removed)
www.tresfjording.com

>
> For one thing, the value of attribute ³marginwidth² for element
> ³<iframe>² must be a number.
>
> --
> dorayme


 
Reply With Quote
 
dorayme
Guest
Posts: n/a
 
      12-06-2008
In article <(E-Mail Removed)>,
Øyvind Granberg <(E-Mail Removed)> wrote:

> I took all the "marginwith" away.
> I removed all the "frameborer="0"
>
> Still no fix!
>
> the url is now http://www.tresfjording.com/
>
> --
>
> Vennlig hilsen
> Øyvind Granberg
>
> (E-Mail Removed)
> www.tresfjording.com
>
> >
> > For one thing, the value of attribute ³marginwidth² for element
> > ³<iframe>² must be a number.
> >


Best not to top post.

Next thing to do is validate your frames. There are 21 errors and 21
warnings errors for the simple left frame alone!

Use

<http://validator.w3.org/>

--
dorayme
 
Reply With Quote
 
Øyvind Granberg
Guest
Posts: n/a
 
      12-06-2008
I've used the validator and it came out blank...

But it's fixed now...

First of all I had to use frameborder=0 in all iframes
Secondly I had to rearrange my table to one cell for each iframe

now it works fine



--

Vennlig hilsen
Øyvind Granberg

(E-Mail Removed)
www.tresfjording.com

"dorayme" <(E-Mail Removed)> skrev i nyhetsmeldingen:
doraymeRidThis-E6715B.11341306122008...ptusnet.com.au ...
> In article <(E-Mail Removed)>,
> Øyvind Granberg <(E-Mail Removed)> wrote:
>


>
> Use
>
> <http://validator.w3.org/>
>
> --
> dorayme


 
Reply With Quote
 
Øyvind Granberg
Guest
Posts: n/a
 
      12-06-2008
it now works fine in all the four big ones...
IE - FF - Opera and Chrome

--

Vennlig hilsen
Øyvind Granberg

(E-Mail Removed)
www.tresfjording.com



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
works in Opera and IE but not FF or Chrome - why? 123Jim Javascript 6 05-08-2011 06:25 PM
input in a text box still appear after page refresh for IE but notFF, Chrome, Opera albert kao Javascript 4 04-07-2010 11:48 PM
Problem with getSelection() in iframe in chrome Ciaran Javascript 10 11-25-2009 04:51 PM
Google Chrome OS, Odds are stacked against Chrome OS's success Max Burke NZ Computing 1 07-11-2009 04:38 AM
Get form values from iframe (1) to iframe (2) inside a layer in iframe (1) Daedalous Javascript 3 01-16-2004 11:08 AM



Advertisments