Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Wireless Networking > How to prevent windows xp sp2 from autoconnecting to a network?

Reply
Thread Tools

How to prevent windows xp sp2 from autoconnecting to a network?

 
 
Mario
Guest
Posts: n/a
 
      04-27-2005
hi
I have my own application which connects a wlan network.
So I have DISABLED the Wireless Zero Configuration Service.

The problem is, if I disable the service, windows automatically connects the
wlan adapter to any of the available wlan networks. I don't know how that
works, but anyone connects to a network....

Can anyone tell me how to disable this?
My app sould be the only thing which connects to a wlan network!!!

Thanks in advance
Mario



 
Reply With Quote
 
 
 
 
Jack \(MVP\)
Guest
Posts: n/a
 
      04-27-2005
Hi
Do not use the Default SSID make a unique name.
Switch all the Wireless hardware to channel 11.
Use the original Utility and look through the menu,might be that there is an entry to
restrict general logging.
Jack (MVP-Networking).


"Mario" <(E-Mail Removed)> wrote in message
news:#lNN$(E-Mail Removed)...
> hi
> I have my own application which connects a wlan network.
> So I have DISABLED the Wireless Zero Configuration Service.
>
> The problem is, if I disable the service, windows automatically connects the
> wlan adapter to any of the available wlan networks. I don't know how that
> works, but anyone connects to a network....
>
> Can anyone tell me how to disable this?
> My app sould be the only thing which connects to a wlan network!!!
>
> Thanks in advance
> Mario
>
>
>



 
Reply With Quote
 
 
 
 
Mario
Guest
Posts: n/a
 
      04-29-2005
hi
Perhaps, I sould discribe my problem a litte bit detailed:

I have disabled the Wireless Zero Configuration, because I have my own
applicatoin to connect to Wlan networks.

At XP SP1, when I plug on a wlan adapter nothing happens. No one is
connecting to a network.

At XP SP2, when I plug in a wlan adapter, windows is autoconnecting to any
of the available wlan networks!!!
The prblem is, I havent found a way to "disable" this autoconnecting from
windows....
The only way is to enable Wireless Zero Configuration and set there the
settings. But this is no possible solution for me, becuase the service MUST
always be stopped, otherwise I got problems with Ndisuio, which I need for
my app to connect to wlans....


You suggested to not using the default SSID, but where sould I set this?
Wireless Zero Configuration is disabled, so there is nothing to configure in
windows...

what do you mean my switch hardware to channel 11?


thanks for your help...
mario



"Jack (MVP)" <Jack(MVP)@discussions.microsoft.com.> wrote in message
news:(E-Mail Removed)...
> Hi
> Do not use the Default SSID make a unique name.
> Switch all the Wireless hardware to channel 11.
> Use the original Utility and look through the menu,might be that there is
> an entry to
> restrict general logging.
> Jack (MVP-Networking).
>
>
> "Mario" <(E-Mail Removed)> wrote in message
> news:#lNN$(E-Mail Removed)...
>> hi
>> I have my own application which connects a wlan network.
>> So I have DISABLED the Wireless Zero Configuration Service.
>>
>> The problem is, if I disable the service, windows automatically connects
>> the
>> wlan adapter to any of the available wlan networks. I don't know how that
>> works, but anyone connects to a network....
>>
>> Can anyone tell me how to disable this?
>> My app sould be the only thing which connects to a wlan network!!!
>>
>> Thanks in advance
>> Mario
>>
>>
>>

>
>



 
Reply With Quote
 
Jerry Peterson[MSFT]
Guest
Posts: n/a
 
      05-02-2005
I'll jump in with two possible theories, let me know if this helps.

1) A client adapter that recieves a "null" SSID will connect to any network
within range. If you created a wireless profile in the Microsoft client
that did not specify a name in the SSID field, you would experience the
behavior you have described below. From the Wireless networks tab, click in
the box for "Preferred networks:". If the "Remove" button becomes
available, click it to delete the invisible profile. Click "OK" at the
bottom of the property sheet to save the changes.

Additionally, you can uncheck the box on the same property sheet for the
field "Use Windows to configure my wireless network settings."

2) An application on your system may be placing wireless settings to the
adpater. If a "null" SSID is set, then you will experience the
auto-connecting behavior. Double check your application to ensure this is
not happening.

--
Jerry Peterson
Windows Network Services - Wireless

This posting is provided "AS IS" with no warranties, and confers no rights.
"Mario" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> hi
> Perhaps, I sould discribe my problem a litte bit detailed:
>
> I have disabled the Wireless Zero Configuration, because I have my own
> applicatoin to connect to Wlan networks.
>
> At XP SP1, when I plug on a wlan adapter nothing happens. No one is
> connecting to a network.
>
> At XP SP2, when I plug in a wlan adapter, windows is autoconnecting to any
> of the available wlan networks!!!
> The prblem is, I havent found a way to "disable" this autoconnecting from
> windows....
> The only way is to enable Wireless Zero Configuration and set there the
> settings. But this is no possible solution for me, becuase the service
> MUST always be stopped, otherwise I got problems with Ndisuio, which I
> need for my app to connect to wlans....
>
>
> You suggested to not using the default SSID, but where sould I set this?
> Wireless Zero Configuration is disabled, so there is nothing to configure
> in windows...
>
> what do you mean my switch hardware to channel 11?
>
>
> thanks for your help...
> mario
>
>
>
> "Jack (MVP)" <Jack(MVP)@discussions.microsoft.com.> wrote in message
> news:(E-Mail Removed)...
>> Hi
>> Do not use the Default SSID make a unique name.
>> Switch all the Wireless hardware to channel 11.
>> Use the original Utility and look through the menu,might be that there is
>> an entry to
>> restrict general logging.
>> Jack (MVP-Networking).
>>
>>
>> "Mario" <(E-Mail Removed)> wrote in message
>> news:#lNN$(E-Mail Removed)...
>>> hi
>>> I have my own application which connects a wlan network.
>>> So I have DISABLED the Wireless Zero Configuration Service.
>>>
>>> The problem is, if I disable the service, windows automatically connects
>>> the
>>> wlan adapter to any of the available wlan networks. I don't know how
>>> that
>>> works, but anyone connects to a network....
>>>
>>> Can anyone tell me how to disable this?
>>> My app sould be the only thing which connects to a wlan network!!!
>>>
>>> Thanks in advance
>>> Mario
>>>
>>>
>>>

>>
>>

>
>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't prevent IE 5.5 SP2 from issuing two security warnings tasTDasd Computer Support 7 09-22-2009 02:33 PM
Adminpak SP2 , Windows Server x64 SP2 =?Utf-8?B?QmrDuHJu?= Windows 64bit 2 09-03-2007 12:54 PM
Novell Client 4.92 SP2 and Windows XP SP2 Yogi Computer Support 1 07-22-2005 01:33 AM
I wonder if XP SP2 can prevent this kind of behaviour... K T T NZ Computing 8 09-15-2004 09:42 PM
Re: IE 6.0 with SP2 and Windows XP SP2 and Adobe Acrobat & Reader 6.0 George ASP .Net 5 08-24-2004 12:11 PM



Advertisments