Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > UK VOIP > Siemens Gigaset S685IP and VOIP problems

Reply
Thread Tools

Siemens Gigaset S685IP and VOIP problems

 
 
Lobster
Guest
Posts: n/a
 
      09-28-2008
I've posted here previously about getting the above to work properly -
had a fair amount of teething trouble and TBH am regretting the purchase
- probably more hi-tech than I needed I think. Anyway...

I'm using (or trying to) with Sipgate, via a Linksys WRT54G router. It
originally worked fine (once I'd sussed I needed to open port 5060 on
the router!), but for some reason (probably due to me having fiddled
with something?) it hasn't worked for several weeks despite all my
efforts - the phone just says "No IP Connection".

Things I've checked:

Logging into the computer interface (http://192.168.1.101/login.html),
under 'Telephony' I can see that Sipgate is registered and active. I
can use my Sipgate account fine via a softphone on my laptop, too.

It's set to automatic IP address assignment.

The router has port 5060 open. (I'm not at all clued up on this side of
things; however it looks OK; and certainly I've got ubittorent
configured OK!)

Any suggestions as to what else I can/should check?

Thanks
David
 
Reply With Quote
 
 
 
 
Lobster
Guest
Posts: n/a
 
      09-28-2008
Jono wrote:
> Lobster wrote :
>> I've posted here previously about getting the above to work properly -
>> had a fair amount of teething trouble and TBH am regretting the
>> purchase - probably more hi-tech than I needed I think. Anyway...
>>
>> I'm using (or trying to) with Sipgate, via a Linksys WRT54G router.
>> It originally worked fine (once I'd sussed I needed to open port 5060
>> on the router!), but for some reason (probably due to me having
>> fiddled with something?) it hasn't worked for several weeks despite
>> all my efforts - the phone just says "No IP Connection".
>>
>> Things I've checked:
>>
>> Logging into the computer interface (http://192.168.1.101/login.html),
>> under 'Telephony' I can see that Sipgate is registered and active. I
>> can use my Sipgate account fine via a softphone on my laptop, too.
>>
>> It's set to automatic IP address assignment.
>>
>> The router has port 5060 open. (I'm not at all clued up on this side
>> of things; however it looks OK; and certainly I've got ubittorent
>> configured OK!)
>>
>> Any suggestions as to what else I can/should check?

>
> I would say you may need more than just port 5060 opening. I have UDP
> ports 5060-5069 & 10000-20000.


Well, dunno... I'm sure I only had 5060 opened when it was working
before. In my ignorance, why would it need a range of 10000 ports
opening though - isn't that almost as bad as having no firewall? I've
just tested it though with all those ports open anyway - didn't make any
difference.

> Anyway, are you sure you've configured your settings correctly in the
> phone itself?


The $64,000 question, I suppose! AFAIK, yes... but wouldn't the
computer interface display Sipgate as having an error - at the moment it
says "Registered"?

Thanks for replying.

David
 
Reply With Quote
 
 
 
 
alexd
Guest
Posts: n/a
 
      09-28-2008
On Sun, 28 Sep 2008 16:46:12 +0100, Lobster wrote:

> Jono wrote:


>> I would say you may need more than just port 5060 opening. I have UDP
>> ports 5060-5069 & 10000-20000.

>
> Well, dunno... I'm sure I only had 5060 opened when it was working
> before. In my ignorance, why would it need a range of 10000 ports
> opening though - isn't that almost as bad as having no firewall? I've
> just tested it though with all those ports open anyway - didn't make any
> difference.


Depends what you mean by 'open'; Do you mean allowing traffic out from
your handset onto the internet? Or do you mean allowing connections in
from the internet to your handset? Or both?

--
<http://ale.cx/> (AIM:troffasky) ((E-Mail Removed))
18:31:44 up 7 days, 41 min, 1 user, load average: 4.03, 4.05, 4.00
They call me titless because I have no tits
 
Reply With Quote
 
Lobster
Guest
Posts: n/a
 
      09-29-2008
www.GymRatZ.co.uk wrote:

Many thanks for the help.

> Lobster wrote:


>> I'm using (or trying to) with Sipgate, via a Linksys WRT54G router. It
>> originally worked fine (once I'd sussed I needed to open port 5060 on
>> the router!), but for some reason (probably due to me having fiddled
>> with something?) it hasn't worked for several weeks despite all my
>> efforts - the phone just says "No IP Connection".

>
> Hmmm... I had that for several accounts but that was down to incorrect
> password on one account my mistake of foolishly copy/paste password
> which very rarely works on anything where password is masked on input.
> (i.e. copying actual numbers from e-mail rather than direct keyboard
> entry into field)


OK, have re-entered password...

>> Logging into the computer interface (http://192.168.1.101/login.html),
>> under 'Telephony' I can see that Sipgate is registered and active. I
>> can use my Sipgate account fine via a softphone on my laptop, too.
>>
>> It's set to automatic IP address assignment.

>
> I tried that and found it made things a bit more confusing so I
> allocated it a fixed IP address well away from the network PC's


Have now switched to fixed IP address...

> Sipgate settings


> STUN enabled - No
> Outbound proxy mode - auto


No idea what these are all about; but have now changed to these from my
original settings of 'Yes' (with settings gleaned from sipgate.co.uk)
and 'No' respectively. (Or was it 'Yes' and 'Yes'? Bugger...) Is this
important?

> The only other thing I have is under "Telephony > advanced settings"
> I set it to "Use Random Ports - Yes"
> But that was more to do with the fact I still have my Draytek on the
> system doing in/out SIP calls as well.
>
> didn't need to do anything to the router, just let it be.
> I though the router/firewall opened up ports it needed from the
> safe-side rather than needing to allow the ports to be set wide open to
> everyone and everything?


AFAIK I do need to open port 5060; that was apparently the original
cause of the system not working problem when I first bought it, as
advised by someone here (see one of my old threads!).

> What about... simpler than that... is the softphone logging in and
> preventing the ATA grabbing the session? or does the same thing happen
> with all PC's shut down?


Indeed, it's the same with all PCs off. Though FWIW if I log into my
account on Sipgate I can see the S685IP listed as a registered device
(as well as the softphone if that PC is switched on). Against the S685IP
it states: IP: sip:58**116@86.*.1*7.114:5060 (where * = digits I've
deleted), which surely implies all should be working OK?

> Also... I found in the absence of any way or re-booting the ATA either
> remotely or physically (apart from the mains switch of course) unticking
> the "active" box then re-ticking it.


OK, rebooted the little black interface box (is that the ATA?!) and have
unticked and ticked the "active" box...


Have done all the above steps one at a time, and unfortunately none of
them have made any difference. I can't help feeling I've done something
stupid somewhere and am about to shout "Duh!" and slap my forehead, but
so far - I'm still struggling.

Bloody thing.

David
 
Reply With Quote
 
Gordon Henderson
Guest
Posts: n/a
 
      09-29-2008
In article <Rn1Ek.10858$(E-Mail Removed)2>,
Lobster <(E-Mail Removed)> wrote:

>> STUN enabled - No
>> Outbound proxy mode - auto


>AFAIK I do need to open port 5060; that was apparently the original
>cause of the system not working problem when I first bought it, as
>advised by someone here (see one of my old threads!).


OK. STUN and Port opening/forwarding. The biggest cause/headache of
one-way audio. Doesn't (shouldn't) affect registration though. (Which
can be very frustrating - my phones registerd, but I can't hear you!)

With regard to port opening - if you're using a NAT firewall, then for
the most part you don't really need an external firewall turned on. I'll
likely get flamed for this, but for the most part, it's not needed. Turn
the external firewall off if you're using a NAT router. (Unless you know
what you're doing and really need it - Zyxel users take note!)

Port forwarding is a differnet kettle of fish. Either port-forward
5060 AND the RTP ports to your phone, or don't. If you do port-forward
them to the phone, then you'll probably need to tell the phone what your
external IP address is. The RTP ports are negotiated by the far-end, so
you'll need to know in-advance what they are. Asterisk defaults to using
10,000 through 20,000, but other services are different.

STUN - This is a mechanism which lets the phone find-out what the NAT
firewall is doing, how it works and how to bypass it - or at least use
it to it's own advantage. You need a stun server and a port - usually
the default port is 3478, but sometimes it's different.

And sometimes you don't need to do anything because the SIP service
you're connecting to runs their own magical proxy server that can work
out what's happening and try to work out what the right thing to do is.

Personally, I've had more success using a STUN server and not doing any
untoward port-forwarding and firewalling other than NAT.

Finally, some routers get in the way of SIP - either because they
themselves are SIP clients (rotuers with phone sockets on them), or
think that they know all sbout how SIP works and try to magiclly make it
work for you. Most of these are broken. (Look for "SIP ALG" in their
documentation and turn it off)

SIP is great - it's taken me a long time to get into it though, but it's
also horribly complex and really not suited for NAT firewalls.. Come the
revolution when everyone uses IPv6 and NAT "goes away"... But that's not
going to happen in my lifetime!

For Siemens DECT phones, I use a STUN server (I run my own - if anyone
wants to use it, drop me an email) and set the proxy to "Never". This has
worked for sipgate and my own Asterisk servers. For other SIP services,
who knows!

Gordon
 
Reply With Quote
 
Lobster
Guest
Posts: n/a
 
      09-29-2008
Gordon Henderson wrote:
> In article <Rn1Ek.10858$(E-Mail Removed)2>,
> Lobster <(E-Mail Removed)> wrote:
>
>>> STUN enabled - No
>>> Outbound proxy mode - auto

>
>> AFAIK I do need to open port 5060; that was apparently the original
>> cause of the system not working problem when I first bought it, as
>> advised by someone here (see one of my old threads!).

>
> OK. STUN and Port opening/forwarding. The biggest cause/headache of
> one-way audio. Doesn't (shouldn't) affect registration though. (Which
> can be very frustrating - my phones registerd, but I can't hear you!)
>
> With regard to port opening - if you're using a NAT firewall, then for
> the most part you don't really need an external firewall turned on. I'll
> likely get flamed for this, but for the most part, it's not needed. Turn
> the external firewall off if you're using a NAT router. (Unless you know
> what you're doing and really need it - Zyxel users take note!)
>
> Port forwarding is a differnet kettle of fish. Either port-forward
> 5060 AND the RTP ports to your phone, or don't. If you do port-forward
> them to the phone, then you'll probably need to tell the phone what your
> external IP address is. The RTP ports are negotiated by the far-end, so
> you'll need to know in-advance what they are. Asterisk defaults to using
> 10,000 through 20,000, but other services are different.
>
> STUN - This is a mechanism which lets the phone find-out what the NAT
> firewall is doing, how it works and how to bypass it - or at least use
> it to it's own advantage. You need a stun server and a port - usually
> the default port is 3478, but sometimes it's different.
>
> And sometimes you don't need to do anything because the SIP service
> you're connecting to runs their own magical proxy server that can work
> out what's happening and try to work out what the right thing to do is.
>
> Personally, I've had more success using a STUN server and not doing any
> untoward port-forwarding and firewalling other than NAT.
>
> Finally, some routers get in the way of SIP - either because they
> themselves are SIP clients (rotuers with phone sockets on them), or
> think that they know all sbout how SIP works and try to magiclly make it
> work for you. Most of these are broken. (Look for "SIP ALG" in their
> documentation and turn it off)
>
> SIP is great - it's taken me a long time to get into it though, but it's
> also horribly complex and really not suited for NAT firewalls.. Come the
> revolution when everyone uses IPv6 and NAT "goes away"... But that's not
> going to happen in my lifetime!
>
> For Siemens DECT phones, I use a STUN server (I run my own - if anyone
> wants to use it, drop me an email) and set the proxy to "Never". This has
> worked for sipgate and my own Asterisk servers. For other SIP services,
> who knows!


Thanks so much for taking the time to explain all that, which I read
with an increasingly sinking feeling as I realise just how far down the
learning curve I am. TBH - pretty much convinced me to pack the thing
up its box again and send it back

However - just had one final fiddle around and have been in another
sub-submenu on the phone's web interface called "number assignment".
I'm embarrassed to admit this, but in there I found a checkbox telling
the handsets to use 'justvoip' rather than 'sipgate' - I very briefly
played with and rejected justvoip some weeks ago and this setting must
have got tweaked. (Pause while slams head on desk multiple times).

So yes, it was something pretty straightforward, as I'd rather suspected
as it had worked for me once before. But thanks very much to everyone
who's tried to help out.

But if anyone's still listening:...

How do I go about diverting all incoming calls on sipgate so they go to
sipgate's voicemail service? The phone's web interface only seems to
allow me to forward them to a number, and I can't see any way of doing
it via my sipgate account online. I only want to use VOIP for outgoing
calls.

Thanks
David

 
Reply With Quote
 
Ian Pawson
Guest
Posts: n/a
 
      09-29-2008
www.GymRatZ.co.uk wrote:
> Lobster wrote:
>> I've posted here previously about getting the above to work properly -
>> had a fair amount of teething trouble and TBH am regretting the purchase

>
> I realised that within about 10 minutes i'd made a grave mistake but
> that was down to the simplicity and system stupidity/inflexabillity
> rather than complexity.
>
> I got it working straight away with Sipgate though.
>
>> I'm using (or trying to) with Sipgate, via a Linksys WRT54G router. It
>> originally worked fine (once I'd sussed I needed to open port 5060 on
>> the router!), but for some reason (probably due to me having fiddled
>> with something?) it hasn't worked for several weeks despite all my
>> efforts - the phone just says "No IP Connection".

>
> Hmmm... I had that for several accounts but that was down to incorrect
> password on one account my mistake of foolishly copy/paste password
> which very rarely works on anything where password is masked on input.
> (i.e. copying actual numbers from e-mail rather than direct keyboard
> entry into field)
>
>
>> Logging into the computer interface (http://192.168.1.101/login.html),
>> under 'Telephony' I can see that Sipgate is registered and active. I
>> can use my Sipgate account fine via a softphone on my laptop, too.
>>
>> It's set to automatic IP address assignment.

>
> I tried that and found it made things a bit more confusing so I
> allocated it a fixed IP address well away from the network PC's
>
> IP address: 192.168.0.200
> Subnet mask: 255.255.255.000
> Default gateway: 192.168.0.1 (router)
> Preferred DNS server: 212.135.001.036 (ISP primary DNS server)
> Alternate DNS server: 208.067.222.222 (open DNS server)
>

I usually point the DNS server to the router as this has isp and opendns
already set..
You don't need to do anything with ports in the router.
 
Reply With Quote
 
Tim
Guest
Posts: n/a
 
      09-30-2008
Lobster wrote:
> The $64,000 question, I suppose! AFAIK, yes... but wouldn't the
> computer interface display Sipgate as having an error - at the moment it
> says "Registered"?
>


If it says Registered, then it is working.

Maybe you set up a second IP connection which is giving the error.

have you unticked the gigaset.net account? This often messes things up.


The phones work great with sipgate. sipgate even sell them.

You shouldn't need to do any port fowarding on your router. SIPgate is
nat safe so should just work. No fiddling required.

Tim
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Re: Gigaset firmware update. (S685ip) Paul Jones UK VOIP 1 11-12-2009 05:23 PM
Re: Gigaset firmware update. (S685ip) Graham. UK VOIP 0 11-12-2009 04:56 PM
Re: Siemans Gigaset S685ip firmware still duff and useless. PAJ UK VOIP 15 11-27-2008 05:39 PM
Re: Siemans Gigaset S685ip firmware still duff and useless. alexd UK VOIP 2 11-22-2008 02:59 PM
Re: Siemens Gigaset S685IP VOIP phone problems Ian Pawson UK VOIP 16 08-26-2008 09:26 AM



Advertisments