Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > Some Questions on VLAN Trunking and Layer 3 Routing

Reply
Thread Tools

Some Questions on VLAN Trunking and Layer 3 Routing

 
 
tman
Guest
Posts: n/a
 
      09-19-2008
Hope this is not to verbose.

-- What I am trying to do:

I am trying to configure a Cisco 2948G-L3 and a Cisco 3548 for vlan
trunking. I am

currently using the Cisco 2948G-L3 as a router. It is not configured
with VLANs, it has

various groups of ports configured in seven different BVIs. Each BVI
has an ip assigned

and acts as the default gateway for end stations on its respective
subnet. This all

works great and we have used it for years.

I am now trying to figure out how to configure the Cisco 2948G-L3 to
terminate a VLAN

trunk from a Nortel switch that we will be getting soon for some
wireless phones. We

will also be using the Nortel wireless network for a few wireless
workstations and

laptops. We will have four VLANs on the Nortel switch. Two of them do
not need to trunk

to the Cisco 2948G-L3 as they will have ports on the Nortel switch
assigned to them to

get to devices.

I also thought I would create and additional BVI, Bridge-group 111 on
the Cisco 2948G-L3

to bridge VLAN1 to the other switch for management.

We do want to trunk two VLANs so they can be routed to our other
subnets. To simmulate

the Nortel switch, I am using the Cisco 3548 to work out the
configuration.

What I have done is created the VLANs on the Cisco 3548. Configured
fa0/1 as a trunk.

I am using dot1q as the trunk protocol. Configured the trunk to allow
only VLANs 1,

100, and 200. Vtp is set to transparent.

On the Cisco 2948G-L3 I configured fa44 with three
subinterfaces:fa44.1, fa44.100, and

fa44.200. They are configure with dot1q and fa44.100 and fa44.200
have ip addresses

assigned. I made fa44.1 a member of bridge-group 111.

BVI111 on the Cisco 2948G-L3 has ip address 192.168.11.1 255.255.255.0
and VLAN 1 on the

Cisco 3548 has ip address 192.168.11.2 with a default gateway of
192.168.11.1.

-- A Basic Question:

I am assuming that the subinterfaces fa44.100 and fa44.20 on the Cisco
2948G-L3 will

route to the other BVIs. Is this correct?

-- My Problem So Far:

My bridging of VLAN1 does not work as I cannot ping the VLAN1 ip
addresses across the

trunk. I have not tried the other subnets yet, but if the bridging
doesn't work the

others probably aren't either.

Is there a way to confirm the trunk is working? The interfaces line
protocols are up.


Here is the config of my subinterfaces on the Cisco 2948G-L3 where the
trunk comes in.

interface FastEthernet44
no ip address
no ip directed-broadcast
!
interface FastEthernet44.1
encapsulation dot1Q 1 native
no ip directed-broadcast
bridge-group 111
!
interface FastEthernet44.100
encapsulation dot1Q 100
ip address 192.168.8.1 255.255.255.0
ip helper-address 192.168.3.4
no ip directed-broadcast
!
interface FastEthernet44.200
encapsulation dot1Q 200
ip address 192.168.10.1 255.255.255.0
ip helper-address 192.168.3.4
no ip directed-broadcast


Here is the trunk on the Cisco 3548

interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,100,200,1002-1005
switchport mode trunk

Any suggestions will be appreciated.

 
Reply With Quote
 
 
 
 
tman
Guest
Posts: n/a
 
      09-19-2008
On Sep 18, 6:13*pm, tman <(E-Mail Removed)> wrote:
> Hope this is not to verbose.
>
> -- What I am trying to do:
>
> I am trying to configure a Cisco 2948G-L3 and a Cisco 3548 for vlan
> trunking. *I am
>
> currently using the Cisco 2948G-L3 as a router. *It is not configured
> with VLANs, it has
>
> various groups of ports configured in seven different BVIs. *Each BVI
> has an ip assigned
>
> and acts as the default gateway for end stations on its respective
> subnet. *This all
>
> works great and we have used it for years.
>
> I am now trying to figure out how to configure the Cisco 2948G-L3 to
> terminate a VLAN
>
> trunk from a Nortel switch that we will be getting soon for some
> wireless phones. *We
>
> will also be using the Nortel wireless network for a few wireless
> workstations and
>
> laptops. We will have four VLANs on the Nortel switch. *Two of them do
> not need to trunk
>
> to the Cisco 2948G-L3 as they will have ports on the Nortel switch
> assigned to them to
>
> get to devices.
>
> I also thought I would create and additional BVI, Bridge-group 111 on
> the Cisco 2948G-L3
>
> to bridge VLAN1 to the other switch for management.
>
> We do want to trunk two VLANs so they can be routed to our other
> subnets. *To simmulate
>
> the Nortel switch, I am using the Cisco 3548 to work out the
> configuration.
>
> What I have done is created the VLANs on the Cisco 3548. *Configured
> fa0/1 as a trunk.
>
> I am using dot1q as the trunk protocol. *Configured the trunk to allow
> only VLANs 1,
>
> 100, and 200. Vtp is set to transparent.
>
> On the Cisco 2948G-L3 I configured fa44 with three
> subinterfaces:fa44.1, fa44.100, and
>
> fa44.200. *They are configure with dot1q and fa44.100 and fa44.200
> have ip addresses
>
> assigned. *I made fa44.1 a member of bridge-group 111.
>
> BVI111 on the Cisco 2948G-L3 has ip address 192.168.11.1 255.255.255.0
> and VLAN 1 on the
>
> Cisco 3548 has ip address 192.168.11.2 with a default gateway of
> 192.168.11.1.
>
> -- A Basic Question:
>
> I am assuming that the subinterfaces fa44.100 and fa44.20 on the Cisco
> 2948G-L3 will
>
> route to the other BVIs. *Is this correct?
>
> -- My Problem So Far:
>
> My bridging of VLAN1 does not work as I cannot ping the VLAN1 ip
> addresses across the
>
> trunk. *I have not tried the other subnets yet, but if the bridging
> doesn't work the
>
> others probably aren't either.
>
> Is there a way to confirm the trunk is working? *The interfaces line
> protocols are up.
>
> Here is the config of my subinterfaces on the Cisco 2948G-L3 where the
> trunk comes in.
>
> interface FastEthernet44
> *no ip address
> *no ip directed-broadcast
> !
> interface FastEthernet44.1
> *encapsulation dot1Q 1 native
> *no ip directed-broadcast
> *bridge-group 111
> !
> interface FastEthernet44.100
> *encapsulation dot1Q 100
> *ip address 192.168.8.1 255.255.255.0
> *ip helper-address 192.168.3.4
> *no ip directed-broadcast
> !
> interface FastEthernet44.200
> *encapsulation dot1Q 200
> *ip address 192.168.10.1 255.255.255.0
> *ip helper-address 192.168.3.4
> *no ip directed-broadcast
>
> Here is the trunk on the Cisco 3548
>
> interface FastEthernet0/1
> *switchport trunk encapsulation dot1q
> *switchport trunk allowed vlan 1,100,200,1002-1005
> *switchport mode trunk
>
> Any suggestions will be appreciated.


Finally got it working. I had forgotten the route ip command on the
new BVI, bridgegroup 111.
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
VLAN Trunking and Routing Qs Bob Simon Cisco 5 11-20-2008 11:33 PM
VLAN Security vs. Inter-VLAN Routing JohnD Cisco 3 12-18-2007 11:07 PM
VLAN Trunking/Routing Problem mnkyb0i Cisco 0 06-25-2007 11:03 PM
business layer, data access layer , presentation layer for asp.net using C#.net Dhananjay ASP .Net 1 12-18-2006 11:35 PM
Using CISCO ASA 5510 as layer 3 for inter-Vlan routing WabukiSensei Cisco 4 12-06-2006 04:24 AM



Advertisments