Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > Debugging problem

Reply
Thread Tools

Debugging problem

 
 
Kevin
Guest
Posts: n/a
 
      08-25-2003
I've been unable to debug a .NET web application with Visual Studio.
Every time I try to run it, I get the error message:

Error while trying to run project: Unable to start debugging on the
web server. Server side-error occurred on sending debug HTTP request.

I know there are several posts from users who experienced the same
problem, but none of the solutions are working for me. Based on
information I read in previous posts, the gotdotnet and microsoft
websites, as well as VS help, I have tried the following things:


-Added new account ASPNET and ensured that process aspnet_wp.exe is
running.

-Verified that web.config is properly formed with no syntax errors and
has the debug attribute set to true.

-Reinstalled the dotnet framework

-Verified IIS security settings and gave the web application a name in
the Properties dialog box for the application.


I'm running Windows XP Pro with IIS 5.1. If anyone has any other
suggestions on how to resolve the problem, please let me know.

Thanks,

Kevin
 
Reply With Quote
 
 
 
 
Tap
Guest
Posts: n/a
 
      08-25-2003
Do you have permission set for that application folder on
the IIS ?

>-----Original Message-----
>I've been unable to debug a .NET web application with

Visual Studio.
>Every time I try to run it, I get the error message:
>
>Error while trying to run project: Unable to start

debugging on the
>web server. Server side-error occurred on sending debug

HTTP request.
>
>I know there are several posts from users who experienced

the same
>problem, but none of the solutions are working for me.

Based on
>information I read in previous posts, the gotdotnet and

microsoft
>websites, as well as VS help, I have tried the following

things:
>
>
>-Added new account ASPNET and ensured that process

aspnet_wp.exe is
>running.
>
>-Verified that web.config is properly formed with no

syntax errors and
>has the debug attribute set to true.
>
>-Reinstalled the dotnet framework
>
>-Verified IIS security settings and gave the web

application a name in
>the Properties dialog box for the application.
>
>
>I'm running Windows XP Pro with IIS 5.1. If anyone has

any other
>suggestions on how to resolve the problem, please let me

know.
>
>Thanks,
>
>Kevin
>.
>

 
Reply With Quote
 
 
 
 
Kevin
Guest
Posts: n/a
 
      08-27-2003
I have it set to allow for anonymous access and integrated Windows
authentication. Is this what you are referring to?


"Tap" <(E-Mail Removed)> wrote in message news:<00d601c36b32$b618eed0$(E-Mail Removed)>...
> Do you have permission set for that application folder on
> the IIS ?
>
> >-----Original Message-----
> >I've been unable to debug a .NET web application with

> Visual Studio.
> >Every time I try to run it, I get the error message:
> >
> >Error while trying to run project: Unable to start

> debugging on the
> >web server. Server side-error occurred on sending debug

> HTTP request.
> >
> >I know there are several posts from users who experienced

> the same
> >problem, but none of the solutions are working for me.

> Based on
> >information I read in previous posts, the gotdotnet and

> microsoft
> >websites, as well as VS help, I have tried the following

> things:
> >
> >
> >-Added new account ASPNET and ensured that process

> aspnet_wp.exe is
> >running.
> >
> >-Verified that web.config is properly formed with no

> syntax errors and
> >has the debug attribute set to true.
> >
> >-Reinstalled the dotnet framework
> >
> >-Verified IIS security settings and gave the web

> application a name in
> >the Properties dialog box for the application.
> >
> >
> >I'm running Windows XP Pro with IIS 5.1. If anyone has

> any other
> >suggestions on how to resolve the problem, please let me

> know.
> >
> >Thanks,
> >
> >Kevin
> >.
> >

 
Reply With Quote
 
Scott M.
Guest
Posts: n/a
 
      08-27-2003
Is your ASPNET account a memeber of the Debugger Users and VS Developers
groups?


"Kevin" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed) om...
> I have it set to allow for anonymous access and integrated Windows
> authentication. Is this what you are referring to?
>
>
> "Tap" <(E-Mail Removed)> wrote in message

news:<00d601c36b32$b618eed0$(E-Mail Removed)>...
> > Do you have permission set for that application folder on
> > the IIS ?
> >
> > >-----Original Message-----
> > >I've been unable to debug a .NET web application with

> > Visual Studio.
> > >Every time I try to run it, I get the error message:
> > >
> > >Error while trying to run project: Unable to start

> > debugging on the
> > >web server. Server side-error occurred on sending debug

> > HTTP request.
> > >
> > >I know there are several posts from users who experienced

> > the same
> > >problem, but none of the solutions are working for me.

> > Based on
> > >information I read in previous posts, the gotdotnet and

> > microsoft
> > >websites, as well as VS help, I have tried the following

> > things:
> > >
> > >
> > >-Added new account ASPNET and ensured that process

> > aspnet_wp.exe is
> > >running.
> > >
> > >-Verified that web.config is properly formed with no

> > syntax errors and
> > >has the debug attribute set to true.
> > >
> > >-Reinstalled the dotnet framework
> > >
> > >-Verified IIS security settings and gave the web

> > application a name in
> > >the Properties dialog box for the application.
> > >
> > >
> > >I'm running Windows XP Pro with IIS 5.1. If anyone has

> > any other
> > >suggestions on how to resolve the problem, please let me

> > know.
> > >
> > >Thanks,
> > >
> > >Kevin
> > >.
> > >



 
Reply With Quote
 
Kevin
Guest
Posts: n/a
 
      08-27-2003
I'm not sure.. how do I verify this?

"Scott M." <(E-Mail Removed)> wrote in message news:<#$(E-Mail Removed)>...
> Is your ASPNET account a memeber of the Debugger Users and VS Developers
> groups?
>
>
> "Kevin" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed) om...
> > I have it set to allow for anonymous access and integrated Windows
> > authentication. Is this what you are referring to?
> >
> >
> > "Tap" <(E-Mail Removed)> wrote in message

> news:<00d601c36b32$b618eed0$(E-Mail Removed)>...
> > > Do you have permission set for that application folder on
> > > the IIS ?
> > >
> > > >-----Original Message-----
> > > >I've been unable to debug a .NET web application with

> Visual Studio.
> > > >Every time I try to run it, I get the error message:
> > > >
> > > >Error while trying to run project: Unable to start

> debugging on the
> > > >web server. Server side-error occurred on sending debug

> HTTP request.
> > > >
> > > >I know there are several posts from users who experienced

> the same
> > > >problem, but none of the solutions are working for me.

> Based on
> > > >information I read in previous posts, the gotdotnet and

> microsoft
> > > >websites, as well as VS help, I have tried the following

> things:
> > > >
> > > >
> > > >-Added new account ASPNET and ensured that process

> aspnet_wp.exe is
> > > >running.
> > > >
> > > >-Verified that web.config is properly formed with no

> syntax errors and
> > > >has the debug attribute set to true.
> > > >
> > > >-Reinstalled the dotnet framework
> > > >
> > > >-Verified IIS security settings and gave the web

> application a name in
> > > >the Properties dialog box for the application.
> > > >
> > > >
> > > >I'm running Windows XP Pro with IIS 5.1. If anyone has

> any other
> > > >suggestions on how to resolve the problem, please let me

> know.
> > > >
> > > >Thanks,
> > > >
> > > >Kevin
> > > >.
> > > >

 
Reply With Quote
 
Scott M.
Guest
Posts: n/a
 
      08-28-2003
On the machine that has the ASPNET account, go into Control Panel and then
Administrative Tools then Computer Management.

Once there expand the Local Users And Groups section. Under Users, double
click the ASPNET account and look at the tab called Member Of.

By default, the ASPNET account is not a member of the Debugger Users or VS
Developers groups, so don't be surprised to not see these groups listed.

If they are not listed, then go into the Groups section and then the
Debugger Users group. Add the ASPNET account to that group, then repeat the
process for the VS Developers group.

Hope this helps!


"Kevin" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed) om...
> I'm not sure.. how do I verify this?
>
> "Scott M." <(E-Mail Removed)> wrote in message

news:<#$(E-Mail Removed)>...
> > Is your ASPNET account a memeber of the Debugger Users and VS Developers
> > groups?
> >
> >
> > "Kevin" <(E-Mail Removed)> wrote in message
> > news:(E-Mail Removed) om...
> > > I have it set to allow for anonymous access and integrated Windows
> > > authentication. Is this what you are referring to?
> > >
> > >
> > > "Tap" <(E-Mail Removed)> wrote in message

> > news:<00d601c36b32$b618eed0$(E-Mail Removed)>...
> > > > Do you have permission set for that application folder on
> > > > the IIS ?
> > > >
> > > > >-----Original Message-----
> > > > >I've been unable to debug a .NET web application with

> > Visual Studio.
> > > > >Every time I try to run it, I get the error message:
> > > > >
> > > > >Error while trying to run project: Unable to start

> > debugging on the
> > > > >web server. Server side-error occurred on sending debug

> > HTTP request.
> > > > >
> > > > >I know there are several posts from users who experienced

> > the same
> > > > >problem, but none of the solutions are working for me.

> > Based on
> > > > >information I read in previous posts, the gotdotnet and

> > microsoft
> > > > >websites, as well as VS help, I have tried the following

> > things:
> > > > >
> > > > >
> > > > >-Added new account ASPNET and ensured that process

> > aspnet_wp.exe is
> > > > >running.
> > > > >
> > > > >-Verified that web.config is properly formed with no

> > syntax errors and
> > > > >has the debug attribute set to true.
> > > > >
> > > > >-Reinstalled the dotnet framework
> > > > >
> > > > >-Verified IIS security settings and gave the web

> > application a name in
> > > > >the Properties dialog box for the application.
> > > > >
> > > > >
> > > > >I'm running Windows XP Pro with IIS 5.1. If anyone has

> > any other
> > > > >suggestions on how to resolve the problem, please let me

> > know.
> > > > >
> > > > >Thanks,
> > > > >
> > > > >Kevin
> > > > >.
> > > > >



 
Reply With Quote
 
Kevin
Guest
Posts: n/a
 
      08-28-2003
Scott,

I added ASPNET to the Debugger Users and VS Developers groups as you
instructed, and rebooted. I tried to run the program again, but still
got the same error. I have verified that the ASPNET account was added
to both groups correctly, and don't know what else to check at this
point. Do you have any other suggestions?

Thanks for your help,

Kevin


"Scott M." <(E-Mail Removed)> wrote in message news:<(E-Mail Removed)>...
> On the machine that has the ASPNET account, go into Control Panel and then
> Administrative Tools then Computer Management.
>
> Once there expand the Local Users And Groups section. Under Users, double
> click the ASPNET account and look at the tab called Member Of.
>
> By default, the ASPNET account is not a member of the Debugger Users or VS
> Developers groups, so don't be surprised to not see these groups listed.
>
> If they are not listed, then go into the Groups section and then the
> Debugger Users group. Add the ASPNET account to that group, then repeat the
> process for the VS Developers group.
>
> Hope this helps!
>
>
> "Kevin" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed) om...
> > I'm not sure.. how do I verify this?
> >
> > "Scott M." <(E-Mail Removed)> wrote in message

> news:<#$(E-Mail Removed)>...
> > > Is your ASPNET account a memeber of the Debugger Users and VS Developers
> > > groups?
> > >
> > >
> > > "Kevin" <(E-Mail Removed)> wrote in message
> > > news:(E-Mail Removed) om...
> > > > I have it set to allow for anonymous access and integrated Windows
> > > > authentication. Is this what you are referring to?
> > > >
> > > >
> > > > "Tap" <(E-Mail Removed)> wrote in message

> news:<00d601c36b32$b618eed0$(E-Mail Removed)>...
> > > > > Do you have permission set for that application folder on
> > > > > the IIS ?
> > > > >
> > > > > >-----Original Message-----
> > > > > >I've been unable to debug a .NET web application with

> Visual Studio.
> > > > > >Every time I try to run it, I get the error message:
> > > > > >
> > > > > >Error while trying to run project: Unable to start

> debugging on the
> > > > > >web server. Server side-error occurred on sending debug

> HTTP request.
> > > > > >
> > > > > >I know there are several posts from users who experienced

> the same
> > > > > >problem, but none of the solutions are working for me.

> Based on
> > > > > >information I read in previous posts, the gotdotnet and

> microsoft
> > > > > >websites, as well as VS help, I have tried the following

> things:
> > > > > >
> > > > > >
> > > > > >-Added new account ASPNET and ensured that process

> aspnet_wp.exe is
> > > > > >running.
> > > > > >
> > > > > >-Verified that web.config is properly formed with no

> syntax errors and
> > > > > >has the debug attribute set to true.
> > > > > >
> > > > > >-Reinstalled the dotnet framework
> > > > > >
> > > > > >-Verified IIS security settings and gave the web

> application a name in
> > > > > >the Properties dialog box for the application.
> > > > > >
> > > > > >
> > > > > >I'm running Windows XP Pro with IIS 5.1. If anyone has

> any other
> > > > > >suggestions on how to resolve the problem, please let me

> know.
> > > > > >
> > > > > >Thanks,
> > > > > >
> > > > > >Kevin
> > > > > >.
> > > > > >

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I skip debugging Ajax when debugging my code? AAaron123 ASP .Net 3 07-28-2009 04:07 PM
Debugging C vs debugging C++ jacob navia C Programming 11 10-27-2006 07:19 PM
Debugging Problem Stephen Noronha ASP .Net 0 09-02-2005 09:49 PM
Problem Debugging COM componenets from ASP.NET =?Utf-8?B?U2FuZHVyZWE=?= ASP .Net 0 07-29-2005 09:04 AM
No Debugging of C# Server-Side Script, but Code-Behind Debugging Works Johann Blake ASP .Net 1 01-05-2004 03:01 PM



Advertisments