Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Computer Information > Re: I have deleted a Key in REGEDIT. help!

Reply
Thread Tools

Re: I have deleted a Key in REGEDIT. help!

 
 
jameshanley39@yahoo.co.uk
Guest
Posts: n/a
 
      08-14-2008
On 14 Aug, 13:36, Adriano <(E-Mail Removed)> wrote:
> Hi, I have just deleted erroneally a Key in REGEDIT and now when I
> turn on my PC goes out a blue screening with 2 Accounts: Administrator
> and mine. But if I click on both it cannot load up the desktop and I
> always see the blue screening with 2 Account. It is blocked there. *I
> cannot use any function of my PC.
> If I can enter in my REGEDIT I can restore it because I remember
> perfectly the wrong steps.
> thanks for your help.



Can you go in in Safe Mode?
If so, then 2 good options, very quick to do
- try to do the key yourself (For fun. if it works, great, if not,
then see next thing)
- do a win xp system restore. (that is very quick and if your
description is accurate, it will fix it ! It can fix many things!
'cos it pushed the registry back to when things were fine )

I would do them in that order..


Another option is a preinstallation environment, like BartPE or WinXP
PE.
It's a common thing to do with it, but not quite as simple as just
running regedit. Good skill to know.. I haven't tried it yet. Great
also for if malware has stopped a key from being deleted(e.g. when you
can go into windows).

you could do a Win XP Repair installation..
this link, first from google, is great explaining that.
http://www.michaelstevenstech.com/XPrepairinstall.htm
That would fix it, and it's easy, but it's the longest route.



slightly rubbish note-
If it could be done from a DOS boot disk, or even from another windows
installation. Any OS that loads. In theory it's possible. I mentioned
win xp pe style things.
There is this thing, but maybe it only works from a command shell on
the current registry http://commandwindows.com/reg.htm
so no use. But DOS users may know of something.
 
Reply With Quote
 
 
 
 
Ragnar
Guest
Posts: n/a
 
      08-14-2008

"Adriano" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Thanks a lot for your advice!
>
>>Can you go in in Safe Mode?
>>If so, then 2 good options, very quick to do
>> - try to do the key yourself (For fun. if it works, great, if not,
>>then see next thing)

>
> I'm sorry but I am not an esxpet guy and I don't understand fine.
> I have just gone in Safe Mode and I have tried the latest
> working configuration but it doesn't work. I always get the same blue
> screening.
>
>> - do a win xp system restore. (that is very quick and if your
>>description is accurate, it will fix it ! It can fix many things!
>>'cos it pushed the registry back to when things were fine )

>
> Could you explain in more detailed mode please?
>
> thanks


In Safe Mode
Start / Run then type in
%SystemRoot%\system32\restore\rstrui.exe

HTH
R.


 
Reply With Quote
 
 
 
 
jameshanley39@yahoo.co.uk
Guest
Posts: n/a
 
      08-14-2008
On 14 Aug, 15:38, Adriano <(E-Mail Removed)> wrote:
> Thanks a lot for your advice!
>
> >Can you go in in Safe Mode?
> >If so, then 2 good options, very quick to do
> > * *- try to do the key yourself (For fun. if it works, great, if not,
> >then see next thing)

>
> I'm sorry but I am not an esxpet guy and I don't understand fine.
> I have just gone in Safe Mode and I have tried the latest
> working configuration but it doesn't work. I always get the same blue
> screening.
>
> > * - do a win xp system restore. (that is very quick and if your
> >description is accurate, it will fix it ! *It can fix many things!
> >'cos it pushed the registry back to when things were fine )

>
> Could you explain in more detailed mode please?
>
> thanks


You ask exactly the right question.

My first response was a terse technical response that would only work
for techies. It is for other technical people to question or comment,
and we coud find the technical solutions without the ABCs..
You could then ask and get an elaboration written for an end user..
such as yourself.
It's good that you did. Most end users would have run away.. (I like
that). But since you didn't run away, that's good, I like that too.

Now, you managed with the F8, got into Safe mode. And got a blue
screen.
ok..
I was suggesting as a possible solution Windows XP System restore,
which is a setting you do within windows (Not related to the F8 menu
offering "last known good configuration", which you thought I meant).
But you can't get into windows at all, not even in Safe Mode.. So you
can't do a Win XP System Restore

A standard step if you can't get into windows 'cos it crashes, and if
you can't even get into safe mode, then certainly, a windows xp
repair installation is a great option.

You need your Windows XP CD.
You need to Boot off of it..

(This involves changing the boot sequence in your BIOS to boot from a
CD/CDROM/DVD drive, whatever your BIOS calls it.
So you hit DEL or F2 or whatever key it is, to go to your BIOS, you do
this as soon as the computer starts.)

But you may not need to. It may be already changed..


As a techie, I would check my boot sequence...

But you could put your Windows XP CD in and see if you can boot from
it.
One of 2 things will happen..
a)
You will get a blue screen saying windows setup.. (maybe you'll get
some writing up that says "Boot from CD" , press any Key, and it
should boot from the CD. Then you get a nice blue screen of the
windows setup). This is not a BSOD(blue screen of death), liks a
crash screen.
It's a screen that looks a bit like this
http://www.microsoft.com/library/med...e-to-setup.jpg
e.g. says something like Windows XP setup. And gives you options.

Your aim has to be to get that kind of screen

b)it goes straight into windows. In which case it didn't boot from the
CD. and you have to change your boot sequence in the BIOS, to boot
from CD.
How to do this can vary from BIOS to BIOS.
This page may help
http://pcsupport.about.com/od/fixthe...erchange_6.htm

I found this great page, a bios setup simulator on a webpage!
http://appro.mit.jyu.fi/tools/biossimu/simu.html
Does your BIOS look like that?
That's the phoenix BIOS.
When you do Del or whatever on your machine after turning it on. To go
to the BIOS.
You would go to "Advanced BIOS Features" and then see where it says
"First Boot Device", and then change it to CDROM. Then as it says on
the bottom. F10 to Save, and Y for Yes. And reboot with Win XP
installation CD in there.

And hopefully it will boot off of it.

Let us know if you can get to that point..


You would then do a windows xp repair installation and your data will
probably be OK but it is better to back it up..

slight techie note - (commonly used by techies with end users.
treesize by jam, can show how many MB used by directories, can thus
locate alot . Can also free up space so is very good.. windows search
of docs,jpg,xls, common extensions particularly the ones the end uesr
uses.. Another thing is to go into ms word and excel and see where it
is saving files.. Often after a reinstall one has to poitn those
programs to the directories where the data files will be stored. Good
to store data files in one directory, or within subdirectories of it.)

slight techie note- regarding F8 to go to safe mode.. there could have
been a few issues.. one way is hit F8 like a mother****er/man
possessed.. as soon as comp turns on. can beep though if done too
many times, which is annoying. In really difficult situations, I
found a great method that works for many.. Is go into the BIOS, Exit
it, then start hitting F8 immediately.. Sometimes leaving the BIOS
maybe doesn't reboot and so the F8 gets perfectly timed. Sometimes
there are UISB issues.. one option is to set legacy USB enabled if it
isn't already, another is to use a Ps2 keyboard.

 
Reply With Quote
 
jameshanley39@yahoo.co.uk
Guest
Posts: n/a
 
      08-14-2008
On 14 Aug, 16:21, "Ragnar" <(E-Mail Removed)> wrote:
> "Adriano" <(E-Mail Removed)> wrote in message
>
> news:(E-Mail Removed)...
>
>
>
>
>
> > Thanks a lot for your advice!

>
> >>Can you go in in Safe Mode?
> >>If so, then 2 good options, very quick to do
> >> * *- try to do the key yourself (For fun. if it works, great, if not,
> >>then see next thing)

>
> > I'm sorry but I am not an esxpet guy and I don't understand fine.
> > I have just gone in Safe Mode and I have tried the latest
> > working configuration but it doesn't work. I always get the same blue
> > screening.

>
> >> * - do a win xp system restore. (that is very quick and if your
> >>description is accurate, it will fix it ! *It can fix many things!
> >>'cos it pushed the registry back to when things were fine )

>
> > Could you explain in more detailed mode please?

>
> > thanks

>
> In Safe Mode
> Start / Run then type in
> %SystemRoot%\system32\restore\rstrui.exe
>
> HTH
> R.-




echo %systemroot% <-- "e.g." c:\windows

rstrui.exe <-- System Restore !

btw, he can't get into windows. Not even in Safe Mode.. so he can't do
that.

Given that he can't even get in even in safe mode.. due to some
windows crash. I see the obvious option of win xp repair
installation.


 
Reply With Quote
 
Paul
Guest
Posts: n/a
 
      08-14-2008
Adriano wrote:
> I'm sorry but I don't undestand your writings. What is the problem?
>


Examine the header of the message carefully. It was not written
by the same person who had been responding to you previously.

Paul
 
Reply With Quote
 
jameshanley39@yahoo.co.uk
Guest
Posts: n/a
 
      08-15-2008
On 14 Aug, 23:42, Adriano <(E-Mail Removed)> wrote:
> I'm sorry but I don't succeed to install the OP or to use Windows XP
> System restore. I have tied many times. My PC is complicated, in fact
> I have one HD with OS and other HDs with RAID0.
> I have PC5W DH Deluxe Motherboard and when I press on F6 to load the
> drivers my PC works to load them but in in short time a writing tells
> me there aren't HDs in my PC. This is a frustrating job.
> I don't know how I could solve this problem. I thibk the next days I
> will bring my PC to the technician. I'd like to solve my problem I
> myself because I have to do 40 km and I have to unplug many cables on
> it.
> A time full of worries!!!
>


you could try the Asus (web) forum

http://vip.asus.com/forum/topic.aspx...Language=en-us

with that link you get the list of forum topics, Motherboard is there
between multimedia and mobile phone. It says motherboard 404

maybe you could call a technician from the local paper


 
Reply With Quote
 
jameshanley39@yahoo.co.uk
Guest
Posts: n/a
 
      08-15-2008
<snip>

Another thing you can try..
This link http://www.hardwaregeeks.com/board/s...ad.php?t=25804

suggests
a)a ps2 keyboard
b)hammering at F6 repeatedly, straight away..

the suggestion of ps2 keyboard is because they always respond
immediately.. whereas USB ones could have some issues with an
immediate response. Out of interest, is your USB keyboard capable of
going into the BIOS? If so, the USB keyboard is probably fine.

Are you even getting the screen that asks for a RAID driver?

You have the RAID driver on - say - on an internal or USB floppy
drive

I don't know about "from", but I think it is the case.. that when
installing windows -to- a RAID drive, it needs the driver, so, F6.
If you install to a non-RAID, but have RAID drives installed, then it
can install without one. And detects the RAID drives once in Windows.

Many sites talk about F6 for - wait for it - SATA , but actually SATA
is no different from IDE here. IT's only when they are RAID that you
have this issue. Apparently some MBRDs have SATA-RAID. I guess even on
the standard IDE controllers.

I see it does load them so you get that screen.

Here is what you do as a next step..

Enter here the EXACT error message that you get when it says there are
no hard drives in your PC. That will get results..

BTW, this link
http://www.techsupportforum.com/hard...-detected.html
mentions about Pressing "F10", to get a RAID menu, that may be worth a
try.. He is probably referring to something at the screen that asks
you to go to the BIOS. So it's a function key that gets you to a
RAID BIOS screen, and I would bet that it may be any function key..

It also suggests something rather obvious, which is trying different
hard drives in place of the one " " with the problem " ". Do others
trigger this issue?

Another thing, is RAID, including RAID-0, may require more than one
hard drive. So try plugging another one in. Have 2 in.

And you may need to configure the RAID array first.. Like, go to the
RAID boot menu in the BIOS. You may just manage to configure it by
experimentation. If it says it's not set up propertly or something,
then you know that's is a suspect for being the cause.


 
Reply With Quote
 
jameshanley39@yahoo.co.uk
Guest
Posts: n/a
 
      08-15-2008
<snip>
just to add

http://www.techsupportforum.com/hard...-resolved.html

"Installing Windows XP to RAID 0"

A non techie wrote.. that he had this error(seems same as yours. (He
had the sense to type it in word for word - this is for the sake of
google), and he says he solved it and describes how.

"Setup did not find any hard disk drives installed in your computer.
Make sure any hard disk drives are powered on and properly connected
to your computer (they are properly connected), and that any disk-
related hardware configuration is correct. This may involve running a
manufactuer-supplied diagnostic or setup program. Setup cannot
continue. To quit Setup, press F3."

"Alright guys, I think I've got it all figured out now. The computer
actually had two raids. That made things really confusing. I had the
floppy with the drivers for one of them, but not the other. Finally I
got the other floppy, and formatted it, and am currently installing xp
pro. "

You should download the drivers from the website of your motherboard
manufacturer, Asus.


This one
http://www.techimo.com/forum/general...indows-xp.html

the questioner says he thinks it needs windows xp sp2 (I don't know
how correct that is though and it probably doesn't relate to your
error either)

 
Reply With Quote
 
Paul
Guest
Posts: n/a
 
      08-17-2008
Adriano wrote:
> Hi, in my PC I have unpluged a cable of an HD and I have hooked the
> sick HD to that cable. With a different HD now I can see every folder
> and file of the sick HD. I have changed the sick REGEDIT with a new
> REGEDIT but this doesn't work again.
> Is there a program that repair the problem of the sick REGEDIT?
> Thanks for some info.
>
>


Regedit is the program that edits the registry. It is not the
registry itself.

This article, contains a lot of information about the registry.
The registry consists of more than one file.

http://en.wikipedia.org/wiki/Windows_Registry

There is an example here, of running the Recovery Console. Basically,
what they're trying to do, is rename the system32\config copy
of "system" file to "system.bak". Then, copy an old copy of the
"system" file, from c:\windows\repair\system. That file is from
the time that the system was installed, and will be missing a lot
of information. Similarly, you can repeat the exercise for
the "software" file, renaming it to "software.bak". Then
copy the c:\windows\repair\software file, to take the place
of the "software" file that was renamed.

http://www.kellys-korner-xp.com/xp_sys32.htm

Doing these commands from the recovery console, will likely
preserve the file system attributes expected for a registry
file. If you just copy the file, while the disk is mounted as
"D:" on another computer, I cannot imagine what a mess that
would create. NTFS has the notion of permissions and attributes,
and if done without attention to those details, the operating
system might not like the file, when you next attempt to reboot.

I'm just trying to look up some suggestions, based on what
the poster "noname" is suggesting in the Asus group. Maybe
you'll get more answers by using two USENET threads, but it
is a bit confusing for me.

Instructions for getting into the Recovery Console, start
at "Figure E" on the following page. Below "Figure H" is
a list of commands you can use in the Recovery Console.

http://articles.techrepublic.com.com...1-5835305.html

Some examples of commands once you get into the Recovery Console.)

cd system32\config Change to the config directory
dir system List all files named "system"
ren system system.bak Rename the existing system hive
copy c:\windows\repair\system Copies "system" from repair
to the current directory "config"
exit Reboot computer using new system hive.

Hope that helps,
Paul
 
Reply With Quote
 
jameshanley39@yahoo.co.uk
Guest
Posts: n/a
 
      08-17-2008
On 17 Aug, 02:43, Paul <(E-Mail Removed)> wrote:
> Adriano wrote:
> > Hi, in my PC I have unpluged a cable of an HD and I have hooked the
> > sick HD to that cable. With a different HD now I can see every folder
> > and file of the sick HD. I have changed the sick REGEDIT with a new
> > REGEDIT but this doesn't work again.
> > Is there a program that repair the problem of the sick REGEDIT?
> > Thanks for some info.

>
> Regedit is the program that edits the registry. It is not the
> registry itself.
>
> This article, contains a lot of information about the registry.
> The registry consists of more than one file.
>
> http://en.wikipedia.org/wiki/Windows_Registry
>
> There is an example here, of running the Recovery Console. Basically,
> what they're trying to do, is rename the system32\config copy
> of "system" file <snip>


quite useful to know...that the registry in xp is stored in these 2
files
\WINDOWS\SYSTEM32\CONFIG\SYSTEM
\WINDOWS\SYSTEM32\CONFIG\SOFTWARE

one could make one's own backup.. in one's own location.

It would be less targetted by malware than system restore. And
typically the registry is the only thing I want system restore to deal
with anyway. I don't like xp's 'system restore' removing files.

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Re: Are deleted pictures REALLY deleted? khoshhon@gmail.com Computer Support 3 01-01-2009 08:53 AM
Re: Are deleted pictures REALLY deleted? John Holmes Computer Support 7 12-31-2008 04:46 PM
Re: Are deleted pictures REALLY deleted? Bucky Breeder Computer Support 0 12-31-2008 02:58 PM
Record not being deleted in dbase, even tho the display on datagrid is deleted.. Chumley the Walrus ASP .Net Web Controls 2 08-10-2004 02:23 PM



Advertisments