Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Windows 64bit > WPF Media Player causing problem on 64-bit Windows 2008

Reply
Thread Tools

WPF Media Player causing problem on 64-bit Windows 2008

 
 
Faisal Shafiq
Guest
Posts: n/a
 
      08-09-2008
I have created a windows service in C# using Visual Studio 2008. This
windows
service is meant to synchronize the Video Content information that has been
uploaded into an SLS (Silverlight Streaming Service) account. In order to
get
a video's meta information (such as duration etc.) and generate it's
thumbnail without downloading it to our server, I am using WPF's MediaPlayer
class.

The service works fine in Windows Server 2003 32 bit and 64 bit edition.
However, it doesn't work in our deployment environment which is Windows
Server 2008 64 bit edition. The player simply fails to retrieve any video's
meta data and thumbnail generation doesn't work either. I don't have any
idea
what is going wrong here. Event Viewer seems to have no clue about the
problem. Can somebody please guide me towards the problem resolution as i
have already slipped my deadline.

Thanks

 
Reply With Quote
 
 
 
 
Charlie Russel - MVP
Guest
Posts: n/a
 
      08-09-2008
You'll want to post this on one of the MSDN forums appropriate to what
you're doing. This is primarily a consumer and IT pro newsgroup, and not a
developer group. The first test, it seems to me, is to try it in Server 2k8
32-bit, and see if the problem exists there. I suspect it will, since my
hunch is that you're using or expecting something that isn't available in
Server 2008, or isn't installed by default. Roles in Server 2k8 are far more
narrowly defined, and only the minimum services are enabled and exposed for
the roles installed.

--
Charlie.
"Faisal Shafiq" <(E-Mail Removed)> wrote in message
news:ezzI4uh%(E-Mail Removed)...
>I have created a windows service in C# using Visual Studio 2008. This
>windows
> service is meant to synchronize the Video Content information that has
> been
> uploaded into an SLS (Silverlight Streaming Service) account. In order to
> get
> a video's meta information (such as duration etc.) and generate it's
> thumbnail without downloading it to our server, I am using WPF's
> MediaPlayer
> class.
>
> The service works fine in Windows Server 2003 32 bit and 64 bit edition.
> However, it doesn't work in our deployment environment which is Windows
> Server 2008 64 bit edition. The player simply fails to retrieve any
> video's
> meta data and thumbnail generation doesn't work either. I don't have any
> idea
> what is going wrong here. Event Viewer seems to have no clue about the
> problem. Can somebody please guide me towards the problem resolution as i
> have already slipped my deadline.
>
> Thanks


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Windows 7, Media Player - Settings for Media Serving NOT being savedfor Home Group Tim Wells Windows 64bit 0 10-27-2009 01:26 PM
Windows Media Player - Download Media Info From Internet is Greyed Out Alan NZ Computing 3 02-27-2006 10:38 PM
mp3 player windows media player Bigfred Computer Support 1 10-28-2003 09:46 PM



Advertisments