Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > Odd clientID behaviour

Reply
Thread Tools

Odd clientID behaviour

 
 
John
Guest
Posts: n/a
 
      08-20-2003
Hi all,

I have a user control which I need tor eference in a javascript function on
the client. What I do is to sedn the name of that control down to the client
in a variable and the javascript function uses that variable to get the
element.

Now in my Page_Load event, I get the clientID of the control (an image
control) and put this into a variable. The value of this in debug is
"_ctl3_UCNutrients_imgNutritional". The javascript is not finding the
element because if I view the source, the value is rendered as
"_ctl4_UCNutrients_imgNutritional". Whay is this happening? How do I fix it?

Regards
John.


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Odd behavior with odd code Michael Speer C Programming 33 02-18-2007 07:31 AM
aspnet_compiler Odd Behaviour? Kulgan ASP .Net 1 07-21-2006 03:02 PM
39th month? Odd DateTime behaviour! =?Utf-8?B?ZGhucml2ZXJzaWRl?= ASP .Net 5 09-03-2005 07:50 AM
Odd behaviour of link colours? Peter Charles HTML 1 01-27-2004 10:21 PM
[ASP. NET VB .NET] clientID and ClientID Maras ASP .Net 1 10-15-2003 02:04 PM



Advertisments