Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > UK VOIP > Re: HELP: forwarding on SPA 3102??

Reply
Thread Tools

Re: HELP: forwarding on SPA 3102??

 
 
Sinna
Guest
Posts: n/a
 
      08-01-2008
Jose wrote:
> Hi All,
>
> Despite seeing, and using, the fields for forwarding in the "User1"
> tab of the SPA3102 interface, I can't get it to work...
>
> What am I missing, please?
>
> Furthermore, can I create rule that forwards only calls from numbers
> diferent than those starting with, say, 123?
>
> Thank you,
> Jose

Please provide what you already have, so we can take a look what's
wrong. The syntax is quite strict, so...


Sinna



 
Reply With Quote
 
 
 
 
Andrew Gabriel
Guest
Posts: n/a
 
      08-01-2008
In article <(E-Mail Removed)>,
http://www.velocityreviews.com/forums/(E-Mail Removed) (Jose) writes:
> On Fri, 01 Aug 2008 08:08:12 +0200, Sinna
> <(E-Mail Removed)> wrote:
>
>
>>Please provide what you already have, so we can take a look what's
>>wrong. The syntax is quite strict, so...

>
> Well, in the "User 1" tab, field "Cfwd No Ans Dest:", I've simply
> entered "+351123456789". That's all I have.


I don't think it will know what to do with the +

--
Andrew Gabriel
[email address is not usable -- followup in the newsgroup]
 
Reply With Quote
 
 
 
 
Brian A
Guest
Posts: n/a
 
      08-02-2008
On 01 Aug 2008 17:52:43 GMT, (E-Mail Removed) (Andrew
Gabriel) wrote:

>In article <(E-Mail Removed)>,
> (E-Mail Removed) (Jose) writes:
>> On Fri, 01 Aug 2008 08:08:12 +0200, Sinna
>> <(E-Mail Removed)> wrote:
>>
>>
>>>Please provide what you already have, so we can take a look what's
>>>wrong. The syntax is quite strict, so...

>>
>> Well, in the "User 1" tab, field "Cfwd No Ans Dest:", I've simply
>> entered "+351123456789". That's all I have.

>
>I don't think it will know what to do with the +

I agree. What you need to do is to put in the appropriate
international access code for the provider you want to use.
This can vary. If it is UK then it would be 00 but, if an Aussie
provider, for example, it might be 0011.

---
Remove 'no_spam_' from email address.
---
 
Reply With Quote
 
Steve Hayes
Guest
Posts: n/a
 
      08-04-2008
Jose wrote:

> On Sat, 02 Aug 2008 10:43:57 GMT, Brian A
> <(E-Mail Removed)> wrote:
>
>>>I don't think it will know what to do with the +

>>I agree. What you need to do is to put in the appropriate
>>international access code for the provider you want to use.
>>This can vary. If it is UK then it would be 00 but, if an Aussie

>
> OK, I've now added the 00 before the 351123456789. It still doesn't
> work...
>
> What do I need to check now?
>
> Thanks,
> Jose


A couple of things:

You should be able to set call forwarding from the phone. Unless you've
changed the various codes, *72 followed by the number you want to forward
to, entered just as you'd dial it normally using the routing you want (e.g.
you can use one of the single digit speed dials) should do the trick. You
can then look at the Cfwd All Dest field to see what's appeared there -
that's the format you need to use. *73 cancels call forwarding (or you can
clear the Cfwd All Dest field).

I suspect the problem you're having may be more fundamental though.

The SPA3102 forwarding seems to work fine (aside from echoes) between the
PSTN line and SIP and vice-versa. In this case, the call is being relayed
through the SPA3102 itself. If a SIP call is to be forwarded out on the
PSTN line, the number in Cfwd All Dest should end with @gw0.

Obviously, you can't forward a call that comes in on the PSTN line directly
back out to the PSTN since the SPA3102 only has one PSTN line although you
should be able to forward it via a SIP to PSTN gateway, e.g. as provided by
your SIP service provider.

From what I've seen (SIP experts will tell us if I'm wrong), forwarding an
incoming SIP call is completely different. The SPA3102 just sends a message
back to the originating end saying that the call is to go to whatever
number you've set. After that, the call doesn't touch your SPA3102 and it's
up to the originating end what to do about it. In my experience that's
quite likely to result in the call going nowhere and I don't think there's
anything you can do about it.

For example, suppose you try to forward calls to a mobile phone (in a
European caller-pays context). If you end the number with @gw0, incoming
SIP calls will be bridged to your PSTN line and you'll pay the PSTN for the
call to the mobile. Incoming PSTN calls will go nowhere.

If you leave off the @gw0, incoming PSTN calls will be routed to the mobile
via your SIP provider and you'll pay them for the call to the mobile.
However, incoming SIP calls will get an instruction redirecting them to
your mobile. The caller may not have a plan that allows them to call
mobiles and, even if they do, they think they are making a free call. Their
SIP client or provider will play it safe by just dropping the call.

If Linksys want to improve their product, making it possible to relay SIP
calls through the SPA3102 would be on my wish list though fixing the awful
echoes would come much higher.

--
Steve Hayes
South Wales, UK
----Remove colours from address----

 
Reply With Quote
 
Andrew Gabriel
Guest
Posts: n/a
 
      08-05-2008
In article <(E-Mail Removed)>,
(E-Mail Removed) (Jose) writes:
> On Mon, 04 Aug 2008 10:04:49 +0100, Steve Hayes
> <(E-Mail Removed)> wrote:
>
>>You should be able to set call forwarding from the phone. Unless you've
>>changed the various codes, *72 followed by the number you want to forward
>>
>>that's the format you need to use. *73 cancels call forwarding (or you can
>>clear the Cfwd All Dest field).

>
> Well, I don't think I'd able to remember to enter the *72 instruction,
> and then cancel it, when appropriate.
>
> What I really expect, is the device to work as would appear normal,
> given the field names, Forward on no answer,


That's *92<number>, *93 to cancel.

> and Forward when busy.


That's *90<number>, *91 to cancel.

> Not "Forward when I remember to do so".


There isn't one for that.

--
Andrew Gabriel
[email address is not usable -- followup in the newsgroup]
 
Reply With Quote
 
Steve Hayes
Guest
Posts: n/a
 
      08-05-2008
Jose wrote:

> On Mon, 04 Aug 2008 10:04:49 +0100, Steve Hayes
> <(E-Mail Removed)> wrote:
>
>>You should be able to set call forwarding from the phone. Unless you've
>>changed the various codes, *72 followed by the number you want to forward
>>
>>that's the format you need to use. *73 cancels call forwarding (or you can
>>clear the Cfwd All Dest field).

>
> Well, I don't think I'd able to remember to enter the *72 instruction,
> and then cancel it, when appropriate.
>
> What I really expect, is the device to work as would appear normal,
> given the field names, Forward on no answer, and Forward when busy.
> Not "Forward when I remember to do so".
>
>
>> If a SIP call is to be forwarded out on the
>>PSTN line, the number in Cfwd All Dest should end with @gw0.

>
> In the case of Forward when busy, I can live with that. So, should the
> number be something like 00351123456789@gw0 ?
>
>
>>Obviously, you can't forward a call that comes in on the PSTN line
>>directly back out to the PSTN since the SPA3102 only has one PSTN line
>>although you should be able to forward it via a SIP to PSTN gateway, e.g.
>>as provided by your SIP service provider.

>
> 1) PSTN to SIP: so, if I want to forward the call throug gw2, I should
> enter something like 00351123456789@gw2 right, in, say, the Forward
> when no answer field? It's not working (
>
> 2) SIP to PSTN: Since I have more than one SIP provider setup in the
> SPA3102, can I have a SIP call coming in through port 5065, and
> forward it through gw2 using port 5060?
> (PSTN-Sip communications "inside" the SPA3102 are using port 5061)
> If so, the string on Forward on no answer, should be something like
> 00351123456789@gw2 ?
>
>
>>If you leave off the @gw0, incoming PSTN calls will be routed to the
>>mobile via your SIP provider and you'll pay them for the call to the
>>mobile.

>
> It's not working. I've tried "00351123456789" in the Forward on no
> answer field, I call my PSTN line 1 from PSTN line 2, and it doesn't
> forward anything. Either as is, or with @gw2 at the end of the number.
>
>
>>However, incoming SIP calls will get an instruction redirecting them to
>>your mobile. The caller may not have a plan that allows them to call
>>mobiles and, even if they do, they think they are making a free call.
>>Their

>
> My SIP accounts, and my PSTN line, all allow me to call mobiles,
> national or international.
>
>
>>If Linksys want to improve their product, making it possible to relay SIP
>>calls through the SPA3102 would be on my wish list though fixing the awful
>>echoes would come much higher.

>
> Echoes are "funny" - they're really bad with one of my phones, and
> absolutelly disappear when I use another specific phone...
>
> Call forwarding limitations are disapointing and frsutrating - I used
> to get perfect results with the PAP2, before "upgrading" to the
> SPA3102.
>
> Thanks a lot!
> Jose


Hi Jose,

I'd really only suggested setting call forwarding from the keypad as a way
for you to confirm what you're entering in the configuration field. When
you set it from the keypad, the SPA3102 automatically fills in the field
and you'll see the result when you go to the web interface. Make sure it's
what you expect.


I just checked that entering my mobile number in Cfwd All Dest with @gw0 on
the end is working when I make a SIP call to the SPA3102. Please try the
following:

Turn off the SPA3102 and leave it off. The power-fail relay will connect the
connected phone directly to the PSTN line.

Dial 00351123456789 from the connected phone.

Confirm that the call rings the number you're wanting to forward to.

If it doesn't, you'll need to change 00351123456789 (which looks like an
international number) to a different format as expected by your PSTN
provider. It should then work to forward incoming SIP calls when you put
@gw0 on the end.


All I know about trying to forward SIP calls to another SIP destination
comes from the following:

I have/had an IPKall number (haven't used it recently, it may have lapsed)
and have a SIP account with Sipgate.

Years ago, incoming calls to the IPKall number could be forwarded to
(E-Mail Removed) but Sipgate blocked this as part of a fix
for big problems they were having at the time.

I tried setting the forwarding to point to an FWD number I have and that
worked.

Peer-to-peer calls from my FWD number to my Sipgate number work OK so
tried setting forwarding from FWD to Sipgate. Incoming IPKall calls would
fail rather than forwarding.

I found I could point IPKall to (E-Mail Removed)ess and
they would come in on the phone connected to my SPA3102.

I have another SPA3102 at a different location and can call between them
using gateways that point directly to the IP addresses. I often forward
incoming PSTN calls that way (though the echoes are stupendously bad) but I
couldn't forward IPKall calls that way (which is something I really wanted
to do).

If the SIP calls were being relayed by FWD or by the first SPA3102, IPKall
wouldn't know this and the calls should come through fine. This is why I
reckon they are being redirected rather than relayed and IPKall aren't
honouring the redirection. I'd have to dream up more experiments to be sure
exactly what will and won't work but I know it's not simple.

Hope this helps.
--
Steve Hayes
South Wales, UK
----Remove colours from address----

 
Reply With Quote
 
Steve Hayes
Guest
Posts: n/a
 
      08-06-2008
Jose wrote:

> On 05 Aug 2008 12:49:14 GMT, (E-Mail Removed) (Andrew
> Gabriel) wrote:
>
>>> What I really expect, is the device to work as would appear normal,
>>> given the field names, Forward on no answer,

>>
>>That's *92<number>, *93 to cancel.
>>
>>> and Forward when busy.

>>
>>That's *90<number>, *91 to cancel.
>>
>>> Not "Forward when I remember to do so".

>
>
> Dear Andrew and Steve,
>
> I've used the telephone keypad to enter the codes *92 and *90 followed
> by the phones numbers I wish to forward my calls to. I then went to
> check the SPA's interface, and there the numbers were, followed by the
> gateway determined by my dialplan. Good so far!
>
> The "Cfwd No Ans Delay:" has a value of 10 (seconds). I then called
> the PSTN line connected to my SPA, from a diferent PSTN line, and
> nothing happened, after 10, 20, and more seconds...
>
> What now?
>
> Thanks,
> Jose


Hi Jose,

I just tried this and you're quite right. It doesn't seem to work and I
can't find out why.

If you want to forward incoming PSTN calls to a SIP phone, you can probably
do this via a gateway account pointing directly to the destination. This is
what I use but getting the audio to work both ways required a lot of trial
and error. Please let me know if you want to do this and I'll dig out the
settings.

Forwarding via a normal service such as Sipgate doesn't do anything, whether
the destination is a SIP or PSTN number.

There are instructions on the Linksys website. These show using the PSTN-SIP
gateway function with a special dial plan (rather inconvenient) and I
couldn't get that to work either.

If I have any inspiration about what the problem is, I'll check it out and
let you know.

--
Steve Hayes
South Wales, UK
----Remove colours from address----

 
Reply With Quote
 
Steve Hayes
Guest
Posts: n/a
 
      08-06-2008
Steve Hayes wrote:

> Jose wrote:
>
>> On 05 Aug 2008 12:49:14 GMT, (E-Mail Removed) (Andrew
>> Gabriel) wrote:
>>
>>>> What I really expect, is the device to work as would appear normal,
>>>> given the field names, Forward on no answer,
>>>
>>>That's *92<number>, *93 to cancel.
>>>
>>>> and Forward when busy.
>>>
>>>That's *90<number>, *91 to cancel.
>>>
>>>> Not "Forward when I remember to do so".

>>
>>
>> Dear Andrew and Steve,
>>
>> I've used the telephone keypad to enter the codes *92 and *90 followed
>> by the phones numbers I wish to forward my calls to. I then went to
>> check the SPA's interface, and there the numbers were, followed by the
>> gateway determined by my dialplan. Good so far!
>>
>> The "Cfwd No Ans Delay:" has a value of 10 (seconds). I then called
>> the PSTN line connected to my SPA, from a diferent PSTN line, and
>> nothing happened, after 10, 20, and more seconds...
>>
>> What now?
>>
>> Thanks,
>> Jose

>
> Hi Jose,
>
> I just tried this and you're quite right. It doesn't seem to work and I
> can't find out why.
>
> If you want to forward incoming PSTN calls to a SIP phone, you can
> probably do this via a gateway account pointing directly to the
> destination. This is what I use but getting the audio to work both ways
> required a lot of trial and error. Please let me know if you want to do
> this and I'll dig out the settings.
>
> Forwarding via a normal service such as Sipgate doesn't do anything,
> whether the destination is a SIP or PSTN number.
>
> There are instructions on the Linksys website. These show using the
> PSTN-SIP gateway function with a special dial plan (rather inconvenient)
> and I couldn't get that to work either.
>
> If I have any inspiration about what the problem is, I'll check it out and
> let you know.
>


Latest:

I love a challenge and have got it partly working now. The trick seems to be
to set the SIP Port, Proxy and Registration details exactly the same on the
PSTN tab as on the Line 1 tab except that, on the PSTN tab, Register should
be "no" and Make Call Without Reg should be "yes".

I'm finding that it only works if the PSTN to VOIP setup on the PSTN tab has
Off Hook While Calling VOIP set to "yes" which makes the whole thing a bit
pointless. The call rings through to the destination OK but the caller
doesn't hear ringback and, when the call is answered, there's no audio in
either direction. However, these problems may be due to the setup I'm using
for testing where both originating and terminating phones and the SPA3102
are all hanging off the same DSL line and router.

Best of luck.


--
Steve Hayes
South Wales, UK
----Remove colours from address----

 
Reply With Quote
 
Chris Davies
Guest
Posts: n/a
 
      08-15-2008
Jose <(E-Mail Removed)> wrote:
> 1) PSTN to SIP: so, if I want to forward the call throug gw2, I should
> enter something like 00351123456789@gw2 right, in, say, the Forward
> when no answer field? It's not working (


I've not tried forwarding, just simple route selection, but I've found
that I need to include the port number in the Gateway Accounts fields:

Gateway 1: (E-Mail Removed):5060
GW1 Auth Id: {my smslisto userid}
GW1 NAT Mapping Enable: no
GW1 Password: {guess what}

This was gleaned over a number of days trawling google, and later getting
excellent help via this newsgroup.

Chris
 
Reply With Quote
 
Chris Davies
Guest
Posts: n/a
 
      08-16-2008
Jose <(E-Mail Removed)> wrote:
> 2) I have yet to find out how to forward a PSTN call to my mobile,
> again if I don't pick up the call after a while


Your SPA does recognise inbound PSTN (i.e. with your phone plugged into
the SPA, can you answer PSTN calls)?

Chris
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
forwarding Args&&... vs forwarding Args... Andrew Tomazos C++ 5 01-05-2012 11:15 PM
Deciding between SPA-3102 and SPA-2102 benn686@hotmail.com VOIP 4 10-07-2006 09:33 PM
Cheapest supplier of SPA-1001?...and operation with SPA-3000 Brian A UK VOIP 4 05-19-2006 11:32 AM
Sipura SPA-3000 Call Forwarding Mike Schumann VOIP 0 09-30-2004 12:46 AM
VOIP (SPA-2000) and POTS cordless phone... Kevin VOIP 0 01-30-2004 06:04 PM



Advertisments