Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > .NET 3.5 install questions

Reply
Thread Tools

.NET 3.5 install questions

 
 
Cirene
Guest
Posts: n/a
 
      05-21-2008
On our server we have .NET 1.0, 1.1 and 2.0 ASP.NET websites.

I am creating a .NET 3.5 website.

If my network guy installs the 3.5 FW, will the older apps still run ok?

Is 3.5 fully backwards compatible with 1.0, 1.1 and 2.0 ASP.NET web apps?

Thanks!


 
Reply With Quote
 
 
 
 
Cowboy \(Gregory A. Beamer\)
Guest
Posts: n/a
 
      05-21-2008
The main point of contention is extra stuff added on top.

If you are using AJAX, for example, you might have some problems until you
ujpdate your web.config. The 2.0 bits will be pointed to a version 1.06.###
(forget the entire number), while the 3.5 bits point to 3.5.0.0 version. If
you change version in the web.config, you should be fine.

That is your biggest danger, from my experience.

--
Gregory A. Beamer
MVP, MCP: +I, SE, SD, DBA

Subscribe to my blog
http://gregorybeamer.spaces.live.com/lists/feed.rss

or just read it:
http://gregorybeamer.spaces.live.com/

*************************************************
| Think outside the box!
|
*************************************************
"Cirene" <(E-Mail Removed)> wrote in message
news:%(E-Mail Removed)...
> On our server we have .NET 1.0, 1.1 and 2.0 ASP.NET websites.
>
> I am creating a .NET 3.5 website.
>
> If my network guy installs the 3.5 FW, will the older apps still run ok?
>
> Is 3.5 fully backwards compatible with 1.0, 1.1 and 2.0 ASP.NET web apps?
>
> Thanks!
>


 
Reply With Quote
 
 
 
 
Cirene
Guest
Posts: n/a
 
      05-21-2008
Thanks. So .NET 3.5 will install side by side with older frameworks
installed on the server?

"Mark Rae [MVP]" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> "Cirene" <(E-Mail Removed)> wrote in message
> news:%(E-Mail Removed)...
>
>> If my network guy installs the 3.5 FW, will the older apps still run ok?

>
> Yes.
>
>> Is 3.5 fully backwards compatible with 1.0, 1.1 and 2.0 ASP.NET web apps?

>
> That's not quite how it works. Installing .NET 3.5 doesn't overwrite or
> uninstall the previous versions - they all co-exist quite happily, as you
> will be able to tell from the folder structure.
>
> The older apps won't care about any other version of the framework than
> the one for which they were compiled...
>
>
> --
> Mark Rae
> ASP.NET MVP
> http://www.markrae.net



 
Reply With Quote
 
Juan T. Llibre
Guest
Posts: n/a
 
      05-21-2008
re:
!> .NET 3.5 will install side by side with older frameworks installed on the server?

Yes, it will.




Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"Cirene" <(E-Mail Removed)> wrote in message news:(E-Mail Removed)...
> Thanks. So .NET 3.5 will install side by side with older frameworks installed on the server?
>
> "Mark Rae [MVP]" <(E-Mail Removed)> wrote in message news:(E-Mail Removed)...
>> "Cirene" <(E-Mail Removed)> wrote in message news:%(E-Mail Removed)...
>>
>>> If my network guy installs the 3.5 FW, will the older apps still run ok?

>>
>> Yes.
>>
>>> Is 3.5 fully backwards compatible with 1.0, 1.1 and 2.0 ASP.NET web apps?

>>
>> That's not quite how it works. Installing .NET 3.5 doesn't overwrite or uninstall the previous versions - they all
>> co-exist quite happily, as you will be able to tell from the folder structure.
>>
>> The older apps won't care about any other version of the framework than the one for which they were compiled...
>>
>>
>> --
>> Mark Rae
>> ASP.NET MVP
>> http://www.markrae.net

>
>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
'gem install' vs. 'ruby install.rb'. A few questions. Géraud Contisouzas Ruby 1 09-13-2006 06:26 PM
XP Pro Install - Can't Install pro_seg5.swf Luke O'Malley Computer Support 1 12-05-2004 07:15 AM
Re: Questions....questions....questions Patrick Michael A+ Certification 0 06-16-2004 04:53 PM
Can't seem to boot from XP install CD (after botched Linux install) Cloud Burst Computer Support 3 05-22-2004 02:52 PM
How to determine JDK install directory and/or do silent install of J2SE? RJGraham Java 8 02-14-2004 02:19 PM



Advertisments