Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > .Net Winforms Control Deployment

Reply
Thread Tools

.Net Winforms Control Deployment

 
 
Billy
Guest
Posts: n/a
 
      05-13-2008
I have written a .Net Windows Control which I am hosting in Internet
Explorer 6/7 which is working.

The problem I am having is deploying this control to the client
machines. I have created a CAB file, referenced it in the codebase
property of my object tag and get a "Do you want to install ..."
dialogue appearing.

The installer is not working. Can anyone point me to a sample to
create cab/inf files that will install/register my assembly on a
client machine. I've tried adding setup.msi files to the CAB file and
using a hook to run msiexec /i serup.msi asper some examples but to no
avail.

Regards

Simon
 
Reply With Quote
 
 
 
 
Juan T. Llibre
Guest
Posts: n/a
 
      05-13-2008
Wrong newsgroup.

This newsgroup is for WebForms, not WinForms.
Try posting your question to the microsoft.public.dotnet.framework ng on this same server.





Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Billy" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
>I have written a .Net Windows Control which I am hosting in Internet
> Explorer 6/7 which is working.
>
> The problem I am having is deploying this control to the client
> machines. I have created a CAB file, referenced it in the codebase
> property of my object tag and get a "Do you want to install ..."
> dialogue appearing.
>
> The installer is not working. Can anyone point me to a sample to
> create cab/inf files that will install/register my assembly on a
> client machine. I've tried adding setup.msi files to the CAB file and
> using a hook to run msiexec /i serup.msi asper some examples but to no
> avail.
>
> Regards
>
> Simon




 
Reply With Quote
 
 
 
 
bruce barker
Guest
Posts: n/a
 
      05-13-2008
the IE active/x installer is rather simple and uses a restricted inf file
(won't run an installer). it basically copies the ocx dll and supporting to a
folder and registers it:

http://msdn.microsoft.com/en-us/libr...74(VS.85).aspx

IE supporting winforms is a dead techonology, thus the lask of
documentation. The current story is to use silverlight to host .net
components.


-- bruce (sqlwork.com)


"Billy" wrote:

> I have written a .Net Windows Control which I am hosting in Internet
> Explorer 6/7 which is working.
>
> The problem I am having is deploying this control to the client
> machines. I have created a CAB file, referenced it in the codebase
> property of my object tag and get a "Do you want to install ..."
> dialogue appearing.
>
> The installer is not working. Can anyone point me to a sample to
> create cab/inf files that will install/register my assembly on a
> client machine. I've tried adding setup.msi files to the CAB file and
> using a hook to run msiexec /i serup.msi asper some examples but to no
> avail.
>
> Regards
>
> Simon
>

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
.NET Winforms Secuity Issue - Deployment None ASP .Net Security 0 03-30-2007 12:58 PM
Button Font in Winforms control in IE =?Utf-8?B?U2hpYnU=?= ASP .Net 0 10-14-2004 09:13 AM
Accessing IE features from embedded WinForms control Ken Varn ASP .Net 2 07-12-2004 01:34 PM
Smartclient (no touch deployment) Winforms app.config download issues Carl ASP .Net Security 0 03-05-2004 12:58 AM
Problems using a winforms control as an object in Internet Explorer John Boghossian ASP .Net 10 01-26-2004 09:56 AM



Advertisments