Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > COM interop from ASP.NET

Reply
Thread Tools

COM interop from ASP.NET

 
 
Stefan Barlow
Guest
Posts: n/a
 
      08-04-2003
I have an ecommerce system that hosts many sites on one server and I have
the main assembly in the GAC. Within the assembly I reference Verisign's
PayFlowPro interop. I have the interop in the GAC and the COM object is
registered. When the system runs and it tries to create the PayFlowPro
object, it cannot find the COM DLL. I have to put the DLL in the /bin
folder of each site in order for it to work. I do not want to have to do
this.

Why does it not find the COM DLL even though it is registered?

Thank you,
Stefan Barlow


 
Reply With Quote
 
 
 
 
Javier Guillen
Guest
Posts: n/a
 
      08-04-2003
this may help you out


http://www.msdnaa.net/Resources/Display.aspx?ResID=1493

regards,

Javier Guillen


"Stefan Barlow" <(E-Mail Removed)> wrote in message
news:qBuXa.138006$(E-Mail Removed) ...
> I have an ecommerce system that hosts many sites on one server and I have
> the main assembly in the GAC. Within the assembly I reference Verisign's
> PayFlowPro interop. I have the interop in the GAC and the COM object is
> registered. When the system runs and it tries to create the PayFlowPro
> object, it cannot find the COM DLL. I have to put the DLL in the /bin
> folder of each site in order for it to work. I do not want to have to do
> this.
>
> Why does it not find the COM DLL even though it is registered?
>
> Thank you,
> Stefan Barlow
>
>



 
Reply With Quote
 
 
 
 
Stefan Barlow
Guest
Posts: n/a
 
      08-04-2003
Strangely enough it wouldn't work the last time I tried, but now it does and
I didn't do anything between then and now. I removed the COM DLL from the
bin folder and restarted the ASPNET process and it still works. I guess it
is just one of those things. Hopefully it won't change it's mind later and
stop working again.

Thanks,
Stefan Barlow


"Javier Guillen" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> this may help you out
>
>
> http://www.msdnaa.net/Resources/Display.aspx?ResID=1493
>
> regards,
>
> Javier Guillen
>
>
> "Stefan Barlow" <(E-Mail Removed)> wrote in message
> news:qBuXa.138006$(E-Mail Removed) ...
> > I have an ecommerce system that hosts many sites on one server and I

have
> > the main assembly in the GAC. Within the assembly I reference

Verisign's
> > PayFlowPro interop. I have the interop in the GAC and the COM object is
> > registered. When the system runs and it tries to create the PayFlowPro
> > object, it cannot find the COM DLL. I have to put the DLL in the /bin
> > folder of each site in order for it to work. I do not want to have to

do
> > this.
> >
> > Why does it not find the COM DLL even though it is registered?
> >
> > Thank you,
> > Stefan Barlow
> >
> >

>
>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Excel interop Vishesh ASP .Net 1 12-13-2005 01:11 AM
com interop C# VB6 JerryP ASP .Net 0 10-28-2004 01:22 PM
Catalyst/Extreme Interop Gary Richardson Cisco 0 02-17-2004 06:56 PM
Tab Fails on TextBox using COM Interop Brett Roy ASP .Net 0 09-29-2003 04:11 AM
Microsoft Office Interop word dll bracoute ASP .Net 1 07-05-2003 05:01 PM



Advertisments