Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Wireless Networking > Re: Two PC's on crossover kills WiFi

Reply
Thread Tools

Re: Two PC's on crossover kills WiFi

 
 
Phillip Windell
Guest
Posts: n/a
 
      04-15-2008
Two choices:

Choice #1 - The easy way
Manually configure The TCP/IP specs of the nics you're using with the
crossover cable.
Make them the same subnet with each other, but different than the wireless
Nics
Leave the Default Gateway blank,..it is used for crossing subnets and they
are not crossing subnets,..it is therefore not supposed to be used,..leave
it blank

Choice #2 - The long annoying and possibly less stabile way
Change the binding order of the nics. Set the WiFi nic as the first. I'll
use XP as the example,..you can translate it to Vista if you run Vista.

Properties of Network Places-->
Advanced from the Top Menu-->
Advanced Settings from the Dropdown Menu-->
Use the side arrows at the Upper box the set the Nic you want to be at the
top

Now it should "favor" that nic if they both have conflicting Default
Gateways

Default Gateways are supposed to be treated as *global* for the whole
machine, hence there should only be one on one nic. This situation is an
example of why a machine should never have more than one Default Gateway
unless the Default Gateway IP#s are in the same subnet and are bound to the
same Nic (used for Dead Gateway Detection, see below). That has been the
Rule for years since TCP/IP was invented,...things haven't changed much.

If it doesn't work after this then you just simply will not be able to
dependably use the Wifi at the same time as using a crossover between the
wired nics. You'll have to pick one or the other at a given moment by
disabling the other.

I hope the links are still good,...they are getting kind of old.

Q128978 - Dead Gateway Detection in TCP/IP for Windows NT
http://support.microsoft.com/support.../Q128/9/78.ASP

Q171564 - TCP/IP Dead Gateway Detection Algorithm Updated for Windows NT
http://support.microsoft.com/support.../Q171/5/64.ASP

Q1157025 - Default Gateway Configuration for Multihomed Computers
http://support.microsoft.com/support.../Q157/0/25.ASP

Q175767 - Expected Behavior of Multiple Adapters on Same Network
http://support.microsoft.com/support.../Q175/7/67.ASP


--
Phillip Windell
www.wandtv.com

The views expressed, are my own and not those of my employer, or Microsoft,
or anyone else associated with me, including my cats.
-----------------------------------------------------

"just bob" <kilbyfan@aoldotcom> wrote in message
news:(E-Mail Removed) m...
> Connecting two PC's with a crossover cable kills the wifi internet.
>
> When we travel we usually have two laptops connected to the same public
> WiFi to check email and surf the web but we also need to share many very
> large files between the two laptops. Since both computes have gigabit
> NIC's I tried using a crossover cable to link them to get better speeds
> than over WiFi.
>
> Both laptops are identical Dell D630 with internal Wifi adapters.
>
> Laptop-A's GB NIC is assigned 172.16.16.1 and Laptop-B is 172.16.16.2,
> subnet mask is 255.255.255.0 and gateway is themselves.
>
> When I do this the two PC's see each other just fine but the WiFi to the
> internet stops working. I believe it is a routing to default gateway issue
> but I'm not sure how to cure this. How do you force the PC to use the WiFi
> as the default gateway, if that will solve the problem? I have tried
> using the route command but even though I craft the command statement
> exactly as the help doc says it comes back with an error.
>
> route add 0.0.0.0 MASK 255.255.0.0 192.168.1.10
>
> If you have any ideas how to make this work please let me know!
>
> Thanks,
> -Bob
>
>
>



 
Reply With Quote
 
 
 
 
Jack \(MVP-Networking\).
Guest
Posts: n/a
 
      04-16-2008
Hi
May be this can Help, http://www.netsetman.com/index.php?s=nsm
Jack (MVP-Networking).

"just bob" <kilbyfan@aoldotcom> wrote in message
news:(E-Mail Removed) m...
>A few minutes later
>
> Had to create two local admin accounts on each machine to use for
> authentication since a DC is not present, added each machine name and IP
> to each others hosts file (even ping seems slow without this) and used map
> network drive with login with other name. Fairly pathetic but it works
> bunch of hoops I had to go through but it does work OK.
>
> Is there an easier way?
>
>
> "just bob" <kilbyfan@aoldotcom> wrote in message
> news:(E-Mail Removed)...
>> Choice 1 worked nice except.... XP will not let me share files.
>>
>> I can ping each other now and both machines can access the internet, so
>> your tip worked. I just do not know how to share files between domain
>> members when they are not on the domain.
>>
>> Any ideas?
>>
>> Thanks again!
>>
>>
>> "Phillip Windell" <(E-Mail Removed)> wrote in message
>> news:u$(E-Mail Removed)...
>>> Two choices:
>>>
>>> Choice #1 - The easy way
>>> Manually configure The TCP/IP specs of the nics you're using with the
>>> crossover cable.
>>> Make them the same subnet with each other, but different than the
>>> wireless Nics
>>> Leave the Default Gateway blank,..it is used for crossing subnets and
>>> they are not crossing subnets,..it is therefore not supposed to be
>>> used,..leave it blank
>>>
>>> Choice #2 - The long annoying and possibly less stabile way
>>> Change the binding order of the nics. Set the WiFi nic as the first.
>>> I'll use XP as the example,..you can translate it to Vista if you run
>>> Vista.
>>>
>>> Properties of Network Places-->
>>> Advanced from the Top Menu-->
>>> Advanced Settings from the Dropdown Menu-->
>>> Use the side arrows at the Upper box the set the Nic you want to be at
>>> the top
>>>
>>> Now it should "favor" that nic if they both have conflicting Default
>>> Gateways
>>>
>>> Default Gateways are supposed to be treated as *global* for the whole
>>> machine, hence there should only be one on one nic. This situation is an
>>> example of why a machine should never have more than one Default Gateway
>>> unless the Default Gateway IP#s are in the same subnet and are bound to
>>> the same Nic (used for Dead Gateway Detection, see below). That has been
>>> the Rule for years since TCP/IP was invented,...things haven't changed
>>> much.
>>>
>>> If it doesn't work after this then you just simply will not be able to
>>> dependably use the Wifi at the same time as using a crossover between
>>> the wired nics. You'll have to pick one or the other at a given moment
>>> by disabling the other.
>>>
>>> I hope the links are still good,...they are getting kind of old.
>>>
>>> Q128978 - Dead Gateway Detection in TCP/IP for Windows NT
>>> http://support.microsoft.com/support.../Q128/9/78.ASP
>>>
>>> Q171564 - TCP/IP Dead Gateway Detection Algorithm Updated for Windows NT
>>> http://support.microsoft.com/support.../Q171/5/64.ASP
>>>
>>> Q1157025 - Default Gateway Configuration for Multihomed Computers
>>> http://support.microsoft.com/support.../Q157/0/25.ASP
>>>
>>> Q175767 - Expected Behavior of Multiple Adapters on Same Network
>>> http://support.microsoft.com/support.../Q175/7/67.ASP
>>>
>>>
>>> --
>>> Phillip Windell
>>> www.wandtv.com
>>>
>>> The views expressed, are my own and not those of my employer, or
>>> Microsoft,
>>> or anyone else associated with me, including my cats.
>>> -----------------------------------------------------
>>>
>>> "just bob" <kilbyfan@aoldotcom> wrote in message
>>> news:(E-Mail Removed) m...
>>>> Connecting two PC's with a crossover cable kills the wifi internet.
>>>>
>>>> When we travel we usually have two laptops connected to the same public
>>>> WiFi to check email and surf the web but we also need to share many
>>>> very large files between the two laptops. Since both computes have
>>>> gigabit NIC's I tried using a crossover cable to link them to get
>>>> better speeds than over WiFi.
>>>>
>>>> Both laptops are identical Dell D630 with internal Wifi adapters.
>>>>
>>>> Laptop-A's GB NIC is assigned 172.16.16.1 and Laptop-B is 172.16.16.2,
>>>> subnet mask is 255.255.255.0 and gateway is themselves.
>>>>
>>>> When I do this the two PC's see each other just fine but the WiFi to
>>>> the internet stops working. I believe it is a routing to default
>>>> gateway issue but I'm not sure how to cure this. How do you force the
>>>> PC to use the WiFi as the default gateway, if that will solve the
>>>> problem? I have tried using the route command but even though I craft
>>>> the command statement exactly as the help doc says it comes back with
>>>> an error.
>>>>
>>>> route add 0.0.0.0 MASK 255.255.0.0 192.168.1.10
>>>>
>>>> If you have any ideas how to make this work please let me know!
>>>>
>>>> Thanks,
>>>> -Bob
>>>>
>>>>
>>>>
>>>
>>>

>>
>>

>
>


 
Reply With Quote
 
 
 
 
Phillip Windell
Guest
Posts: n/a
 
      04-16-2008

"just bob" <kilbyfan@aoldotcom> wrote in message
news:(E-Mail Removed) m...
> Had to create two local admin accounts on each machine to use for
> authentication since a DC is not present, added each machine name and IP
> to each others hosts file (even ping seems slow without this) and used map
> network drive with login with other name. Fairly pathetic but it works
> bunch of hoops I had to go through but it does work OK.


The "workgroup model" is always "pathetic" to me

See Jack's post. He has the links that will help with that stuff. I got
the networking side of things cleared up,..I'm satisfied with just that.

--
Phillip Windell
www.wandtv.com

The views expressed, are my own and not those of my employer, or Microsoft,
or anyone else associated with me, including my cats.
-----------------------------------------------------


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Re: Installing Sysinternals Desktops kills WiFi Bucky Breeder Computer Support 3 12-04-2008 10:39 PM
Re: Installing Sysinternals Desktops kills WiFi Desk Rabbit Computer Support 0 12-04-2008 04:13 PM
Re: Two PC's on crossover kills WiFi John Wireless Networking 1 04-15-2008 05:16 PM
Connecting two switches - crossover required? thefunnel@aol.com Cisco 1 06-30-2005 06:34 PM
Dell True Mobile 1300"G" WiFi Card/Notebook and Hotel WiFi and WiFii Hot Spots Mike Computer Support 5 06-17-2004 04:09 AM



Advertisments