Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > XML > Q: my mistake or theirs?

Reply
Thread Tools

Q: my mistake or theirs?

 
 
Martin Honnen
Guest
Posts: n/a
 
      03-26-2008
Malcolm Dew-Jones wrote:
> Some literal text in my style sheet is not being output, I'm not sure why.
> I'm using the Oracle xml routines.


> Why is the word BEFORE not included in the output?


I don't see a problem with your stylesheet so you might want to raise
the issue on an Oracle support forum or mailing list.

--

Martin Honnen
http://JavaScript.FAQTs.com/
 
Reply With Quote
 
 
 
 
Malcolm Dew-Jones
Guest
Posts: n/a
 
      03-26-2008
Some literal text in my style sheet is not being output, I'm not sure why.
I'm using the Oracle xml routines.


declare
xmlclob varchar2(4000);
xslclob varchar2(4000);
the_xml XMLType;
the_xsl XMLType;
the_doc XMLType;
begin

xmlclob := '<top><w>this_one</w><w>that_one</w></top>';

xslclob :=
'<xsl:stylesheet xmlnssl="http://www.w3.org/1999/XSL/Transform"
version="1.0">

<xsl:template match="w">
<xsl:copy>
BEFORE
<xsl:apply-templates select="@*|node()"/>
AFTER
</xsl:copy>
</xsl:template>

<xsl:template match="@*|node()">
<xsl:copy><xsl:apply-templates select="@*|node()"/></xsl:copy>
</xsl:template>
</xsl:stylesheet>';

the_xml := XMLType.createXML(xmlclob);
the_xsl := XMLType.createXML(xslclob);
the_doc := the_xml.transform(the_xsl);
:docclob := the_doc.getCLOBval();
end;
/
print docclob

<top>
<w>this_one
AFTER
</w>
<w>that_one
AFTER
</w>
</top>


Why is the word BEFORE not included in the output?

Feedback appreciated.
Thanks.

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Made a mistake Cisco router 3640 elliotth123 Cisco 0 09-22-2005 12:39 AM
New computer wireless PCI adapter setup mistake recovery =?Utf-8?B?Q3VyaW91c01hcms=?= Wireless Networking 3 02-15-2005 04:01 PM
Access-List: Blocking all access by mistake Sarah Cisco 4 11-30-2004 11:14 PM
where is the mistake? \(beta-\) Frank Nitzsche VHDL 4 06-25-2004 06:53 PM
erased flash by mistake, now not booting David Hodgson Cisco 3 03-02-2004 07:34 PM



Advertisments