Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > Error with ASP.NET opening OleDb/ODBC database

Reply
Thread Tools

Error with ASP.NET opening OleDb/ODBC database

 
 
Giuseppe D'Elia
Guest
Posts: n/a
 
      07-15-2003
Hi there,

I got a problem using an MS Access database through
ASP.NET.

After updating my system from .NET Framework 1.0 to 1.1,
my existing
application gives me the following error when opening a
connection
with the code below:

"Unspecified error" (ErrorCode: -2147467259)

string connectionStringKey = "LocalDBConnectionString";
string connectionString
= "Provider=Microsoft.Jet.OLEDB.4.0;Data
Source=C:\InetPub\wwwroot\IS_Italy_2003\IS.mdb";

OdbcConnection connection = new OdbcConnection
(connectionString);
try
{
connection.Open();
}
catch (OdbcException ex)
{
string error = ex.Message;
}
finally
{
connection.Close();
}

What's really strange is that:
1. The same application works on some of my colleagues'
computers with
the .net Framework 1.1
2. The very same code works on my computer when creating a
brand new
application with VS.NET 2003
3. The same application was working with .NET Framework 1.0

The same thing happens (including the two cases above)
when using ODBC
classes instead of OleDB ones. In this case the connection
string is:

"FIL=MS Access;DSN=AIS_Local"

and the error is:

"ERROR [HY000] [Microsoft][ODBC Microsoft Access Driver]
Disk or
network error.\r\nERROR [IM006] [Microsoft][ODBC Driver
Manager]
Driver's SQLSetConnectAttr failed\r\nERROR [HY000]
[Microsoft][ODBC
Microsoft Access Driver] Disk or network error."

Need HELP!!!
tks
 
Reply With Quote
 
 
 
 
Peter
Guest
Posts: n/a
 
      07-24-2003
Just to help with a little more info on what might be the
same problem.

http://www.asp.net/Forums/ShowPost.aspx?
tabindex=1&PostID=225749

I have the same problem that I can't access my mdb.
I have enabled p/w on my db but this does not seem to work
for me.

If you solve the problem please post the solution.

Peter

>-----Original Message-----
>Hi there,
>
>I got a problem using an MS Access database through
>ASP.NET.
>
>After updating my system from .NET Framework 1.0 to 1.1,
>my existing
>application gives me the following error when opening a
>connection
>with the code below:
>
>"Unspecified error" (ErrorCode: -2147467259)
>
>string connectionStringKey = "LocalDBConnectionString";
>string connectionString
>= "Provider=Microsoft.Jet.OLEDB.4.0;Data
>Source=C:\InetPub\wwwroot\IS_Italy_2003\IS.mdb" ;
>
>OdbcConnection connection = new OdbcConnection
>(connectionString);
>try
>{
>connection.Open();
>}
>catch (OdbcException ex)
>{
>string error = ex.Message;
>}
>finally
>{
>connection.Close();
>}
>
>What's really strange is that:
>1. The same application works on some of my colleagues'
>computers with
>the .net Framework 1.1
>2. The very same code works on my computer when creating

a
>brand new
>application with VS.NET 2003
>3. The same application was working with .NET Framework

1.0
>
>The same thing happens (including the two cases above)
>when using ODBC
>classes instead of OleDB ones. In this case the

connection
>string is:
>
>"FIL=MS Access;DSN=AIS_Local"
>
>and the error is:
>
>"ERROR [HY000] [Microsoft][ODBC Microsoft Access Driver]
>Disk or
>network error.\r\nERROR [IM006] [Microsoft][ODBC Driver
>Manager]
>Driver's SQLSetConnectAttr failed\r\nERROR [HY000]
>[Microsoft][ODBC
>Microsoft Access Driver] Disk or network error."
>
>Need HELP!!!
>tks
>.
>

 
Reply With Quote
 
 
 
 
John Toop
Guest
Posts: n/a
 
      07-25-2003
Hi Peter, I had a similar problem with MSAccess. It was becasuse the ASPNET
user (it seems this is the user that ASP.NET uses) did not have permissions
to read/write ... in the directory I had chosen to place the file. I moved
it into it's own directory and changed the permission to allow ASPNET to do
anything and ... it worked.

I'm using an XP machine. When I clicked on the properties for the folder,
there was no security property. I had to change "folder options" in control
panel away from "simple security" so that I could make this change. Then
after I had it working, I changed "folder options" back to simple security
and it's still working.

That was what I did for my PC. Not necessarily the solution for you.

"Peter" <(E-Mail Removed)> wrote in message
news:0b7801c351db$c9aa8870$(E-Mail Removed)...
> Just to help with a little more info on what might be the
> same problem.
>
> http://www.asp.net/Forums/ShowPost.aspx?
> tabindex=1&PostID=225749
>
> I have the same problem that I can't access my mdb.
> I have enabled p/w on my db but this does not seem to work
> for me.
>
> If you solve the problem please post the solution.
>
> Peter
>
> >-----Original Message-----
> >Hi there,
> >
> >I got a problem using an MS Access database through
> >ASP.NET.
> >
> >After updating my system from .NET Framework 1.0 to 1.1,
> >my existing
> >application gives me the following error when opening a
> >connection
> >with the code below:
> >
> >"Unspecified error" (ErrorCode: -2147467259)
> >
> >string connectionStringKey = "LocalDBConnectionString";
> >string connectionString
> >= "Provider=Microsoft.Jet.OLEDB.4.0;Data
> >Source=C:\InetPub\wwwroot\IS_Italy_2003\IS.mdb" ;
> >
> >OdbcConnection connection = new OdbcConnection
> >(connectionString);
> >try
> >{
> >connection.Open();
> >}
> >catch (OdbcException ex)
> >{
> >string error = ex.Message;
> >}
> >finally
> >{
> >connection.Close();
> >}
> >
> >What's really strange is that:
> >1. The same application works on some of my colleagues'
> >computers with
> >the .net Framework 1.1
> >2. The very same code works on my computer when creating

> a
> >brand new
> >application with VS.NET 2003
> >3. The same application was working with .NET Framework

> 1.0
> >
> >The same thing happens (including the two cases above)
> >when using ODBC
> >classes instead of OleDB ones. In this case the

> connection
> >string is:
> >
> >"FIL=MS Access;DSN=AIS_Local"
> >
> >and the error is:
> >
> >"ERROR [HY000] [Microsoft][ODBC Microsoft Access Driver]
> >Disk or
> >network error.\r\nERROR [IM006] [Microsoft][ODBC Driver
> >Manager]
> >Driver's SQLSetConnectAttr failed\r\nERROR [HY000]
> >[Microsoft][ODBC
> >Microsoft Access Driver] Disk or network error."
> >
> >Need HELP!!!
> >tks
> >.
> >



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Database Database Database Database scott93727@gmail.com Computer Information 0 09-27-2012 02:43 AM
DataBase DataBase DataBase DataBase scott93727@gmail.com Computer Information 0 09-26-2012 09:40 AM
Anyone resolved links opening blank page? or box opening in Outlook 2000? S.Rodgers Firefox 13 12-16-2005 03:07 PM
Word file not opening from Adm -My recent docs but opening from file menu of Word Thaqalain Computer Support 0 06-30-2005 02:20 AM
need some help with dial box opening when opening a folder John Computer Information 0 11-13-2003 08:38 PM



Advertisments