Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > Question about QoS over frame-relay

Reply
Thread Tools

Question about QoS over frame-relay

 
 
ttripp
Guest
Posts: n/a
 
      02-28-2008
My question is about appling QoS over a frame-relay subinterface. I
inherited an MPLS network that has mostly T1s on the CE end of things,
but a few locations have frame-relay connections instead. A typical
frame-relay setup looks something like this:

On the physical interface:
---------------------------------------------------------------------------
interface Serial0/1/0
bandwidth 1536
no ip address
max-reserved-bandwidth 100
encapsulation frame-relay IETF
load-interval 30
no fair-queue
service-module t1 remote-alarm-enable
frame-relay traffic-shaping
frame-relay lmi-type ansi
hold-queue 40 out

On the subinterface:
----------------------------------------------------------------------------
interface Serial0/1/0.525 point-to-point
bandwidth 1536
ip address 10.254.240.2 255.255.255.252
ip verify unicast reverse-path allow-self-ping
no ip redirects
no ip unreachables
ip virtual-reassembly
frame-relay interface-dlci 702
class VOIPovFR


The frame-relay map class:
---------------------------------------------------------------------------
map-class frame-relay VOIPovFR
frame-relay cir 1536000
frame-relay bc 15360
frame-relay be 0
frame-relay mincir 1536000
service-policy output QOSpolicy

The QoS policy & class maps:
------------------------------------------------------------------------------
class-map match-any REAL-TIME
match ip dscp ef
class-map match-any CRITICAL-DATA
match ip dscp af41
match protocol h323
class-map match-any TRANSACTIONAL-DATA
match access-group 110
match access-group 111
(I'm leaving out the access-lists, as they are extensive, and I'm not
worried about them right this moment.)

policy-map QOSpoliy
description Based on telco's recommended settings
class REAL-TIME
priority percent 35
police cir percent 35
conform-action transmit
exceed-action set-dscp-transmit 0
class CRITICAL-DATA
set dscp af41
police cir percent 35
conform-action transmit
exceed-action set-dscp-transmit 0
class TRANSACTIONAL-DATA
set ip dscp af21
police cir percent 20
conform-action transmit
exceed-action set-dscp-transmit 0
class class-default
police cir percent 10
conform-action transmit
exceed-action transmit


Everything looks OK to me, but since I've not worked with QoS over
frame-relay, I'm not 100% sure this is a proper setup. One thing I
noticed is that I cannot generate a graph of QoS statistics using SDM,
which I have no problem doing with my CEs that are using T1. Is it
not possible to use SDM to view those stats, and if not, is there a
command-line equivilant?

Thanks.
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Qos for VoIP over 802.11g over VPN on 871W ensnare Cisco 0 01-24-2009 06:01 AM
VOIP over VPN over TCP over WAP over 3G Theo Markettos UK VOIP 2 02-14-2008 03:27 PM
[QOS] minimal hardware and IOS requirement for QOS dominix Cisco 2 02-06-2007 10:19 AM
QOS for VOIP using 768k of FR / Auto QOS Andrew Albert Cisco 7 02-09-2005 07:42 PM
QoS over 837. AM Cisco 0 12-06-2004 02:03 PM



Advertisments