Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Computer Support > Re: Changing icon for AVI?

Reply
Thread Tools

Re: Changing icon for AVI?

 
 
Terry Pinnell
Guest
Posts: n/a
 
      02-15-2008
John <(E-Mail Removed)> wrote:

>Terry Pinnell wrote:
>> Somehow VLC player took over the file association AVI. I managed to
>> change that back to VirtualDub, but the VLC icon is still shown
>> against all AVI files. And the File Types list still refers to VLC as
>> the default program for this type. Even though d-clicking an AVI does
>> now open it in VirtualDub.
>>
>> I couldn't find any settings in VLC itself to change file types.
>>
>> Anyone have any suggestions please?
>>

>Hi Terry,
>
>Open up Explorer, then click on Tools, then folder options. Click on the
>file types tab at the top, then scroll down to AVI. files. Highlight it,
>then click on the change button and choose what program you would like
>to open this type of file.
>
>John.


Thanks John, but I had tried that without success. I still have the
VLC icon. Here's a screenshot showing what I see in File Types, and
the Change dialog.
http://img84.imageshack.us/my.php?im...onissuerw4.jpg

Obviously, somehow I need to convince XP that VLC is NOT the default
for AVI! But how? It's no big deal, but it irritates me

--
Terry, East Grinstead, UK
 
Reply With Quote
 
 
 
 
Rgr
Guest
Posts: n/a
 
      02-15-2008
Terry Pinnell wrote:
> John <(E-Mail Removed)> wrote:
>
>> Terry Pinnell wrote:
>>> Somehow VLC player took over the file association AVI. I managed to
>>> change that back to VirtualDub, but the VLC icon is still shown
>>> against all AVI files. And the File Types list still refers to VLC as
>>> the default program for this type. Even though d-clicking an AVI does
>>> now open it in VirtualDub.
>>>
>>> I couldn't find any settings in VLC itself to change file types.
>>>
>>> Anyone have any suggestions please?
>>>

>> Hi Terry,
>>
>> Open up Explorer, then click on Tools, then folder options. Click on the
>> file types tab at the top, then scroll down to AVI. files. Highlight it,
>> then click on the change button and choose what program you would like
>> to open this type of file.
>>
>> John.

>
> Thanks John, but I had tried that without success. I still have the
> VLC icon. Here's a screenshot showing what I see in File Types, and
> the Change dialog.
> http://img84.imageshack.us/my.php?im...onissuerw4.jpg
>
> Obviously, somehow I need to convince XP that VLC is NOT the default
> for AVI! But how? It's no big deal, but it irritates me


Try clicking the Browse button and surf to whatever program you want to
use and select that. If there an "always use" box, check that.
 
Reply With Quote
 
 
 
 
Terry Pinnell
Guest
Posts: n/a
 
      02-15-2008
Rgr <(E-Mail Removed)> wrote:

>Terry Pinnell wrote:
>> John <(E-Mail Removed)> wrote:
>>
>>> Terry Pinnell wrote:
>>>> Somehow VLC player took over the file association AVI. I managed to
>>>> change that back to VirtualDub, but the VLC icon is still shown
>>>> against all AVI files. And the File Types list still refers to VLC as
>>>> the default program for this type. Even though d-clicking an AVI does
>>>> now open it in VirtualDub.
>>>>
>>>> I couldn't find any settings in VLC itself to change file types.
>>>>
>>>> Anyone have any suggestions please?
>>>>
>>> Hi Terry,
>>>
>>> Open up Explorer, then click on Tools, then folder options. Click on the
>>> file types tab at the top, then scroll down to AVI. files. Highlight it,
>>> then click on the change button and choose what program you would like
>>> to open this type of file.
>>>
>>> John.

>>
>> Thanks John, but I had tried that without success. I still have the
>> VLC icon. Here's a screenshot showing what I see in File Types, and
>> the Change dialog.
>> http://img84.imageshack.us/my.php?im...onissuerw4.jpg
>>
>> Obviously, somehow I need to convince XP that VLC is NOT the default
>> for AVI! But how? It's no big deal, but it irritates me

>
>Try clicking the Browse button and surf to whatever program you want to
>use and select that. If there an "always use" box, check that.


Thanks Roger, but already tried that too. Whether I select VirtualDub
from the list already present (see screenshot), or after browsing to
the executable itself, it doesn't stick. Icons in folders are still
VLC, and on re-opening File Types and clicking Change I still see VLC
is the default!

--
Terry, East Grinstead, UK
 
Reply With Quote
 
Charles May
Guest
Posts: n/a
 
      02-15-2008
Have you tried checking the options for the associations it places on
filetypes for each viewer? I would think you could select .avi in virtual
dubs options and deselect it in VLC.

I don't have either installed here but I will check when I get to another
machine.
"Terry Pinnell" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Rgr <(E-Mail Removed)> wrote:
>
>>Terry Pinnell wrote:
>>> John <(E-Mail Removed)> wrote:
>>>
>>>> Terry Pinnell wrote:
>>>>> Somehow VLC player took over the file association AVI. I managed to
>>>>> change that back to VirtualDub, but the VLC icon is still shown
>>>>> against all AVI files. And the File Types list still refers to VLC as
>>>>> the default program for this type. Even though d-clicking an AVI does
>>>>> now open it in VirtualDub.
>>>>>
>>>>> I couldn't find any settings in VLC itself to change file types.
>>>>>
>>>>> Anyone have any suggestions please?
>>>>>
>>>> Hi Terry,
>>>>
>>>> Open up Explorer, then click on Tools, then folder options. Click on
>>>> the
>>>> file types tab at the top, then scroll down to AVI. files. Highlight
>>>> it,
>>>> then click on the change button and choose what program you would like
>>>> to open this type of file.
>>>>
>>>> John.
>>>
>>> Thanks John, but I had tried that without success. I still have the
>>> VLC icon. Here's a screenshot showing what I see in File Types, and
>>> the Change dialog.
>>> http://img84.imageshack.us/my.php?im...onissuerw4.jpg
>>>
>>> Obviously, somehow I need to convince XP that VLC is NOT the default
>>> for AVI! But how? It's no big deal, but it irritates me

>>
>>Try clicking the Browse button and surf to whatever program you want to
>>use and select that. If there an "always use" box, check that.

>
> Thanks Roger, but already tried that too. Whether I select VirtualDub
> from the list already present (see screenshot), or after browsing to
> the executable itself, it doesn't stick. Icons in folders are still
> VLC, and on re-opening File Types and clicking Change I still see VLC
> is the default!
>
> --
> Terry, East Grinstead, UK



 
Reply With Quote
 
Charles May
Guest
Posts: n/a
 
      02-15-2008
Try this:
Go to the avi file type. Click on the restore button to change it back to
VLC
The restore button should change to Advanced
Click Advanced and browse to the VirtualDub and select it that way.

Charlie
"Terry Pinnell" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Rgr <(E-Mail Removed)> wrote:
>
>>Terry Pinnell wrote:
>>> John <(E-Mail Removed)> wrote:
>>>
>>>> Terry Pinnell wrote:
>>>>> Somehow VLC player took over the file association AVI. I managed to
>>>>> change that back to VirtualDub, but the VLC icon is still shown
>>>>> against all AVI files. And the File Types list still refers to VLC as
>>>>> the default program for this type. Even though d-clicking an AVI does
>>>>> now open it in VirtualDub.
>>>>>
>>>>> I couldn't find any settings in VLC itself to change file types.
>>>>>
>>>>> Anyone have any suggestions please?
>>>>>
>>>> Hi Terry,
>>>>
>>>> Open up Explorer, then click on Tools, then folder options. Click on
>>>> the
>>>> file types tab at the top, then scroll down to AVI. files. Highlight
>>>> it,
>>>> then click on the change button and choose what program you would like
>>>> to open this type of file.
>>>>
>>>> John.
>>>
>>> Thanks John, but I had tried that without success. I still have the
>>> VLC icon. Here's a screenshot showing what I see in File Types, and
>>> the Change dialog.
>>> http://img84.imageshack.us/my.php?im...onissuerw4.jpg
>>>
>>> Obviously, somehow I need to convince XP that VLC is NOT the default
>>> for AVI! But how? It's no big deal, but it irritates me

>>
>>Try clicking the Browse button and surf to whatever program you want to
>>use and select that. If there an "always use" box, check that.

>
> Thanks Roger, but already tried that too. Whether I select VirtualDub
> from the list already present (see screenshot), or after browsing to
> the executable itself, it doesn't stick. Icons in folders are still
> VLC, and on re-opening File Types and clicking Change I still see VLC
> is the default!
>
> --
> Terry, East Grinstead, UK



 
Reply With Quote
 
Charles May
Guest
Posts: n/a
 
      02-15-2008
Sorry, left out a few steps.
Click on Advanced.
Select Open and then click to edit it
Then browse to virtualdubs exe file
"Charles May" <(E-Mail Removed)> wrote in message
news:mhgtj.4372$%x3.3746@trndny06...
> Try this:
> Go to the avi file type. Click on the restore button to change it back to
> VLC
> The restore button should change to Advanced
> Click Advanced and browse to the VirtualDub and select it that way.
>
> Charlie
> "Terry Pinnell" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
>> Rgr <(E-Mail Removed)> wrote:
>>
>>>Terry Pinnell wrote:
>>>> John <(E-Mail Removed)> wrote:
>>>>
>>>>> Terry Pinnell wrote:
>>>>>> Somehow VLC player took over the file association AVI. I managed to
>>>>>> change that back to VirtualDub, but the VLC icon is still shown
>>>>>> against all AVI files. And the File Types list still refers to VLC as
>>>>>> the default program for this type. Even though d-clicking an AVI does
>>>>>> now open it in VirtualDub.
>>>>>>
>>>>>> I couldn't find any settings in VLC itself to change file types.
>>>>>>
>>>>>> Anyone have any suggestions please?
>>>>>>
>>>>> Hi Terry,
>>>>>
>>>>> Open up Explorer, then click on Tools, then folder options. Click on
>>>>> the
>>>>> file types tab at the top, then scroll down to AVI. files. Highlight
>>>>> it,
>>>>> then click on the change button and choose what program you would like
>>>>> to open this type of file.
>>>>>
>>>>> John.
>>>>
>>>> Thanks John, but I had tried that without success. I still have the
>>>> VLC icon. Here's a screenshot showing what I see in File Types, and
>>>> the Change dialog.
>>>> http://img84.imageshack.us/my.php?im...onissuerw4.jpg
>>>>
>>>> Obviously, somehow I need to convince XP that VLC is NOT the default
>>>> for AVI! But how? It's no big deal, but it irritates me
>>>
>>>Try clicking the Browse button and surf to whatever program you want to
>>>use and select that. If there an "always use" box, check that.

>>
>> Thanks Roger, but already tried that too. Whether I select VirtualDub
>> from the list already present (see screenshot), or after browsing to
>> the executable itself, it doesn't stick. Icons in folders are still
>> VLC, and on re-opening File Types and clicking Change I still see VLC
>> is the default!
>>
>> --
>> Terry, East Grinstead, UK

>
>



 
Reply With Quote
 
Terry Pinnell
Guest
Posts: n/a
 
      02-15-2008
"Charles May" <(E-Mail Removed)> wrote:

>Sorry, left out a few steps.
>Click on Advanced.
>Select Open and then click to edit it
>Then browse to virtualdubs exe file
>"Charles May" <(E-Mail Removed)> wrote in message
>news:mhgtj.4372$%x3.3746@trndny06...
>> Try this:
>> Go to the avi file type. Click on the restore button to change it back to
>> VLC
>> The restore button should change to Advanced
>> Click Advanced and browse to the VirtualDub and select it that way.
>>
>> Charlie
>> "Terry Pinnell" <(E-Mail Removed)> wrote in message
>> news:(E-Mail Removed)...
>>> Rgr <(E-Mail Removed)> wrote:
>>>
>>>>Terry Pinnell wrote:
>>>>> John <(E-Mail Removed)> wrote:
>>>>>
>>>>>> Terry Pinnell wrote:
>>>>>>> Somehow VLC player took over the file association AVI. I managed to
>>>>>>> change that back to VirtualDub, but the VLC icon is still shown
>>>>>>> against all AVI files. And the File Types list still refers to VLC as
>>>>>>> the default program for this type. Even though d-clicking an AVI does
>>>>>>> now open it in VirtualDub.
>>>>>>>
>>>>>>> I couldn't find any settings in VLC itself to change file types.
>>>>>>>
>>>>>>> Anyone have any suggestions please?
>>>>>>>
>>>>>> Hi Terry,
>>>>>>
>>>>>> Open up Explorer, then click on Tools, then folder options. Click on
>>>>>> the
>>>>>> file types tab at the top, then scroll down to AVI. files. Highlight
>>>>>> it,
>>>>>> then click on the change button and choose what program you would like
>>>>>> to open this type of file.
>>>>>>
>>>>>> John.
>>>>>
>>>>> Thanks John, but I had tried that without success. I still have the
>>>>> VLC icon. Here's a screenshot showing what I see in File Types, and
>>>>> the Change dialog.
>>>>> http://img84.imageshack.us/my.php?im...onissuerw4.jpg
>>>>>
>>>>> Obviously, somehow I need to convince XP that VLC is NOT the default
>>>>> for AVI! But how? It's no big deal, but it irritates me
>>>>
>>>>Try clicking the Browse button and surf to whatever program you want to
>>>>use and select that. If there an "always use" box, check that.
>>>
>>> Thanks Roger, but already tried that too. Whether I select VirtualDub
>>> from the list already present (see screenshot), or after browsing to
>>> the executable itself, it doesn't stick. Icons in folders are still
>>> VLC, and on re-opening File Types and clicking Change I still see VLC
>>> is the default!
>>>
>>> --
>>> Terry, East Grinstead, UK

>>
>>

>

Many thanks, that finally did the job!

There were a few further difficulties. I had in fact already gone that
route, but this time I noticed something I missed before: there was
only a PLAY entry, not an OPEN one. So I used New to add one, and
assigned VirtualDub to that, and changed the icon. I made OPEN the
default action.

But then VirtualDub gave an error when I d-clicked an AVI, saying it
couldn't find the folder.

I then went back and noted that the OPEN action was
"D:\Program Files\VirtualDub-1.7.7\VirtualDub.exe"
So I checked the PLAY action (aiming to copy it) and was very
surprised to find that it was
"D:\Program Files\VideoLAN\VLC\vlc.exe" --started-from-file "%1"

That just doesn't square with fact that my AVIs *were* opening with
VirtualDub! Any idea?

Anyway, putting that puzzle aside, I duly changed that to
"D:\Program Files\VirtualDub-1.7.7\VirtualDub.exe" "%1"

.... and it works!

--
Terry, East Grinstead, UK

 
Reply With Quote
 
Lookout
Guest
Posts: n/a
 
      02-15-2008
On Fri, 15 Feb 2008 09:16:25 +0000, Terry Pinnell
<(E-Mail Removed)> wrote:

>John <(E-Mail Removed)> wrote:
>
>>Terry Pinnell wrote:
>>> Somehow VLC player took over the file association AVI. I managed to
>>> change that back to VirtualDub, but the VLC icon is still shown
>>> against all AVI files. And the File Types list still refers to VLC as
>>> the default program for this type. Even though d-clicking an AVI does
>>> now open it in VirtualDub.
>>>
>>> I couldn't find any settings in VLC itself to change file types.
>>>
>>> Anyone have any suggestions please?
>>>

>>Hi Terry,
>>
>>Open up Explorer, then click on Tools, then folder options. Click on the
>>file types tab at the top, then scroll down to AVI. files. Highlight it,
>>then click on the change button and choose what program you would like
>>to open this type of file.
>>
>>John.

>
>Thanks John, but I had tried that without success. I still have the
>VLC icon. Here's a screenshot showing what I see in File Types, and
>the Change dialog.
>http://img84.imageshack.us/my.php?im...onissuerw4.jpg
>
>Obviously, somehow I need to convince XP that VLC is NOT the default
>for AVI! But how? It's no big deal, but it irritates me


Open VLC and change the default associations there. Make sure that AVI
isn't checked.
It's one reason I won't install it.
 
Reply With Quote
 
Pennywise@DerryMaine.Gov
Guest
Posts: n/a
 
      02-16-2008
Lookout <(E-Mail Removed)> wrote:

>>Obviously, somehow I need to convince XP that VLC is NOT the default
>>for AVI! But how? It's no big deal, but it irritates me


>Open VLC and change the default associations there. Make sure that AVI
>isn't checked.
>It's one reason I won't install it.


I just drop my AVI's on VLC to play them, my default AVI association
is Irfanview.
--

Bette Davis Eyes
http://youtube.com/watch?v=_-RdAzkKlXY
 
Reply With Quote
 
Terry Pinnell
Guest
Posts: n/a
 
      02-16-2008
Lookout <(E-Mail Removed)> wrote:

>On Fri, 15 Feb 2008 09:16:25 +0000, Terry Pinnell
><(E-Mail Removed)> wrote:
>
>>John <(E-Mail Removed)> wrote:
>>
>>>Terry Pinnell wrote:
>>>> Somehow VLC player took over the file association AVI. I managed to
>>>> change that back to VirtualDub, but the VLC icon is still shown
>>>> against all AVI files. And the File Types list still refers to VLC as
>>>> the default program for this type. Even though d-clicking an AVI does
>>>> now open it in VirtualDub.
>>>>
>>>> I couldn't find any settings in VLC itself to change file types.
>>>>
>>>> Anyone have any suggestions please?
>>>>
>>>Hi Terry,
>>>
>>>Open up Explorer, then click on Tools, then folder options. Click on the
>>>file types tab at the top, then scroll down to AVI. files. Highlight it,
>>>then click on the change button and choose what program you would like
>>>to open this type of file.
>>>
>>>John.

>>
>>Thanks John, but I had tried that without success. I still have the
>>VLC icon. Here's a screenshot showing what I see in File Types, and
>>the Change dialog.
>>http://img84.imageshack.us/my.php?im...onissuerw4.jpg
>>
>>Obviously, somehow I need to convince XP that VLC is NOT the default
>>for AVI! But how? It's no big deal, but it irritates me

>
>Open VLC and change the default associations there. Make sure that AVI
>isn't checked.
>It's one reason I won't install it.


I've now sorted the problem as you see from my later reply. But I'm
curious about your suggestion. As I said in my opening post "I
couldn't find any settings in VLC itself to change file types."

Where do you see these VLC default associations please?

--
Terry, East Grinstead, UK

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Multiple image sizes in frame icon (window icon) in Swing Dan Polansky Java 3 02-12-2007 11:15 PM
app.rc resource's icon to .net Icon Miro Durcik ASP .Net 0 10-09-2004 12:44 AM
howto place internet icon on the level of the start icon Sieds Computer Support 5 04-18-2004 01:51 PM
Changing Icon on a WebSetp Project Robert M ASP .Net 0 11-25-2003 02:56 PM
Create a Desktop Icon with proper icon name, not URL name Bodi Javascript 1 11-18-2003 02:40 AM



Advertisments