Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > UserControl loses state in TemplateField

Reply
Thread Tools

UserControl loses state in TemplateField

 
 
jerryjthorpe@gmail.com jerryjthorpe@gmail.com is offline
Junior Member
Join Date: Nov 2007
Posts: 2
 
      01-22-2008
Hi,

I have a UserControl with some ListBoxes on it. It works fine when called from a page unless I embed it in a TemplateField on a DetailsView. It loads properly but the SelectedIndex gets reset to -1 when I press a button to post. How can I save the state of the ListBoxes in the UserControl.

Thanks,
Jerry
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
TemplateField in 2.0 // Disappears on Postback when TemplateField is added thru code sloan ASP .Net 2 10-17-2007 09:08 AM
Boundcolumn or TemplateField when to use Boundcolumn and when TemplateField ???? mesut ASP .Net 0 06-29-2007 10:17 AM
Re: Problem: public array loses elements (in usercontrol) VB Programmer ASP .Net 1 07-01-2003 03:32 PM
Problem: public array loses elements (in usercontrol) VB Programmer ASP .Net 0 07-01-2003 02:10 PM
Problem: public array loses elements (in usercontrol) VB Programmer ASP .Net Web Controls 0 07-01-2003 02:10 PM



Advertisments