Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > Error in install package: Error 1001. Unable to get installer types in the Inv2_web.dll assembly

Reply
Thread Tools

Error in install package: Error 1001. Unable to get installer types in the Inv2_web.dll assembly

 
 
Monty
Guest
Posts: n/a
 
      01-20-2008
I have an installation package for my web application which has worked well.
After rebuilding the package and running install, I began receiving this
error message:

Error 1001. Unable to get installer types in the <MY_APPLICATION>.dll
assembly. --> Unable to load one or more of the requested types. Retrieve
the LoaderExceptions property for more information.
The install package has a Custom Action, but it has always worked fine
before. If I remove the custom action, it installs successfully. I kinda
need the custom action though. One note... I've recently updated from VS2005
to '08. The solution still targets the 2.0 framework though.

Thanks in advance for any light you can shed.


 
Reply With Quote
 
 
 
 
Steven Cheng[MSFT]
Guest
Posts: n/a
 
      01-21-2008
Hi Monty,

From your description and the error message you provided, it does indicate
that the setup program is looking for the installer type in your custom
action.

As you mentioned that it used to work, then, is it after you move it to VS
2008(and rebuild) that the problem start occuring? Also, as for the
<MY_APPLICATION>.dll , have you also move that project into VS 2008 and
rebuild it? I'm wondering whether thre is something mismatch with the setup
program and the main application assembly(an the one that contains the
custom action installer type). You may try build both of them through the
same IDE.

btw, if your setup program is targeting only .net framework 2.0, you can
also open the "properties" of the setup project and check the
"prerequisites", by default, .net framework 3.5 is selected as
prerequisites for VS 2008 setup project, you may also remove it.

Sincerely,

Steven Cheng

Microsoft MSDN Online Support Lead



==================================================

Get notification to my posts through email? Please refer to
http://msdn.microsoft.com/subscripti...ult.aspx#notif
ications.



Note: The MSDN Managed Newsgroup support offering is for non-urgent issues
where an initial response from the community or a Microsoft Support
Engineer within 1 business day is acceptable. Please note that each follow
up response may take approximately 2 business days as the support
professional working with you may need further investigation to reach the
most efficient resolution. The offering is not appropriate for situations
that require urgent, real-time or phone-based interactions or complex
project analysis and dump analysis issues. Issues of this nature are best
handled working with a dedicated Microsoft Support Engineer by contacting
Microsoft Customer Support Services (CSS) at
http://msdn.microsoft.com/subscripti...t/default.aspx.

==================================================


This posting is provided "AS IS" with no warranties, and confers no rights.

--------------------
>From: "Monty" <(E-Mail Removed)>
>Subject: Error in install package: Error 1001. Unable to get installer

types in the Inv2_web.dll assembly
>Date: Sat, 19 Jan 2008 19:01:03 -0500
>
>I have an installation package for my web application which has worked

well.
>After rebuilding the package and running install, I began receiving this
>error message:
>
>Error 1001. Unable to get installer types in the <MY_APPLICATION>.dll
>assembly. --> Unable to load one or more of the requested types. Retrieve
>the LoaderExceptions property for more information.
>The install package has a Custom Action, but it has always worked fine
>before. If I remove the custom action, it installs successfully. I kinda
>need the custom action though. One note... I've recently updated from

VS2005
>to '08. The solution still targets the 2.0 framework though.
>
>Thanks in advance for any light you can shed.
>
>
>


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
pywin32 vista installer fix & general distutils installer name bug Ville Vainio Python 0 04-09-2008 07:16 PM
Failure adding Assembly to cache.Attempt to install an assembly without a strong name Elmo Watson ASP .Net Web Controls 0 11-09-2007 05:00 PM
can distutils windows installer invoke another distutils windows installer timw.google Python 1 05-11-2006 10:07 PM
Everytime I try to open OE or IE I get windows installer trying to install office 2003 Lady Chatterly Computer Support 14 11-12-2004 09:00 AM
MSI Installer Problem: can't install 2.4a2 on new install of Win2kSP2 Richard Hanson Python 13 08-31-2004 04:43 PM



Advertisments