Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > RE: ASP.NET Fails after SP4 with Impersonation

Reply
Thread Tools

RE: ASP.NET Fails after SP4 with Impersonation

 
 
Bassel Tabbara [MSFT]
Guest
Posts: n/a
 
      06-27-2003
Hello Michael,
Try to add read, execute, and list access for the account on the root Web
site or on any virtual directory, follow these steps:



1. In Windows Explorer, browse to the folder that contains the root Web
site (which is C:\Inetpub\Wwwroot by default) or the virtual directory.

2. Right-click the folder, and then click Properties.

3. On the Security tab, click Add.

4. Type "<ComputerName>\ASPNET" (without the quotation marks) (for
example, on a computer named Webdev, type "Webdev\Account" (without the
quotation marks)), and then click OK.

5. Allow the following permissions for the custom account:

- Read & Execute

- List Folder Contents

- Read



6. Click OK to close the Properties dialog box and to save the changes.


NOTE: You do not need to perform these steps if the Everyone group or the
Users group has read access to the root Web site or virtual directory.

You might check also the following Kb article:
317955 FIX: "Failed to Start Monitoring Directory Changes" Error Message
When
http://support.microsoft.com/?id=317955


Please let me know if this solves the problem.


Thanks,
Bassel Tabbara
Microsoft, ASP.NET

This posting is provided "AS IS", with no warranties, and confers no rights.


--------------------
| From: "Michael Kennedy [UB]" <(E-Mail Removed)>
| Subject: ASP.NET Fails after SP4 with Impersonation
| Date: Fri, 27 Jun 2003 10:53:47 -0700
| Lines: 23
| Organization: United Binary, LLC.
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
| Message-ID: <ujp$(E-Mail Removed)>
| Newsgroups:
microsoft.public.dotnet.framework.aspnet,microsoft .public.win2000.general
| NNTP-Posting-Host: 130.191.240.187
| Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP10.phx.gbl
| Xref: cpmsftngxa06.phx.gbl microsoft.public.win2000.general:55001
microsoft.public.dotnet.framework.aspnet:155514
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Hi Everyone,
|
| Last night we installed SP4 on our Windows 2000 Advanced Server which was
| are using as an ASP.NET web server (.NET 1.1). This morning we found out
| that our ASP.NET applications that use impersonation. That is from the
| web.config:
|
| <identity impersonate="true" userName="DOMAIN\USER" password="PASSWORD" />
|
| fail with the message "Access Denied: Failed to start monitoring
| c:\inetpub\wwwroot\myapp\default.aspx for changes."
|
| This application worked fine before. Moreover, if I remove the
impersonation
| line from the web.config, everything is find again except of course things
| that required the impersonation fail.
|
| Does anyone know why this happens? Better yet, anyone know how to fix it?
|
| Thanks in advance!
| Michael
|
|
|
|


 
Reply With Quote
 
 
 
 
Michael Kennedy [UB]
Guest
Posts: n/a
 
      06-28-2003
Hi Bassel,

Thanks. I think it may have been a combination of this and the KB article
mentioned previously by Raymond. I'm still working on it however. There is
something that is not quite right here. I'll let you know if I learn any
more details.

Michael

""Bassel Tabbara [MSFT]"" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Hello Michael,
> Try to add read, execute, and list access for the account on the root Web
> site or on any virtual directory, follow these steps:
>
>
>
> 1. In Windows Explorer, browse to the folder that contains the root Web
> site (which is C:\Inetpub\Wwwroot by default) or the virtual directory.
>
> 2. Right-click the folder, and then click Properties.
>
> 3. On the Security tab, click Add.
>
> 4. Type "<ComputerName>\ASPNET" (without the quotation marks) (for
> example, on a computer named Webdev, type "Webdev\Account" (without the
> quotation marks)), and then click OK.
>
> 5. Allow the following permissions for the custom account:
>
> - Read & Execute
>
> - List Folder Contents
>
> - Read
>
>
>
> 6. Click OK to close the Properties dialog box and to save the changes.
>
>
> NOTE: You do not need to perform these steps if the Everyone group or the
> Users group has read access to the root Web site or virtual directory.
>
> You might check also the following Kb article:
> 317955 FIX: "Failed to Start Monitoring Directory Changes" Error Message
> When
> http://support.microsoft.com/?id=317955
>
>
> Please let me know if this solves the problem.
>
>
> Thanks,
> Bassel Tabbara
> Microsoft, ASP.NET
>
> This posting is provided "AS IS", with no warranties, and confers no

rights.
>
>
> --------------------
> | From: "Michael Kennedy [UB]" <(E-Mail Removed)>
> | Subject: ASP.NET Fails after SP4 with Impersonation
> | Date: Fri, 27 Jun 2003 10:53:47 -0700
> | Lines: 23
> | Organization: United Binary, LLC.
> | X-Priority: 3
> | X-MSMail-Priority: Normal
> | X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
> | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
> | Message-ID: <ujp$(E-Mail Removed)>
> | Newsgroups:
> microsoft.public.dotnet.framework.aspnet,microsoft .public.win2000.general
> | NNTP-Posting-Host: 130.191.240.187
> | Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP10.phx.gbl
> | Xref: cpmsftngxa06.phx.gbl microsoft.public.win2000.general:55001
> microsoft.public.dotnet.framework.aspnet:155514
> | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
> |
> | Hi Everyone,
> |
> | Last night we installed SP4 on our Windows 2000 Advanced Server which

was
> | are using as an ASP.NET web server (.NET 1.1). This morning we found out
> | that our ASP.NET applications that use impersonation. That is from the
> | web.config:
> |
> | <identity impersonate="true" userName="DOMAIN\USER" password="PASSWORD"

/>
> |
> | fail with the message "Access Denied: Failed to start monitoring
> | c:\inetpub\wwwroot\myapp\default.aspx for changes."
> |
> | This application worked fine before. Moreover, if I remove the
> impersonation
> | line from the web.config, everything is find again except of course

things
> | that required the impersonation fail.
> |
> | Does anyone know why this happens? Better yet, anyone know how to fix

it?
> |
> | Thanks in advance!
> | Michael
> |
> |
> |
> |
>
>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Impersonation fails after upgrade to .NET 1.1 Framework John W. ASP .Net Security 1 02-19-2004 03:54 PM
Impersonation fails after upgrade to .NET Framework 1.1 =?Utf-8?B?Sm9obiBXLg==?= ASP .Net 0 02-10-2004 07:31 PM
Re: ASP.NET problem after installing W2K SP4 Alex Kilpatrick ASP .Net 1 07-04-2003 03:06 AM
Re: ASP.NET Fails after SP4 with Impersonation Hidulf ASP .Net 1 06-30-2003 05:23 PM
Re: ASP.NET Fails after SP4 with Impersonation Raymond Basque ASP .Net 3 06-29-2003 05:18 PM



Advertisments