Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Windows 64bit > Slow loading ASP.NET application

Reply
Thread Tools

Slow loading ASP.NET application

 
 
Sanjay Pais
Guest
Posts: n/a
 
      01-14-2008
We are setting up our new environment with our hosting providers.
We have a Quad Core Windows 2003 Server with 12 GB RAM
We have a Load balancer with 2 web servers and a database server. The
website and the code are stored on a SAN.

The problem we are facing is that the app pool takes very long to load >
20sec
We have another dual core windows 2003 server where it loads in 5 secs. This
is
a 64bit database server at our current hosting provider.


we noticed that the ASP.NET Web site takes really long to load. When
comparing
it with load tests we did on our current server it loaded in under 5 secs.
To time the load, I recycle the application pool and launch the browser from
my desktop. I also tried launcing the website from the server after making
an
entry in the hosts file.


I have tried Process Mon, File Mon to try and identify why the application
is taking so long to load. but have not managed to get very far. We did try
and pull out the Enterprise Library assemblies and that did account for 10
secs.


I also tried moving the code to the local disk, as well as using a different
user
(administrative priveliges) etc.

I am running out of ideas and any suggestions are welcome.

Let me know if you need anymore information.

Cheers

Sanjay





 
Reply With Quote
 
 
 
 
Charlie Russel - MVP
Guest
Posts: n/a
 
      01-14-2008
Most of the folks here tend to focus on the desktop side of things, though
you may get an answer anyway. But I suspect you'd do better asking over on
an IIS newsgroup - this is less about 64bit, than it is about .NET.

--
Charlie.
http://msmvps.com/xperts64
http://mvp.support.microsoft.com/profile/charlie.russel


"Sanjay Pais" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> We are setting up our new environment with our hosting providers.
> We have a Quad Core Windows 2003 Server with 12 GB RAM
> We have a Load balancer with 2 web servers and a database server. The
> website and the code are stored on a SAN.
>
> The problem we are facing is that the app pool takes very long to load >
> 20sec
> We have another dual core windows 2003 server where it loads in 5 secs.
> This is
> a 64bit database server at our current hosting provider.
>
>
> we noticed that the ASP.NET Web site takes really long to load. When
> comparing
> it with load tests we did on our current server it loaded in under 5 secs.
> To time the load, I recycle the application pool and launch the browser
> from
> my desktop. I also tried launcing the website from the server after making
> an
> entry in the hosts file.
>
>
> I have tried Process Mon, File Mon to try and identify why the application
> is taking so long to load. but have not managed to get very far. We did
> try
> and pull out the Enterprise Library assemblies and that did account for 10
> secs.
>
>
> I also tried moving the code to the local disk, as well as using a
> different user
> (administrative priveliges) etc.
>
> I am running out of ideas and any suggestions are welcome.
>
> Let me know if you need anymore information.
>
> Cheers
>
> Sanjay
>
>
>
>
>


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Re: slow slow slow! Expert lino fitter Computer Support 5 12-12-2008 04:00 PM
Re: slow slow slow! General Patron Computer Support 0 12-11-2008 11:01 PM
Re: slow slow slow! chuckcar Computer Support 0 12-10-2008 11:25 PM
Re: slow slow slow! Beauregard T. Shagnasty Computer Support 2 12-10-2008 09:03 PM
Re: slow slow slow! Expert lino fitter Computer Support 0 12-10-2008 02:33 PM



Advertisments