Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > SMTP Error

Reply
Thread Tools

SMTP Error

 
 
Latha Rajeev
Guest
Posts: n/a
 
      06-26-2003
Hi,
I have an application which sends out mails(using CDO),
the SMTP Server being a machine which is one the same
network. Most times, the mails are sent out successfully
but every once in a while, the app reports the following
error:
"The message could not be sent to the SMTP server. The
transport error code was 0x800ccc0b. The server response
was not available.".
Also at times i get the following error:"The transport
lost its connection to the server."

Any idea why i keep getting these errors.?

I have a deadline approaching pretty fast, plz HELP...
 
Reply With Quote
 
 
 
 
Yan-Hong Huang[MSFT]
Guest
Posts: n/a
 
      06-27-2003
Hello Latha,

The error message "The transport error code was 0x800ccc0b. The server
response was not available."

Means: Server is busy.

If we use cdoSendUsingPort in CDOSYS to send mail rapidly, it may lock up
application.


The resolution is to use the default cdoSendUsingPickup directory, and
allow the local SMTP service to route the mail. cdoSendUsing pickup will
take up to 30 seconds to complete its communication with the mailserver per
mail connection. cdoSendUsingPickup, can put out mass mails because it only
creates a file I/O file into the local store.

I suggest you try this method to send out meail. For details, please check
out:
http://msdn.microsoft.com/library/en...mtp_mail_by_th
e_pickup_directory_using_cdosys_vbs.asp?frame=true

Hope it helps.

Best regards,
yhhuang
VS.NET, Visual C++
Microsoft

This posting is provided "AS IS" with no warranties, and confers no rights.
Got .Net? http://www.gotdotnet.com
--------------------
!Content-Class: urn:content-classes:message
!From: "Latha Rajeev" <(E-Mail Removed)>
!Sender: "Latha Rajeev" <(E-Mail Removed)>
!Subject: SMTP Error
!Date: Thu, 26 Jun 2003 01:13:18 -0700
!Lines: 15
!Message-ID: <09cc01c33bba$ccb53790$(E-Mail Removed)>
!MIME-Version: 1.0
!Content-Type: text/plain;
! charset="iso-8859-1"
!Content-Transfer-Encoding: 7bit
!X-Newsreader: Microsoft CDO for Windows 2000
!Thread-Index: AcM7usyyQ0tsfI/iRpWdS3vcb7R+zQ==
!X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4910.0300
!Newsgroups: microsoft.public.dotnet.framework.aspnet
!Path: cpmsftngxa06.phx.gbl
!Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:155031
!NNTP-Posting-Host: TK2MSFTNGXA11 10.40.1.163
!X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
!
!Hi,
!I have an application which sends out mails(using CDO),
!the SMTP Server being a machine which is one the same
!network. Most times, the mails are sent out successfully
!but every once in a while, the app reports the following
!error:
!"The message could not be sent to the SMTP server. The
!transport error code was 0x800ccc0b. The server response
!was not available.".
!Also at times i get the following error:"The transport
!lost its connection to the server."
!
!Any idea why i keep getting these errors.?
!
!I have a deadline approaching pretty fast, plz HELP...
!

 
Reply With Quote
 
 
 
 
Latha Rajeev
Guest
Posts: n/a
 
      06-27-2003

Hello Yan-Hong Huang,
Thanx for u'r suggestion. I will be trying this out as
soon as i can.


Latha



*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
 
Reply With Quote
 
Carlito Carlito is offline
Junior Member
Join Date: Jun 2007
Posts: 1
 
      06-07-2007
Hi Guys\Girls

It will be a good idea to talk to the infrastructure guys.

I had the same problem and it came down to SPAM control.

In my instance this same problem was caused by connection filtering that was enabled with multiple RBL lists.

As soon as i excluded the local subnet from the connection filtering everything started working again. One thing i do know is that in my instance this was working a month ago, thus obviously the RBL providers managed to restrict SMTP senders by obviouse ip subnet senders.

Hope it works

Carlito
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SMTP Relay from IIS SMTP Virtual Server tshad ASP .Net 1 05-05-2008 04:26 AM
Sending SMTP mail when SMTP server is unavailable matthewjbarr@gmail.com Java 3 01-24-2006 06:53 PM
smtplib.SMTP "no attributes SMTP" Copelandia Cyanescens Python 2 07-31-2004 07:24 PM
sending of mail (smtp) - connection refused - but smtp server isrunning! Alex Hunsley Python 4 06-29-2004 04:30 PM
RE: sending of mail (smtp) - connection refused - but smtp serveris running! Raaijmakers, Vincent \(GE Infrastructure\) Python 0 06-29-2004 02:38 PM



Advertisments