Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > NZ Computing > streaming media

Reply
Thread Tools

streaming media

 
 
Shane
Guest
Posts: n/a
 
      10-27-2005
Ive used a perl script (not my own work but from www.perlmonks.org) to
stream sound files from one of my machines to another one (cos I'm l33t
ow) but when I try to stream a movie file, I get the following error
(from mplayer)

Playing http://192.168.0.98:8000.
Connecting to server 192.168.0.98[192.168.0.98]:8000 ...
Cache size set to 320 KBytes
Connected to server: 192.168.0.98
Cache fill: 0.00% (0 bytes) ISO: File Type Major Brand: ISO/IEC 14496-1 (MPEG-4 system) v2
QuickTime/MOV file format detected.
Stream not seekable!
MOV: longest streams: A: #-1 (0 samples) V: #-1 (0 samples)
No stream found.


Exiting... (End of file)

FYI this is what happens playing sound files

Playing http://192.168.0.98:8000.
Connecting to server 192.168.0.98[192.168.0.98]:8000 ...
Cache size set to 320 KBytes
Connected to server: 192.168.0.98
Cache fill: 0.00% (0 bytes) Stream not seekable!
Audio file detected.
================================================== ========================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 44100 Hz, 2 ch, 16 bit (0x10), ratio: 20000->176400 (160.0 kbit)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
================================================== ========================
Checking audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 44100 hz, little endian signed int
AF_pre: 44100Hz 2ch Signed 16-bit (Little-Endian)
AO: [oss] 44100Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
Video: no video
Starting playback...




is mp4 just not streamable.. or am I missing something
TIA
--
Hardware, n.: The parts of a computer system that can be kicked

The best way to get the right answer on usenet is to post the wrong one.

 
Reply With Quote
 
 
 
 
Shane
Guest
Posts: n/a
 
      10-27-2005
addednum:
This is what happens when an .mpg file is streamed (success)

Playing http://192.168.0.98:8000.
Connecting to server 192.168.0.98[192.168.0.98]:8000 ...
Cache size set to 320 KBytes
Connected to server: 192.168.0.98
Cache fill: 0.00% (0 bytes) MPEG-PS file format detected.
VIDEO: MPEG1 320x240 (aspect 1) 25.000 fps 500.0 kbps (62.5 kbyte/s)
================================================== ========================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 32000 Hz, 2 ch, 16 bit (0x10), ratio: 16000->128000 (128.0 kbit)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
================================================== ========================
open: Permission denied
vo_mga: Couldn't open /dev/mga_vid
open: Permission denied
vo_mga: Couldn't open /dev/mga_vid
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
It seems there is no Xvideo support for your video card available.
Run 'xvinfo' to verify its Xv support and read DOCS/HTML/en/video.html#xv!
See 'mplayer -vo help' for other (non-xv) video out drivers. Try -vo x11
================================================== ========================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 320 x 240 (preferred csp: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
VDecoder init failed
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG 1 or 2 (libmpeg2))
================================================== ========================
Checking audio filter chain for 32000Hz/2ch/16bit -> 32000Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 32000 hz, little endian signed int
AF_pre: 32000Hz 2ch Signed 16-bit (Little-Endian)
AO: [oss] 32000Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 32000Hz/2ch/16bit -> 32000Hz/2ch/16bit...
Starting playback...
VDec: vo config request - 320 x 240 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [x11] 320x240 => 320x240 Planar YV12
SwScaler: using unscaled Planar YV12 -> BGRA special converter
New_Face failed. Maybe the font path is wrong. 2 ??% ??% ??,?% 1 0 58%
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.
A: 5.8 V: 5.7 A-V: 0.037 ct: 0.095 128/128 48% 26% 0.6% 16 0 43%



So its only .mp4 format thats causing issues

--
Hardware, n.: The parts of a computer system that can be kicked
The best way to get the right answer on usenet is to post the wrong one.
http://www.velocityreviews.com/forums/(E-Mail Removed)-a-geek.net <<-- need more spam


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
streaming media authentication. ashish ASP .Net 0 02-03-2005 03:48 PM
Streaming Audio with Windows Media Server Question? Raed Sawalha ASP .Net 0 10-07-2004 07:33 PM
A Media Streaming Question Kane Brolin Cisco 0 11-23-2003 03:30 AM
Streaming Media and NBAR BenH Cisco 0 11-18-2003 10:25 AM



Advertisments