Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > NZ Computing > Laptop Question

Reply
Thread Tools

Laptop Question

 
 
Rastus
Guest
Posts: n/a
 
      04-16-2005
Greetings all,

I have an Acer 512T laptop which is about 5 years old.
It's been going fine until the other day. I went to turn it on, it
made the usual startup noises which I assume are the fan and the hard
drive, nothing camp up on screen, then a few seconds later it just
turned off again. Battery is fully charged. Every time I turn the
power switch on, it does the same thing, winds up for a few seconds
then dies with the screen remaining blank. Can't even get far enough
to look at the bios settings. It just seems dead.

I realise this is a really long shot, but is there anyone technically
minded enough out there that is able to give some constructive
thoughts as to what sorts of things it could be.

Cheers and many thanks.
 
Reply With Quote
 
 
 
 
Me
Guest
Posts: n/a
 
      04-16-2005
On Sat, 16 Apr 2005 17:06:21 +1200, Rastus <(E-Mail Removed)>
wrote:

Does it attempt to mount the hard drive?
any does the HD LED show activity
can it boot to a floppy boot disk?

hmm, does sound rather terminal
 
Reply With Quote
 
 
 
 
EMB
Guest
Posts: n/a
 
      04-16-2005
Rastus wrote:
> Greetings all,
>
> I have an Acer 512T laptop which is about 5 years old.
> It's been going fine until the other day. I went to turn it on, it
> made the usual startup noises which I assume are the fan and the hard
> drive, nothing camp up on screen, then a few seconds later it just
> turned off again. Battery is fully charged. Every time I turn the
> power switch on, it does the same thing, winds up for a few seconds
> then dies with the screen remaining blank. Can't even get far enough
> to look at the bios settings. It just seems dead.
>
> I realise this is a really long shot, but is there anyone technically
> minded enough out there that is able to give some constructive
> thoughts as to what sorts of things it could be.
>
> Cheers and many thanks.


Try taking the battery out and doing it all again. If that doesn't work
have a google about getting into it's bios and see if anything's amiss
there.

--
EMB
 
Reply With Quote
 
AlexT
Guest
Posts: n/a
 
      04-16-2005
I am guessing here.



Sound like your external power source not function anymore.

So the battery try to power up but die again.



 
Reply With Quote
 
Martin Kaufmann
Guest
Posts: n/a
 
      04-17-2005
Rastus wrote:
> Greetings all,
>
> I have an Acer 512T laptop which is about 5 years old.
> It's been going fine until the other day. I went to turn it on, it
> made the usual startup noises which I assume are the fan and the hard
> drive, nothing camp up on screen, then a few seconds later it just
> turned off again. Battery is fully charged. Every time I turn the
> power switch on, it does the same thing, winds up for a few seconds
> then dies with the screen remaining blank. Can't even get far enough
> to look at the bios settings. It just seems dead.
>
> I realise this is a really long shot, but is there anyone technically
> minded enough out there that is able to give some constructive
> thoughts as to what sorts of things it could be.
>
> Cheers and many thanks.


I once had a similar problem with an Acer 507T. It turned out to be the
power supply. In my case I could sometimes run the computer for half an
hour before it died out of the blue. So I don't know whether you've got
the same issue.

Cheers,

Martin
 
Reply With Quote
 
Jerry
Guest
Posts: n/a
 
      04-17-2005
Rastus wrote:
> Greetings all,
>
> I have an Acer 512T laptop which is about 5 years old.
> It's been going fine until the other day. I went to turn it on, it
> made the usual startup noises which I assume are the fan and the hard
> drive, nothing camp up on screen, then a few seconds later it just
> turned off again. Battery is fully charged. Every time I turn the
> power switch on, it does the same thing, winds up for a few seconds
> then dies with the screen remaining blank. Can't even get far enough
> to look at the bios settings. It just seems dead.
>
> I realise this is a really long shot, but is there anyone technically
> minded enough out there that is able to give some constructive
> thoughts as to what sorts of things it could be.
>
> Cheers and many thanks.


I have a customer Compaq in with a similar problem, except that the
Windows start screen comes up before it quits. It is the power supply,
he replaced the original with a brand X with a lower amp rating than the
original.

If the battery is really charged, try it on just battery, no charger.
Then take the battery out and try it on just the charger. Try to borow
a charger somewhere to see if that fixes it. Good luck

Jerry
 
Reply With Quote
 
Dave - Dave.net.nz
Guest
Posts: n/a
 
      04-17-2005
Rastus wrote:
> I have an Acer 512T laptop which is about 5 years old.
> It's been going fine until the other day. I went to turn it on, it
> made the usual startup noises which I assume are the fan and the hard
> drive, nothing camp up on screen, then a few seconds later it just
> turned off again. Battery is fully charged. Every time I turn the
> power switch on, it does the same thing, winds up for a few seconds
> then dies with the screen remaining blank. Can't even get far enough
> to look at the bios settings. It just seems dead.


I have two suggestions for you.

first, take out all batteries(it might have more than one, you'll know
whether it does or not), and see if it powers up from mains alone... if
it does, wait until its finished loading the OS, and then biff the
batteries back in.

not sure what causes this, or even whats wrong, but it happens to some
of the dells and toshibashere at work.

The other potential problem is capacitor damage. a fried had this same
sort of problem happen to his laptop, and it turned out to be dead
capacitors on the motherboard, and because it was well out of warranty,
no way to fix it.
 
Reply With Quote
 
Rastus
Guest
Posts: n/a
 
      04-19-2005
On Mon, 18 Apr 2005 08:06:34 +1200, "Dave - Dave.net.nz"
<(E-Mail Removed)> wrote:

>Rastus wrote:
>> I have an Acer 512T laptop which is about 5 years old.
>> It's been going fine until the other day. I went to turn it on, it
>> made the usual startup noises which I assume are the fan and the hard
>> drive, nothing camp up on screen, then a few seconds later it just
>> turned off again. Battery is fully charged. Every time I turn the
>> power switch on, it does the same thing, winds up for a few seconds
>> then dies with the screen remaining blank. Can't even get far enough
>> to look at the bios settings. It just seems dead.

>
>I have two suggestions for you.
>
>first, take out all batteries(it might have more than one, you'll know
>whether it does or not), and see if it powers up from mains alone... if
>it does, wait until its finished loading the OS, and then biff the
>batteries back in.
>
>not sure what causes this, or even whats wrong, but it happens to some
>of the dells and toshibashere at work.
>
>The other potential problem is capacitor damage. a fried had this same
>sort of problem happen to his laptop, and it turned out to be dead
>capacitors on the motherboard, and because it was well out of warranty,
>no way to fix it.



I've tried it several ways. With the battery in and mains connected,
using the battery only and with the battery out and on mains. In all
cases the results are just the same.

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Laptop A -> Wireless Router -> Laptop B and Laptop C ??? rafael Wireless Networking 7 01-21-2008 02:10 AM
Desktop can see Laptop, but Laptop can't see Desktop! Plomaris Wireless Networking 3 02-17-2006 01:41 PM
WLAN: from Laptop to Laptop to router ...??? =?Utf-8?B?VGF6?= Wireless Networking 2 10-14-2005 05:40 PM
Desktop can't access Laptop but Laptop can access desktop =?Utf-8?B?Qmx1Y2FkZHk3MQ==?= Wireless Networking 2 11-23-2004 01:52 AM
Work Laptop (XP Pro in Domain) to Home Laptop (XPH WorkGroup) =?Utf-8?B?UGV0ZXIgQy4=?= Wireless Networking 1 10-22-2004 10:18 PM



Advertisments