Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > NZ Computing > IPV6, NAT-PT

Reply
Thread Tools

IPV6, NAT-PT

 
 
Philip D'Ath
Guest
Posts: n/a
 
      02-25-2005
I'm trying to get NAT-PT support working on a Cisco DSL router to
support native ipv6 clients behind it. I've done a lot of searching,
and can't find the answers to what I'm doing wrong. I have two problems.

First, I can't get them to grab additional parameters from DHCP. I'm using:

ipv6 dhcp pool dhcppool
dns-server ::210.55.12.1
- I know the above is not likely to answer AAAA requests,
but I plan to use DNS-ALG
domain-name local.arpa

Interface Ethernet0
ipv6 enable
ipv6 nd other-config-flag
ipv6 dhcp server dhcppool


The second problem is I can't NAT-PT to work at all. It doesn't even
attempt to do translations. Snippits I'm using are:

Interface Dialer0
description ipv4 Interface connecting to Internet
ipv6 nat

Interface Ethernet0
description ipv6 Interface connection to local lan (aka LINK-LOCAL)
ipv6 address 3FFE:AAAA:BBBB:1::9/64
- An address copied from an example, hope to use LINK-LOCAL
addresses later
ipv6 enable
ipv6 nat

ipv6 nat translation udp-timeout 600
ipv6 nat v6v4 source list pt-list1 interface Dialer0 overload
ipv6 nat prefix 3FFE:B00:1::/96
ipv6 access-list pt-list1
permit ipv6 3FFE:AAAA:BBBB:1::/64 any
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Advertisments