Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > Static Route Redistribution over OSPF.

Reply
Thread Tools

Static Route Redistribution over OSPF.

 
 
Dave Ward
Guest
Posts: n/a
 
      03-14-2006
Hi,

Is it possible to redistribute Classless IP range Static routes over
OSPF?

For example can I redistribute a static for IP range 10.135.64.0 /19
over OSPF, or will OSPF redistribute 10.0.0.0/8 instead?

many thanks

Dave
 
Reply With Quote
 
 
 
 
ciscodagama@gmail.com
Guest
Posts: n/a
 
      03-14-2006
To redistribute static routes to subnets of classful networks use
"redistribute static subnets" under the ospf router configuration.

Cisco da Gama
http://ciscostudy.blogspot.com

 
Reply With Quote
 
 
 
 
Dave Ward
Guest
Posts: n/a
 
      03-14-2006
Thanks!

On 14 Mar 2006 13:11:59 -0800, "(E-Mail Removed)"
<(E-Mail Removed)> wrote:

>To redistribute static routes to subnets of classful networks use
>"redistribute static subnets" under the ospf router configuration.
>
>Cisco da Gama
>http://ciscostudy.blogspot.com

 
Reply With Quote
 
CiscoHeadsetAdapter.com
Guest
Posts: n/a
 
      03-15-2006
"Dave Ward" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Thanks!
>
> On 14 Mar 2006 13:11:59 -0800, "(E-Mail Removed)"
> <(E-Mail Removed)> wrote:
>
>>To redistribute static routes to subnets of classful networks use
>>"redistribute static subnets" under the ospf router configuration.
>>
>>Cisco da Gama
>>http://ciscostudy.blogspot.com


Another shing you should look at - now you define your OSPF areas. This
command will redistribute the static route with subnetting information. Some
OSPF areas (for examle, NSSA) allow you to redistribute SUMMARY address only
(for exampe, you have 10.1.1.0/24, 10.100.0.0/16 and 10.0.0.0/8. OSPF may
send 10.0.0.0/8 only).

Good luck,

Mike
----
www.ciscoheadsetadapter.com


 
Reply With Quote
 
Adtran-ACES
Guest
Posts: n/a
 
      03-16-2006
Here is an expample:
router ospf 1
log-adjacency-changes
summary-address 172.16.0.0 255.255.0.0
network 10.10.102.0 0.0.0.3 area 1
network 10.10.104.0 0.0.0.3 area 1
network 10.10.105.0 0.0.0.3 area 1
network 10.10.106.0 0.0.0.3 area 1
network 10.10.107.0 0.0.0.3 area 1
network 10.10.108.0 0.0.0.3 area 1
network 10.10.109.0 0.0.0.3 area 1
network 10.10.110.0 0.0.0.3 area 1
network 10.10.188.0 0.0.0.3 area 1
network 10.10.0.0 0.0.255.255 area 1
network 172.16.103.0 0.0.0.255 area 1
network 172.16.0.0 0.0.255.255 area 1
default-information originate always
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.103.45
ip route 0.0.0.0 0.0.0.0 172.16.188.47 10
ip route 10.10.0.0 255.255.0.0 Null0
ip route 170.209.0.2 255.255.255.255 172.16.103.40
ip route 170.209.0.3 255.255.255.255 172.16.103.40
ip route 172.16.0.0 255.255.0.0 Null0

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbie route redistribution eigrp into bgp question Sean.Evershed@gmail.com Cisco 3 06-25-2009 10:18 AM
What is the default precedence: local-route, static-route,OSPF-route? ilan.berco@gmail.com Cisco 9 08-07-2008 05:42 PM
OSPF Cost Problem - Redistribution of Static Route cperf Cisco 0 06-11-2008 10:45 AM
Virtual Tunnel Interface Flapping - Route Redistribution: static->RIP->OSPF philbo30 Cisco 0 07-12-2007 06:44 PM
route redistribution RIP and EIGRP slipstream_242 Cisco 1 07-15-2004 11:21 PM



Advertisments