Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > UK VOIP > ASTERISK@HOME 2.7 AND VOIPBUSTER SETUP

Reply
Thread Tools

ASTERISK@HOME 2.7 AND VOIPBUSTER SETUP

 
 
phpguy
Guest
Posts: n/a
 
      12-30-2007
i got an asterisk@home 2.7 box setup with zap and voipbuster

the zap works and i set it up to dial using my landline and fxo card
when i dial 99= something it ommits the 99 and dials the rest

i want to set up the voipbuster trunk to do the same with 88 but for
some reason it wotn connect

i used the default settings im behiond a router and i put nat to yes
but nothing


what do i need to do ? all my phones are sip phones linksys spa 921

i can see from the flash panel its going through to trunk but nothing
happens then times out, i cant hear anytihng

i setted up asterisk as sip trunk not iax2


thanks in advance



OUTGOING SETTINGS

host=194.120.0.198
nat=1
secret=XXXXXX
type=peer
username=XXXXXXXX

//////////////////////////////////

INCOMING SETTINGS

context=from-pstn
secret=XXXXXXXXXXXXXXX
type=user


/////////////////////////////

REGISTRATION

XXXXX:XXXXXXXXXX@194.120.0.198

////////////////////////////////

SIP.CONF

; Note: If your SIP devices are behind a NAT and your Asterisk
; server isn't, try adding "nat=1" to each peer definition to
; solve translation problems.


[general]
port = 5060 ; Port to bind to (SIP is 5060)
bindaddr = 192.168.100.69 ; Address to bind to (all addresses on
machine)
disallow=all
allow=ulaw
allow=alaw
context = from-sip-external ; Send unknown SIP callers to this context
callerid = Unknown


#include sip_nat.conf
#include sip_custom.conf
#include sip_additional.conf


//////////////////////////////////////
 
Reply With Quote
 
 
 
 
voiptalker@gmail.com
Guest
Posts: n/a
 
      12-31-2007
On 30 Dec, 21:02, phpguy <(E-Mail Removed)> wrote:
> i got an asterisk@home 2.7 box setup with zap and voipbuster
>
> the zap works and i set it up to dial using my landline and fxo card
> when i dial 99= something it ommits the 99 and dials the rest
>
> i want to set up the voipbuster trunk to do the same with 88 but for
> some reason it wotn connect


I'm assuming you've set the dial rules in *both* the trunk *and* the
corresponding outbound route.


my settings in AAH2.7 were as follows:

SIP TRUNK: Voipbuster
/////////////////////////////////
Outgoing dial rules: (for UK + International - Note my UK outbound
route was 0|[1278]XXXXXXXXX and 0044|.)

0044+1XXXXXXXXX
0044+2XXXXXXXXX
0044+7XXXXXXXXX
0044+8XXXXXXXXX
00.
/////////////////////////////////
Outgoing Settings
/////////////////////////////////
Trunk name: voipbuster
----------------------
Peer Details:
allow=ulaw&alaw
canreinvite=yes
disallow=all
fromdomain=voipbuster.com
fromuser=USERNAME
host=sip.voipbuster.com
insecure=very
nat=yes
qualify=1000
secret=PASSWORD
srvlookup=yes
type=friend
username=USERNAME

///////////////////////////////////
Incoming details:
USER details: empty

///////////////////////////////////
Register string:

USERNAME(E-Mail Removed)

//////////////////////////////////////
If you have a voip-in number, this would look a little different - but
that's another issue.
Also, if you have more than 2 voipbuster accounts on your AAH box,
you'll need to delete the line: qualify=1000

 
Reply With Quote
 
 
 
 
Hongtian
Guest
Posts: n/a
 
      12-31-2007
On 31 Dec, 04:02, phpguy <(E-Mail Removed)> wrote:
> i got an asterisk@home 2.7 box setup with zap and voipbuster
>
> the zap works and i set it up to dial using my landline and fxo card
> when i dial 99= something it ommits the 99 and dials the rest
>
> i want to set up the voipbuster trunk to do the same with 88 but for
> some reason it wotn connect
>
> i used the default settings im behiond a router and i put nat to yes
> but nothing
>
> what do i need to do ? all my phones are sip phones linksys spa 921
>
> i can see from the flash panel its going through to trunk but nothing
> happens then times out, i cant hear anytihng
>
> i setted up asterisk as sip trunk not iax2
>
> thanks in advance
>
> OUTGOING SETTINGS
>
> host=194.120.0.198
> nat=1
> secret=XXXXXX
> type=peer
> username=XXXXXXXX
>
> //////////////////////////////////
>
> INCOMING SETTINGS
>
> context=from-pstn
> secret=XXXXXXXXXXXXXXX
> type=user
>
> /////////////////////////////
>
> REGISTRATION
>
> XXXXX:XXXXXXX...@194.120.0.198
>
> ////////////////////////////////
>
> SIP.CONF
>
> ; Note: If your SIP devices are behind a NAT and your Asterisk
> ; server isn't, try adding "nat=1" to each peer definition to
> ; solve translation problems.
>
> [general]
> port = 5060 ; Port to bind to (SIP is 5060)
> bindaddr = 192.168.100.69 ; Address to bind to (all addresses on
> machine)
> disallow=all
> allow=ulaw
> allow=alaw
> context = from-sip-external ; Send unknown SIP callers to this context
> callerid = Unknown
>
> #include sip_nat.conf
> #include sip_custom.conf
> #include sip_additional.conf
>
> //////////////////////////////////////


It is terrible. I would like to suggest you try miniSipServer. It is
very easy to use.
 
Reply With Quote
 
Jono
Guest
Posts: n/a
 
      12-31-2007
Hongtian pretended :
> It is terrible. I would like to suggest you try miniSipServer. It is
> very easy to use.


Not that I can comment on miniSipServer, however, AAH 2.7 is far from
terrible.

I have been using that version since it came out....until yesterday.

The OP could & should consider using PBX-in-a-Flash (which I set up
yesterday)

<http://nerdvittles.com/index.php?p=196>

<http://www.pbxinaflash.org/index.htm>


 
Reply With Quote
 
voiptalker@gmail.com
Guest
Posts: n/a
 
      12-31-2007
On Dec 31, 12:28*pm, Jono <(E-Mail Removed)> wrote:
> Hongtian pretended :
>
> > It is terrible. I would like to suggest you try miniSipServer. It is
> > very easy to use.

>
> Not that I can comment on miniSipServer, however, AAH 2.7 is far from
> terrible.


Agreed.

> I have been using that version since it came out....until yesterday.
>
> The OP could & should consider using PBX-in-a-Flash (which I set up
> yesterday)
>
> <http://nerdvittles.com/index.php?p=196>
>
> <http://www.pbxinaflash.org/index.htm>


And those settings above also work in PBX-in-a-Flash B-)
 
Reply With Quote
 
phpguy
Guest
Posts: n/a
 
      01-03-2008
hello there i tried that but it says all circuits are busy now and
voipbuster truck is greyed out in the flash operator panel, any idea
why this happens ? cheers



On 31 Dec 2007, 11:18, (E-Mail Removed) wrote:
> On 30 Dec, 21:02, phpguy <(E-Mail Removed)> wrote:
>
> > i got an asterisk@home 2.7 box setup with zap and voipbuster

>
> > the zap works and i set it up to dial using my landline and fxo card
> > when i dial 99= something it ommits the 99 and dials the rest

>
> > i want to set up the voipbuster trunk to do the same with 88 but for
> > some reason it wotn connect

>
> I'm assuming you've set the dial rules in *both* the trunk *and* the
> corresponding outbound route.
>
> my settings in AAH2.7 were as follows:
>
> SIP TRUNK: Voipbuster
> /////////////////////////////////
> Outgoing dial rules: (for UK + International - Note my UK outbound
> route was 0|[1278]XXXXXXXXX and 0044|.)
>
> 0044+1XXXXXXXXX
> 0044+2XXXXXXXXX
> 0044+7XXXXXXXXX
> 0044+8XXXXXXXXX
> 00.
> /////////////////////////////////
> Outgoing Settings
> /////////////////////////////////
> Trunk name: voipbuster
> ----------------------
> Peer Details:
> allow=ulaw&alaw
> canreinvite=yes
> disallow=all
> fromdomain=voipbuster.com
> fromuser=USERNAME
> host=sip.voipbuster.com
> insecure=very
> nat=yes
> qualify=1000
> secret=PASSWORD
> srvlookup=yes
> type=friend
> username=USERNAME
>
> ///////////////////////////////////
> Incoming details:
> USER details: empty
>
> ///////////////////////////////////
> Register string:
>
> USERNAME(E-Mail Removed)
>
> //////////////////////////////////////
> If you have a voip-in number, this would look a little different - but
> that's another issue.
> Also, if you have more than 2 voipbuster accounts on your AAH box,
> you'll need to delete the line: qualify=1000



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
VoIPBuster and double DTMF tones Sparks UK VOIP 5 06-15-2005 08:56 AM
Re: VoIPBuster and 18866 VOIP?? David Floyd UK VOIP 7 06-10-2005 01:15 PM
ATA-486 and VoIPBuster David Floyd UK VOIP 5 06-08-2005 07:24 AM
VoIPBuster and softphone "Call failed: 486 busy here" Al UK VOIP 3 06-07-2005 11:09 AM
Grandstream ATA and VoIPBuster David Floyd UK VOIP 14 05-28-2005 11:38 PM



Advertisments