Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Windows 64bit > OpenGL problems with XP64

Reply
Thread Tools

OpenGL problems with XP64

 
 
Zootal
Guest
Posts: n/a
 
      12-07-2007
I have a clean installation of XP64, and I am having problems with Opengl
apps. The first indication that there was a problem was when I realized
Doom3 would not run. So then I tried some programs I wrote myself that use
the opengl api, and they likewise don't work. Are there known issues with
OpenGL on XP64?

AMD Phenom quad core cpu, 4GB ram, XP64 clean install.


 
Reply With Quote
 
 
 
 
Allan
Guest
Posts: n/a
 
      12-08-2007

"Zootal" <(E-Mail Removed)> wrote in message
news:%(E-Mail Removed)...
>I have a clean installation of XP64, and I am having problems with Opengl
>apps. The first indication that there was a problem was when I realized
>Doom3 would not run. So then I tried some programs I wrote myself that use
>the opengl api, and they likewise don't work. Are there known issues with
>OpenGL on XP64?
>
> AMD Phenom quad core cpu, 4GB ram, XP64 clean install.
>

You may need the x86 version of Java not the AMD 64 version for Opengl to
run. I have only one Opengl app but it runs under the x86 version on Windows
XP Home.

 
Reply With Quote
 
 
 
 
Zootal
Guest
Posts: n/a
 
      12-08-2007

"Allan" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
>
> "Zootal" <(E-Mail Removed)> wrote in message
> news:%(E-Mail Removed)...
>>I have a clean installation of XP64, and I am having problems with Opengl
>>apps. The first indication that there was a problem was when I realized
>>Doom3 would not run. So then I tried some programs I wrote myself that use
>>the opengl api, and they likewise don't work. Are there known issues with
>>OpenGL on XP64?
>>
>> AMD Phenom quad core cpu, 4GB ram, XP64 clean install.
>>

> You may need the x86 version of Java not the AMD 64 version for Opengl to
> run. I have only one Opengl app but it runs under the x86 version on
> Windows XP Home.


Java? What does that have to do with OpenGL?

I did get it to work - I have to disable one of my video cards and reboot.
Then it works. With two cards active, it won't work for some strange reason.


 
Reply With Quote
 
Allan
Guest
Posts: n/a
 
      12-08-2007

"Zootal" <(E-Mail Removed)> wrote in message
news:%(E-Mail Removed)...
>
> "Allan" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
>>
>> "Zootal" <(E-Mail Removed)> wrote in message
>> news:%(E-Mail Removed)...
>>>I have a clean installation of XP64, and I am having problems with Opengl
>>>apps. The first indication that there was a problem was when I realized
>>>Doom3 would not run. So then I tried some programs I wrote myself that
>>>use the opengl api, and they likewise don't work. Are there known issues
>>>with OpenGL on XP64?
>>>
>>> AMD Phenom quad core cpu, 4GB ram, XP64 clean install.
>>>

>> You may need the x86 version of Java not the AMD 64 version for Opengl to
>> run. I have only one Opengl app but it runs under the x86 version on
>> Windows XP Home.

>
> Java? What does that have to do with OpenGL?
>
> I did get it to work - I have to disable one of my video cards and reboot.
> Then it works. With two cards active, it won't work for some strange
> reason.
>

The one application I had was a Java app and so I wrongly assumed that
Opengl run under Java only. Sorry for my error. I am glad you got it to work
after all.

 
Reply With Quote
 
Carlos
Guest
Posts: n/a
 
      12-08-2007
Zootal,
Have you checked the videocards manufacturer's forums?
This seems more like a problem in the SLI (or crossfire) and driver
combination.
Carlos

"Zootal" wrote:

>
> "Allan" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
> >
> > "Zootal" <(E-Mail Removed)> wrote in message
> > news:%(E-Mail Removed)...
> >>I have a clean installation of XP64, and I am having problems with Opengl
> >>apps. The first indication that there was a problem was when I realized
> >>Doom3 would not run. So then I tried some programs I wrote myself that use
> >>the opengl api, and they likewise don't work. Are there known issues with
> >>OpenGL on XP64?
> >>
> >> AMD Phenom quad core cpu, 4GB ram, XP64 clean install.
> >>

> > You may need the x86 version of Java not the AMD 64 version for Opengl to
> > run. I have only one Opengl app but it runs under the x86 version on
> > Windows XP Home.

>
> Java? What does that have to do with OpenGL?
>
> I did get it to work - I have to disable one of my video cards and reboot.
> Then it works. With two cards active, it won't work for some strange reason.
>
>
>

 
Reply With Quote
 
Zootal
Guest
Posts: n/a
 
      12-08-2007

>>> You may need the x86 version of Java not the AMD 64 version for Opengl
>>> to
>>> run. I have only one Opengl app but it runs under the x86 version on
>>> Windows XP Home.

>>
>> Java? What does that have to do with OpenGL?
>>
>> I did get it to work - I have to disable one of my video cards and
>> reboot. Then it works. With two cards active, it won't work for some
>> strange reason.
>>

> The one application I had was a Java app and so I wrongly assumed that
> Opengl run under Java only. Sorry for my error. I am glad you got it to
> work after all.


OK, that makes sense. OpenGL outside of the Microsoft world is quite
popular, and there are some Windows apps that use it as well. There is a new
version of OpenGL due out early next year, and I'm curious to see how it
does next to DirectX. If Microsoft doesn't make DirectX 10 work with XP, it
probably won't take of like they would like it to. Vista-only games are not
going to be a huge success.

</soapbox>


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems using ruby and opengl Ciph3rzer0 Ruby 7 04-22-2009 10:50 PM
xp64 trial version & xp64 beta version install =?Utf-8?B?TWF0dGhldyBXZWJzdGVy?= Windows 64bit 7 01-08-2006 01:29 AM
Problems installing XP64 danny Windows 64bit 4 05-25-2005 06:17 PM
Help with Trial XP64 Problems Richard G Carruthers Windows 64bit 6 05-25-2005 01:53 PM
OEM xp64 v. Trial xp64 ? Soma11 Windows 64bit 4 05-22-2005 08:00 PM



Advertisments